Solved SLiM: Failed to execute login command (ambiguous package message)

grahamperrin

Daemon

Reaction score: 648
Messages: 2,087

slim display manager says "Failed to execute login command" is Solved but what's there is not the answer here. The user is already a member of the video group.

dbus is running.

FreeBSD 13.0-RELEASE, not yet updated.

Beyond an update to the OS: what next?

From <https://www.freshports.org/x11/slim/#message>:

Code:
Thanks to Nikos Ntarmos, it is now possible to start slim from /etc/ttys.
Please see /usr/local/etc/rc.d/slim for instructions on how to do that.

Alternatively, just put the following entry in /etc/rc.conf:

slim_enable=yes

slim requires a dbus session bus to connect to. Add the following entry in
/etc/rc.conf:

dbus_enable="YES"

*** Option "sessions" is no longer supported. ***

Now you need to put session files in the directory specified by option
"sessiondir". They should be xdg-style .desktop files.

WARNING: the default behaviour in parsing .xinitrc file has changed!
         You can now set a default xsession as described here:
         https://github.com/iwamatsu/slim/pull/1
         You can turn back to random xsession selection by compiling
         this port without the option XDEFAULT.

Before I installed SLiM, SDDM was installed.
 

Aeterna

Member

Reaction score: 30
Messages: 99

slim display manager says "Failed to execute login command" is Solved but what's there is not the answer here. The user is already a member of the video group.

dbus is running.

FreeBSD 13.0-RELEASE, not yet updated.

Beyond an update to the OS: what next?

From <https://www.freshports.org/x11/slim/#message>:

Code:
Thanks to Nikos Ntarmos, it is now possible to start slim from /etc/ttys.
Please see /usr/local/etc/rc.d/slim for instructions on how to do that.

Alternatively, just put the following entry in /etc/rc.conf:

slim_enable=yes

slim requires a dbus session bus to connect to. Add the following entry in
/etc/rc.conf:

dbus_enable="YES"

*** Option "sessions" is no longer supported. ***

Now you need to put session files in the directory specified by option
"sessiondir". They should be xdg-style .desktop files.

WARNING: the default behaviour in parsing .xinitrc file has changed!
         You can now set a default xsession as described here:
         https://github.com/iwamatsu/slim/pull/1
         You can turn back to random xsession selection by compiling
         this port without the option XDEFAULT.

Before I installed SLiM, SDDM was installed.
for slim to work you need to
1) install slim themes
2) edit /usr/local/etc/slim.conf
and change line
current_theme default
to
current_theme fbsd
 

Aeterna

Member

Reaction score: 30
Messages: 99

no, with slim all works when swithing from tty8/GUI to ttyX and back
 
OP
grahamperrin

grahamperrin

Daemon

Reaction score: 648
Messages: 2,087

… all works when swithing from tty8/GUI to ttyX and back

Not working here, see below.

Where SLiM does not work out of the box, which alternative would you recommend?

I prefer SDDM, but you ask me to use an alternative to SDDM.
1624851590180.png

1624851624872.png

1624851651491.png
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 12,266
Messages: 38,773

On the logon screen hit F1 and switch to a working desktop environment.
 

sko

Aspiring Daemon

Reaction score: 391
Messages: 701

Where SLiM does not work out of the box, which alternative would you recommend?

It worked for me out of the box on several systems with XFCE4.

Slim complains about the login command - so what *did* you set as a login command in slim.conf?
Usually it tries to execute the ~/.xinitrc; if so, what did you put in that file?

for slim to work you need to
1) install slim themes
2) edit /usr/local/etc/slim.conf
and change line
current_theme default
to
current_theme fbsd
I've never installed themes or changed that option in slim.conf; on all my systems there is still "default" set.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 12,266
Messages: 38,773

I have this in my ~/.xinitrc:
Code:
[ -f "${HOME}/.Xresources" ] && xrdb "${HOME}/.Xresources"

[ -n "$1" ] && [ -x "$1" ] && exec "$1"
SLiM is working out of the box. The only thing I change in slim.conf is the theme, nothing else.
 

Vull

Aspiring Daemon

Reaction score: 431
Messages: 725

Not working here, see below.

Where SLiM does not work out of the box, which alternative would you recommend?

I prefer SDDM, but you ask me to use an alternative to SDDM.
I've been using lightdm to start plasma5-plasma without problems, on 13.0-RELEASE, for the last month or two. Both are obtained from quarterly packages. I have not however attempted to start it using service lightdm onestart from a root shell command prompt, I just put lightdm_enable="YES" in /etc/rc.conf and reboot.
 
OP
grahamperrin

grahamperrin

Daemon

Reaction score: 648
Messages: 2,087

… what *did* you set as a login command in slim.conf? …

Nothing, I made only the theme-related changes that were suggested by Aeterna

~/.xinitrc

Did not exist for the affected user.
The package message mentioned a method of parsing the file, but did not express a requirement for the file to exist.

Solved; thank you.

Someone might like to raise a bug for an improvement to the package message.
 

CuatroTorres

Member
Developer

Reaction score: 38
Messages: 83

It will probably depend on the skin chosen, see the sample at the bottom. You can also run shutdown and reboot commands inside the login box in Simple Login Manager.
Off-topic: it's a component without maintenance, I would go for LightDM.
 
OP
grahamperrin

grahamperrin

Daemon

Reaction score: 648
Messages: 2,087

OP
grahamperrin

grahamperrin

Daemon

Reaction score: 648
Messages: 2,087

Oops!

PS for clarity: whilst the login issue was solved, I do still have (off topic) the switching issue; the blackness.

Maybe a cure for the blackness affecting SDDM (without switching) will also cure the blackness affecting SLiM (with switching).
 
Top