Solved Skype Mysteriously Started Working ... Except

Geezer

Aspiring Daemon

Reaction score: 381
Messages: 671

I have never had skype in chrome working for video calls, only ever messaging. Until I tried it last night.
And it works. Mysteriously. I have not changed anything, except upgrading packages. Everything works ... except the microphone.

I have got zoom to work, with video, sound and microphone. But in skype, I can see, be seen and hear. But I could really do with the microphone.

I have tried with the internal camera, and a plug in USB camera. Both work for video only.

Getting skype up and running would be the last step for me to drop my old windows box off a cliff.

Do you know how to get the microphone working in skype in chrome? Thank you.
 

shurik

Member

Reaction score: 7
Messages: 24

I have tried to make a call and:
- web-page crashes after few minutes of call.
- no sound at all
+ camera works
 

shkhln

Daemon

Reaction score: 970
Messages: 2,224

Chrome or Chromium? Single input/output audio device or two separate devices?
 
OP
Geezer

Geezer

Aspiring Daemon

Reaction score: 381
Messages: 671

Chrome or Chromium? Single input/output audio device or two separate devices?
Chromium.

cat /dev/sndstat
FreeBSD Audio Driver (64bit 2009061500/amd64) Installed devices: pcm0: <Intel Broadwell (HDMI/DP 8ch)> on hdaa0 (1p:3v/0r:0v) default snddev flags=0x2e7<SIMPLEX,AUTOVCHAN,SOFTPCMVOL,BUSY,MPSAFE,REGISTERED,VPC> [pcm0:play:dsp0.p0]: spd 48000, fmt 0x00200010, flags 0x00006100, 0x00000004 interrupts 62018, underruns 0, feed 62018, ready 0 [b:2048/1024/2|bs:2048/1024/2] channel flags=0x6100<BUSY,HAS_VCHAN,VCHAN_PASSTHROUGH> {userland} -> feeder_mixer(0x00200010) -> {hardware} pcm0:play:dsp0.p0[pcm0:virtual:dsp0.vp0]: spd 22050/48000, fmt 0x00200002/0x00200010, flags 0x10000000, 0x0000002b interrupts 0, underruns 0, feed 0, ready 0 [b:0/0/0|bs:2048/256/8] channel flags=0x10000000<VIRTUAL> {userland} -> feeder_root(0x00200002) -> feeder_format(0x00200002 -> 0x00200010) -> feeder_volume(0x00200010) -> feeder_rate(0x00200010 q:1 22050 -> 48000) -> {hardware} pcm0:play:dsp0.p0[pcm0:virtual:dsp0.vp1]: spd 48000, fmt 0x00200010, flags 0x10000000, 0x00000021 interrupts 0, underruns 0, feed 0, ready 0 [b:0/0/0|bs:8192/1024/8] channel flags=0x10000000<VIRTUAL> {userland} -> feeder_root(0x00200010) -> feeder_volume(0x00200010) -> {hardware} pcm0:play:dsp0.p0[pcm0:virtual:dsp0.vp2]: spd 48000, fmt 0x00100010/0x00200010, flags 0x10000000, 0x00000061 interrupts 0, underruns 0, feed 0, ready 0 [b:0/0/0|bs:4096/512/8] channel flags=0x10000000<VIRTUAL> {userland} -> feeder_root(0x00100010) -> feeder_matrix(1.0 -> 2.0) -> feeder_volume(0x00200010) -> {hardware} pcm1: <Realtek ALC236 (Analog 2.0+HP/2.0)> on hdaa1 (1p:5v/1r:2v) snddev flags=0x300002e2<AUTOVCHAN,BUSY,MPSAFE,REGISTERED,VPC,PRIO_RD,PRIO_WR> [pcm1:play:dsp1.p0]: spd 48000, fmt 0x00200010, flags 0x00002108, 0x00000004 interrupts 19876084, underruns 0, feed 19876084, ready 0 [b:2048/1024/2|bs:2048/1024/2] channel flags=0x2108<TRIGGERED,BUSY,HAS_VCHAN> {userland} -> feeder_mixer(0x00200010) -> {hardware} pcm1:play:dsp1.p0[pcm1:virtual:dsp1.vp0]: spd 44100/48000, fmt 0x00200010, flags 0x100011c8, 0x00000029, pid 1650 (pulseaudio) interrupts 0, underruns 0, feed 21013385, ready 15560 [b:0/0/0|bs:16384/4096/4] channel flags=0x100011c8<TRIGGERED,NBIO,MMAP,BUSY,HAS_SIZE,VIRTUAL> {userland} -> feeder_root(0x00200010) -> feeder_volume(0x00200010) -> feeder_rate(0x00200010 q:1 44100 -> 48000) -> {hardware} pcm1:play:dsp1.p0[pcm1:virtual:dsp1.vp1]: spd 48000, fmt 0x00200010, flags 0x10000000, 0x00000021 interrupts 0, underruns 0, feed 0, ready 0 [b:0/0/0|bs:8192/1024/8] channel flags=0x10000000<VIRTUAL> {userland} -> feeder_root(0x00200010) -> feeder_volume(0x00200010) -> {hardware} pcm1:play:dsp1.p0[pcm1:virtual:dsp1.vp2]: spd 48000, fmt 0x00200010, flags 0x10000000, 0x00000021 interrupts 0, underruns 0, feed 0, ready 0 [b:0/0/0|bs:8192/1024/8] channel flags=0x10000000<VIRTUAL> {userland} -> feeder_root(0x00200010) -> feeder_volume(0x00200010) -> {hardware} pcm1:play:dsp1.p0[pcm1:virtual:dsp1.vp3]: spd 48000, fmt 0x00200010, flags 0x10000000, 0x00000021 interrupts 0, underruns 0, feed 0, ready 0 [b:0/0/0|bs:8192/1024/8] channel flags=0x10000000<VIRTUAL> {userland} -> feeder_root(0x00200010) -> feeder_volume(0x00200010) -> {hardware} pcm1:play:dsp1.p0[pcm1:virtual:dsp1.vp4]: spd 48000, fmt 0x00200010, flags 0x10000000, 0x00000021 interrupts 0, underruns 0, feed 0, ready 0 [b:0/0/0|bs:8192/1024/8] channel flags=0x10000000<VIRTUAL> {userland} -> feeder_root(0x00200010) -> feeder_volume(0x00200010) -> {hardware} [pcm1:record:dsp1.r0]: spd 48000, fmt 0x00200010, flags 0x00002100, 0x00000005 interrupts 72055388, overruns 0, feed 144110762, hfree 512, sfree 511 [b:512/256/2|bs:512/256/2] channel flags=0x2100<BUSY,HAS_VCHAN> {hardware} -> feeder_root(0x00200010) -> feeder_mixer(0x00200010) -> {userland} pcm1:record:dsp1.r0[pcm1:virtual:dsp1.vr0]: spd 44100/48000, fmt 0x00200010, flags 0x100011d0, 0x00000029, pid 1650 (pulseaudio) interrupts 0, overruns 0, feed 269972506, hfree 0, sfree 16384 [b:0/0/0|bs:16384/4096/4] channel flags=0x100011d0<NOTRIGGER,NBIO,MMAP,BUSY,HAS_SIZE,VIRTUAL> {hardware} -> feeder_root(0x00200010) -> feeder_rate(0x00200010 q:1 48000 -> 44100) -> feeder_volume(0x00200010) -> {userland} pcm1:record:dsp1.r0[pcm1:virtual:dsp1.vr1]: spd 48000, fmt 0x00200010, flags 0x10000000, 0x00000021 interrupts 0, overruns 0, feed 0, hfree 0, sfree 32768 [b:0/0/0|bs:32768/256/128] channel flags=0x10000000<VIRTUAL> {hardware} -> feeder_root(0x00200010) -> feeder_volume(0x00200010) -> {userland} pcm2: <Realtek ALC236 (Right Analog Mic)> on hdaa1 (0p:0v/1r:2v) snddev flags=0x2e3<SIMPLEX,AUTOVCHAN,BUSY,MPSAFE,REGISTERED,VPC> [pcm2:record:dsp2.r0]: spd 48000, fmt 0x00200010, flags 0x00002100, 0x00000005 interrupts 72055394, overruns 0, feed 144110783, hfree 512, sfree 512 [b:512/256/2|bs:512/256/2] channel flags=0x2100<BUSY,HAS_VCHAN> {hardware} -> feeder_root(0x00200010) -> feeder_mixer(0x00200010) -> {userland} pcm2:record:dsp2.r0[pcm2:virtual:dsp2.vr0]: spd 44100/48000, fmt 0x00200010, flags 0x10000000, 0x00000029 interrupts 0, overruns 0, feed 0, hfree 0, sfree 32768 [b:0/0/0|bs:32768/256/128] channel flags=0x10000000<VIRTUAL> {hardware} -> feeder_root(0x00200010) -> feeder_rate(0x00200010 q:1 48000 -> 44100) -> feeder_volume(0x00200010) -> {userland} pcm2:record:dsp2.r0[pcm2:virtual:dsp2.vr1]: spd 48000, fmt 0x00200010, flags 0x10000000, 0x00000021 interrupts 0, overruns 0, feed 0, hfree 0, sfree 32768 [b:0/0/0|bs:32768/256/128] channel flags=0x10000000<VIRTUAL> {hardware} -> feeder_root(0x00200010) -> feeder_volume(0x00200010) -> {userland} No devices installed from userspace.

And with another webcam plugged in:
pcm3: <USB audio> at ? kld snd_uaudio (0p:0v/1r:1v) snddev flags=0x2e3<SIMPLEX,AUTOVCHAN,BUSY,MPSAFE,REGISTERED,VPC> [pcm3:record:dsp3.r0]: spd 48000, fmt 0x00200010/0x00100010, flags 0x00002100, 0x00000045 interrupts 0, overruns 0, feed 0, hfree 1536, sfree 4096 [b:1536/768/2|bs:4096/2048/2] channel flags=0x2100<BUSY,HAS_VCHAN> {hardware} -> feeder_root(0x00100010) -> feeder_matrix(1.0 -> 2.0) -> feeder_mixer(0x00200010) -> {userland} pcm3:record:dsp3.r0[pcm3:virtual:dsp3.vr0]: spd 8000, fmt 0x00100008, flags 0x10000000, 0x00000000 interrupts 0, overruns 0, feed 0, hfree 0, sfree 0 [b:0/0/0|bs:0/0/0] channel flags=0x10000000<VIRTUAL> {hardware} -> feeder_root(0x00000000) -> {userland}
 
OP
Geezer

Geezer

Aspiring Daemon

Reaction score: 381
Messages: 671

Mixer vol is currently set to 100:100 Mixer pcm is currently set to 100:100 Mixer speaker is currently set to 100:100 Mixer rec is currently set to 0:0 Mixer ogain is currently set to 100:100 Mixer monitor is currently set to 67:67 Recording source: monitor
 
OP
Geezer

Geezer

Aspiring Daemon

Reaction score: 381
Messages: 671

Just set rec to 100. I will see if that makes a difference.
 
OP
Geezer

Geezer

Aspiring Daemon

Reaction score: 381
Messages: 671

Too much gain. Set at 25 and it works wonders.
 
Top