Solved Silencing beeping internal computer speaker

Preetpal

Active Member

Thanks: 27
Messages: 118

#1
Is there a way to disable the internal computer speaker (Desktop PC) from beeping during normal use? I am using XFCE4 and when I use the right arrow keys once I've reached the rightmost location in certain applications, it makes the computer's internal speaker beep (which is annoying). I would prefer to disable the internal computer speaker usage altogether in FreeBSD.
 
OP
OP
P

Preetpal

Active Member

Thanks: 27
Messages: 118

#2
I managed to discover how to do this with the command sysctl -a | grep bell. It yielded two relevant settings.
  • kern.vt.enable_bell: 1
  • hw.syscons.bell: 1
I changed these settings as illustrated by the following terminal session:

Code:
# sysctl kern.vt.enable_bell=0
kern.vt.enable_bell: 1 -> 0
# sysctl hw.syscons.bell=0
hw.syscons.bell: 1 -> 0
#
This stopped the beeping.
 
OP
OP
P

Preetpal

Active Member

Thanks: 27
Messages: 118

#3
To make the changes persistent, I added the following lines to /etc/sysctl.conf.

YAML:
# Disable annoying internal computer speaker beeping
kern.vt.enable_bell=0
hw.syscons.bell=0
 
Top