Shutdown on initial install of FreeBSD 12.1 STABLE on sun7i-a20-bananapi

bigbohemia

New Member


Messages: 1

I'm trying to install FreeBSD ARM to run on Banana Pi M1. The model that I am using is included at the following link:


I have tried various images and variations of the startup script, but I am mainly focusing on the image at the link below and using the commands following:


The computer seems to be able to boot U-Boot, and eventually I think it passes the execution to the kernel, but once the kernel tries to load, the computer halts and turns off.

I have tried booting U-Boot manually, by pressing space at the first pause, which says "Hit any key to stop autoboot:" and entering the following commands at the prompts:

=> load mmc 0:1 0x43000000 dtb/sun7i-a20-bananapi.dtb
=> load mmc 0:1 0x42000000 ubldr.bin
=> bootm 0x42000000 - 0x43000000

I have not been able to successfully get FreeBSD to load on my Banana Pi. Has anyone been able to successfully install this or any other recently supported version of FreeBSD onto the Banana Pi M1? Are there any changes to my booting procedure that I should try?
 
Top