Setting password to protect beastie boot menu

driesm

Active Member
Developer

Reaction score: 55
Messages: 129

Whenever I try to set a password in loader.conf in terms of password="test" my system does not autoboot nor does it show the beastie boot menu. From the manual pages:

password Protect boot menu with a password without interrupting autoboot process. The password should be in clear text format. If a password is set, boot menu will not appear until any key is pressed during countdown period specified by autoboot_delay variable or autoboot process fails. In both cases user should provide specified password to be able to access boot menu.

Am I doing something wrong or am I just completely misinterpreting the setting of password="test" in loader.conf. I also added the errror message I get when the system tries to autoboot after a password has been set. When I execute show password it says the password is set to test. Furthermore, when I enter the command boot the system boots perfectly without any hickups. It just doesn't do so automatically. My loader.conf contents are simply: password="test". Also, when I remove the variable of password="test" in loader.conf my system does autoboot and shows the beastie boot menu.

Thanks in Advance
 

Attachments

  • error.PNG
    error.PNG
    30.6 KB · Views: 420

ABV

New Member


Messages: 7

It's possible that this is a bug. For me, setting bootlock_password works correctly, but I encounter the same problem you do when I set just password. I don't think you're misinterpreting it all.
 
OP
driesm

driesm

Active Member
Developer

Reaction score: 55
Messages: 129

Hey there, thank you for your reply. Your loader.conf variable does work. However this is not what I was looking for. Setting this variable prevents autoboot and the password is required to boot. I'd like to only have a password on the boot menu. I think that this might be a bug aswell for it clearly states in the manual what it should do but it doesn't ;D!
 

RichardM

Member

Reaction score: 20
Messages: 49

I remember this feature stopped working a few years ago, I think when going from FreeBSD 9.1 to 9.2. The syntax is (was) correct - password="******" in /boot/loader/conf.
 

Beastie

Daemon

Reaction score: 548
Messages: 2,275

No one bothers fixing it probably because it's not a very useful feature? This protects you from unauthorized access just as much as a BIOS password or FreeBSD login/password (that is, not very much).

Anyway, the forums are not the proper place to report bugs. Check Bugzilla for anything relevant and file a bug report there.
 
Top