ZFS setting nfs share in /etc/exports on zfs doesn't work.

Hi
I have added the following line into /etc/exports :
Code:
/vol/server/storage1_vol00 -maproot=root -alldirs
/vol/server/storage1_vol01 -maproot=root -alldirs
and the zfs sharenfs is set to off on both filesystem.

However, after I have restarted nfsd, the volumes still not mountable with error message permission denied.

May I know what is the recommend setting to enable nfs share in /etc/exports without turning on the nfsshare on zfs?

I prefer to use NFS version 3.

Thanks.
 
Last edited by a moderator:
Please show output of grep 'nfs|rpc|mountd' /etc/rc.conf
My server has the following parameters in /etc/rc.conf

Code:
# NFS
nfsv4_server_enable="YES"
rpcbind_enable="YES"
nfs_server_enable="YES"
nfs_server_flags="-u -t -n 16"
mountd_flags="-r"
rpc_lockd_enable="YES"
rpc_statd_enable="YES"
 
Back
Top