Solved sddm not starting on boot and failing when started manually

clawhammer

Active Member

Reaction score: 6
Messages: 182

when I type service sddm onestart it says it is already running. but all i get is the console. I have my user set to wheel and video.

im running freebsd 12.0 release. graphics card drivers loaded and works correctly.
 

roccobaroccoSC

Aspiring Daemon

Reaction score: 209
Messages: 718

You also need to install dbus, otherwise graphics will not start.

Code:
pkg install dbus

# To start automatically with graphics:
sysrc dbus_enable=YES
sysrc sddm_enable=YES

service dbus start
service sddm start
 
OP
clawhammer

clawhammer

Active Member

Reaction score: 6
Messages: 182

You also need to install dbus, otherwise graphics will not start.

Code:
pkg install dbus

# To start automatically with graphics:
sysrc dbus_enable=YES
sysrc sddm_enable=YES

service dbus start
service sddm start

so dbus isnt automatically on the system? i added it to rc.conf already.
 

Geezer

Aspiring Daemon

Reaction score: 374
Messages: 660

Also, are you sure you have X installed correctly?
 
OP
clawhammer

clawhammer

Active Member

Reaction score: 6
Messages: 182

Also, are you sure you have X installed correctly?
i did pkg install xorg.

is there a way to test if it is installed correctly?

when i type startx I get xauth: file /home/bob/.serverauth.4861 does not exist.
 
OP
clawhammer

clawhammer

Active Member

Reaction score: 6
Messages: 182

Also, are you sure you have X installed correctly?
Code:
drmn0: successfully loaded firmware image with name: amdgpu/polaris10_mc.bin

it recognizes all the vram and that it's ddr5.

pciconf -lv
Code:
vgapci0@pci0:1:0:1:

device = 'Ellesmere [Radeon RX 470/480/570/580/590]'
class = display

xorg log file says

Code:
failed to load module "amdgpu" (module does not exist, 0)
no drivers available.
 

Geezer

Aspiring Daemon

Reaction score: 374
Messages: 660

i did pkg install xorg.

is there a way to test if it is installed correctly?

when i type startx I get xauth: file /home/bob/.serverauth.4861 does not exist.

Yes, does it start X or not? If not, then sddm won't work.

Try the simplest command, Xorg -retro
Does that even work?

If not, try scfb in a simple xorg.conf (if you boot use EFI).

And if you want to use the Radeon, install i915, lots of stuff in this forum about it.
 

roccobaroccoSC

Aspiring Daemon

Reaction score: 209
Messages: 718

so dbus isnt automatically on the system? i added it to rc.conf already.
Alas, no. FreeBSD is very flexible but you have to tell it exactly what to do. That's why it's vital to follow a good handbook or tutorial. On Linux I have had the same issues by the way.
You do need to install dbus separately and only installing Xorg won't help. Also, your graphics drivers need to be set up properly - independently from Xorg, but you already have that running.

Do install and enable dbus, then make sure it is running:
sudo ps aux | grep dbus
If you see the daemon processes, go ahead and start your sddm.
 

roccobaroccoSC

Aspiring Daemon

Reaction score: 209
Messages: 718

drmn0: successfully loaded firmware image with name: amdgpu/polaris10_mc.bin

it recognizes all the vram and that its ddr5.

pciconf -lv
vgapci0@pci0:1:0:1: device = 'Ellesmere [Radeon RX 470/480/570/580/590]' class = display

xorg log file says

failed to load module "amdgpu" (module does not exist, 0) no drivers available.
Oh, you have Polaris. Me too.
I have had issues getting it to run. I think when you boot in UEFI mode the driver has a conflict with the console and prevents starting graphics. The workaround is to set hw.syscons.disable=1 in /boot/loader.conf. See if you have this set at your side.
Here is the thread where I shared my experience (although the info is a bit older, so keep this in mind).
 
OP
clawhammer

clawhammer

Active Member

Reaction score: 6
Messages: 182

Oh, you have Polaris. Me too.
I have had issues getting it to run. I think when you boot in UEFI mode the driver has a conflict with the console and prevents starting graphics. The workaround is to set hw.syscons.disable=1 in /boot/loader.conf. See if you have this set at your side.
Here is the thread where I shared my experience (although the info is a bit older, so keep this in mind).
i never got kde working. I installed gnome3 and it worked. I had the framerate disabled like you said but that didnt get sddm to load kde.
 

roccobaroccoSC

Aspiring Daemon

Reaction score: 209
Messages: 718

The desktop has nothing to do with the video driver. If you're able to start Gnome, KDE should not be a problem. You probably missed a step when installing and configuring it.
A common mistake I did often was to forget enabling the dbus service. This prevents display managers like sddm and slim from loading properly.

By the way, when you have gnome already, nothing stops you from installing also KDE on top. You can still use gdm but on login, select "KDE plasma session" instead of "Gnome session".
 
OP
clawhammer

clawhammer

Active Member

Reaction score: 6
Messages: 182

The desktop has nothing to do with the video driver. If you're able to start Gnome, KDE should not be a problem. You probably missed a step when installing and configuring it.
A common mistake I did often was to forget enabling the dbus service. This prevents display managers like sddm and slim from loading properly.

By the way, when you have gnome already, nothing stops you from installing also KDE on top. You can still use gdm but on login, select "KDE plasma session" instead of "Gnome session".
it will automatically give both options?
 

roccobaroccoSC

Aspiring Daemon

Reaction score: 209
Messages: 718

Yes, when you log in you can select which session to start: Gnome, KDE, or you can even have dozens of others - just google what desktop environments are available for Xorg.
 

Zirias

Son of Beastie

Reaction score: 1,507
Messages: 2,627

So your problem is completely different than the one that was discussed here two years(!) ago.

Create a new thread and describe your problem more detailed (what exactly did you try, what did you expect, what happened, include error output if appropriate…), then it's quite likely someone is able to help.
 

Geezer

Aspiring Daemon

Reaction score: 374
Messages: 660

My problem is every thing boots on the sddm but dose't recognize user name or password.
Tried going as single user, it boots to root, but can't write to correct anything in file.

Are you discussing this in two different threads? Not helpful.
 

Zirias

Son of Beastie

Reaction score: 1,507
Messages: 2,627

Are you discussing this in two different threads? Not helpful.
It doesn't belong here and I guess the new thread was created in response to me stating that. So let's just leave this thread here alone ;)
 

Zirias

Son of Beastie

Reaction score: 1,507
Messages: 2,627

where is the right place to post? I'll get to it, Thanks
In a new thread, cause it's most likely a different problem than the one discussed here. One new thread, not multiple (you already opened two). The correct subforum would be KDE, cause sddm belongs to KDE. And, as I already told you, please be more specific and detailed about your problem.
 
Top