Other sddm login manager loops over

Using Qtile ( git version ) and sddm.
As per Qtile documentation - i have qtile.desktop file linked to .xsession file which is identical to .xinitrc file and also tried custom .xsession file from qtile examples - but i have same issue - It starts, i enter my password - but loops back to login menu where i have to add my password and again back to login but if i disable sddm - startx works just fine.
 
It means you have an error in your configuration. The login worked, but the failed session sends it back to the display manager.

Check ~/.xsession-errors or another log. An executable permission for group to .xsession may need to be added. .xsession needs this permission, which is optional on .xinitrc. If they're linked together, keep the executive permission for both files. It could alternatively have to do with a relevant sddm file.
 
I have the same issue after I upgraded to Freebsd 13.2, I had to recreate Xauthority file which seems to have fixed the error with the logs on Xorg regarding the .servauth not found message.
 
It means you have an error in your configuration. The login worked, but the failed session sends it back to the display manager.

Check ~/.xsession-errors or another log. An executable permission for group to .xsession may need to be added. .xsession needs this permission, which is optional on .xinitrc. If they're linked together, keep the executive permission for both files. It could alternatively have to do with a relevant sddm file.
I dont have .xsession-errors file.
Checking today what i can do.
I have the same issue after I upgraded to Freebsd 13.2, I had to recreate Xauthority file which seems to have fixed the error with the logs on Xorg regarding the .servauth not found message.
Recreate ? Just delete it right ?
I had some issues with xauth as it was not found, but installed this xauth issue dissapeared but still same issue.
 
i actually deleted Xauthority , recreated new .xsession file, made it executable - still not able to log in. still need to get xsession-errors file going as i cant find one and dont know how to create one but googling the isssue.
 
Can you see hidden files in your home directory? ls -al | grep xsession. There may be other xsession files. You've probably already seen then, so the problem may be in /var/log/Xorg.0.log or some SDDL produced file.

I've found ArchWiki to be good with software, which is also used on FreeBSD, even if it's meant for Linux, https://wiki.archlinux.org/title/SDDM . I've used Arch Linux's documentation before when there was a lack of documentation for programs elsewhere.

XDM isn't bad as an SDDM alternative, once you get used to it, https://forums.freebsd.org/threads/howto-light-desktop-setup-2018-update.64623/. The basic setup has a lot to be desired, but its appearance can be improved.

From looking at the description of SDDL, it also can be used with Wayland. XDM couldn't do that, the last time I checked. It may be good to figure out getting SDDL to work, especially for the long run.
 
Can you post your Xorg.0.log file? You can look at some hints there.
Its all clean, checked. I have to enable sddm again to see what is what but im still strugling to getting .xsession-error log file and dont know how to create it but in my understanding it should create if there is a problem.
Now im trying to play around with qtile.desktop file and actual xsession file as i have a feeling that my qtile.desktop file is incorrect.
Ive attached my qtile.desktop and .xsession and .xinitrc files.
i do experiment with qtile.desktop file i might rename it as custom.desktop instead of qtile.desktop.
But what i noted - i have another xinitrc.desktop file but i removed it before.
Later i will upload Xorg log file once i enable sddm.
 

Attachments

  • .xsession.txt
    180 bytes · Views: 74
  • qtile.desktop.txt
    156 bytes · Views: 69
  • .xinitrc.txt
    657 bytes · Views: 69
Why are you trying to install a heavy login manager like x11/sddm when x11/lightDM is a better alternative? Also your .desktop files is incorrect.
eg.
Code:
[Desktop Entry]
Name=Qtile
Comment=Qtile Session
Exec=/usr/local/bin/qtile
Type=Application
Keywords=wm;tiling
When using a login manager there is no need for .xinitrc file.
Install x11/lightDM & x11/lightdm-gtk-greeter, echo lightdm_enable="YES" >> /etc/rc.conf and reboot. #QED.
 
My qtile.desktop sends to xsession and xsession starts qtile.
As per Qtile documentation: If you're using an X session manager, you still may need to create a custom.desktop file similar to the qtile.desktop file above, but with Exec=/etc/X11/xsession. Then, create your own ~/.xsession. so i adjusted Exec command with FreeBSD location of xsession.
But i will try lightDM.
Yes, i dont need .xinitrc with Login Manager i posted as i had .xsession file exact to .xinitrc file. There are few ways to have .xsession thats why i have it.
 
Back
Top