Solved SDDM config location

SAJM

Active Member

Reaction score: 12
Messages: 138

Im attempting to run KDE, SDDM will not load and brings up errors. Whilst trying to sort it out I went to:

SDDM.CONF(5) sddm SDDM.CONF(5)

NAME
sddm.conf - sddm display manager configuration

SYNOPSIS
Configuration loads all files in the configuration directories followed
by the configuration file in the order listed below with the latter
having the most precedent. Changes should be made to the local configu-
rations.

/usr/local/lib/sddm/sddm.conf.d
System configuration directory

/usr/local/etc/sddm.conf.d
Local configuration directory

/usr/local/etc/sddm.conf
Local configuration file for compatibility

My install does not have any sddm directories or configs as listed above.

Where else may they be hiding?
 

Zirias

Son of Beastie

Reaction score: 1,587
Messages: 2,718

/usr/local/etc/sddm.conf is correct (plus /usr/local/etc/sddm.conf.d/ for partial configs).

But, you won't find anything there unless you create it yourself. sddm doesn't need any config to run. So, if it doesn't work for you, you probably have a different problem (maybe with the X server?)

Describe what exactly goes wrong please.
 
OP
S

SAJM

Active Member

Reaction score: 12
Messages: 138

2 things happen.

1. After reboot after log in:
Code:
$sddm
[16:27:35.650] (II) DAEMON: Initializing...
[16:27:35.656] (II) DAEMON: Starting...
[16:27:35.663] (II) DAEMON: No session manager found
[16:27:35.663] (II) DAEMON: Adding new display on vt 9
[16:27:35.664] (II) DAEMON: Loading theme configuration from ""
[16:27:35.664] (II) DAEMON: Display server starting...
[16:27:35.664] (II) DAEMON: Adding cookie to "/var/run/sddm/{ hex string }"
/usr/local/bin/xauth/:  timeout in locking authority file /var/run/sddm/{ hex string }
[16:27:55.308] (EE) DAEMON: Failed to write Xauth file
[16:27:55.304] (EE) DAEMON: could not start display server on vt 9
CNTL C to break out back to prompt
2. Subsequently:

$sddm
/usr/local/bin/xauth: (stdin)  :1: bad display name ":0" in "remove" command
/usr/local/bin/xauth: (stdin)  :2: bad display name ":0" in "bad" command
CNTL C to break out back to prompt
 
OP
S

SAJM

Active Member

Reaction score: 12
Messages: 138

The PC in question developed a hardware fault so this install is now in the bin!
 

Zirias

Son of Beastie

Reaction score: 1,587
Messages: 2,718

Don't try to run sddm as root. Add sddm_enable="YES" to /etc/rc.conf and start it with service sddm start.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 12,361
Messages: 38,898

First things first, does Xorg actually work? Start the machine, login as a user and run startx. If that works then enable SDDM. But you need to verify and make sure X actually works before moving on to the next step. It will be pointless to enable SDDM if your Xorg isn't working correctly. It's like building a house, you build your foundations and walls first before you put the roof on it.
 

cybersans

New Member

Reaction score: 1
Messages: 13

Don't try to run sddm as root. Add sddm_enable="YES" to /etc/rc.conf and start it with service sddm start.
every pages i visited will said this.

but what if i want to make it happen? i read every single documentations on the net, the only tutorial i get is a plasma with linux. none with bsd.

i make an empty sddm.conf inside /usr/local/etc and put the minimumuid= line

reboot.
also doesn't work. why the developer make it so hard to the "root login lover"? thats why until now i still ruyn kde4 because of the kdmrc config file.
 

Zirias

Son of Beastie

Reaction score: 1,587
Messages: 2,718

but what if i want to make it happen?
[…]
why the developer make it so hard to the "root login lover"?
Cause you're aiming at your foot and the systems tries to avoid pulling the trigger?

You'd run literally *tons* of code as root, and every single bug could destroy your whole system (or it could be compromised if you use network applications). Just don't do it. Create an unprivileged account.
 
Top