Screen turn off after startx?

Hello everyone!

I recently installed FreeBSD 11.0 for the first time and now I'm trying to set my DE. I successfully installed X.Org and Xfce. After I configured properly my .xinitrc adding this line
Code:
exec /usr/local/bin/startxfce4
. After rebooting, I got some error messages when I issued startx, all of them related with vesa driver. So I tried installing the xf86-intel-video driver, and got a better font rendering on my screen (system terminal). After rebooting again, and issuing startx, my screen virtually turned off! NO video at all, none of the virtual terminals. At this point, I humbly ask for your help.

This is my /var/log/Xorg.0.log: https://pastebin.com/wubKprpZ.

Edit: I forgot to mention that at the beginning (just before installing Xfce and the xf86-intel-video driver) I tried i3wm and I was able to startx successfully, however, applications like Firefox didn't work.
 
i had the same problem Someone broke xorg pkg just missing some files. Upgrade freebsd, portstree and reinstall xorg from ports. I was install from DVD.

make reinstall clean batch=yes from x11/xorg folder and go to sleep...

After that add your username into /etc/group VIDEO
 
Someone broke xorg pkg just missing some files. Upgrade freebsd, portstree and reinstall xorg from ports.
This sounds like a very long process. I don't understand, I didn't mess up with the configuration of X.Org, I just followed the handbook to install it, and this is pretty straightforward. The user that I created belongs to the wheel group, isn't that enough to have video?
 
Did You install FreeBSD from memstick? Can You show, photo, Your /etc/pkg/FreeBSD.conf?

On the new compilation of pkg requed is add user to video group. Handbook is old. Did You tried to reinstall Xorg from ports, before that upgrade system? Use pw() or ee /etc/group find video and add your username.

1. freebsd-update fetch
2. freebsd-update install
3. portsnap fetch
4. portsnap extract
5. [B]cd /usr/ports/x11/xorg[/B]
6. make install clean BATCH="YES" - batch If defined, only operate on a port if it can be installed 100% automatically. Without "enter" all the time.
7. ee /etc/group
8. video:*:44:YOUR_USERNAME
 
Did You install FreeBSD from memstick? Can You show, photo, Your /etc/pkg/FreeBSD.conf?
Hello, I attach to this message the picture of the file /etc/pkg/FreeBSD.conf (sorry for the quality). Unfortunately, I did all your suggested steps and that didn't work: screen turns off again. I updated the system, reinstalled X.Org via ports, added my user to the video group, and still no luck.
 

Attachments

  • FreeBSDconf.jpg
    FreeBSDconf.jpg
    715.4 KB · Views: 477
What kind of hardware does the machine have? Specifically the video card and the exact model of the CPU/GPU.
 
What kind of hardware does the machine have? Specifically the video card and the exact model of the CPU/GPU.
This is my video card:
Code:
VGA compatible controller: Intel Corporation 82Q35 Express Integrated Graphics Controller (rev 02)
And my CPU:
Code:
Architecture:          x86_64
CPU op-mode(s):        32-bit, 64-bit
Byte Order:            Little Endian
CPU(s):                2
On-line CPU(s) list:   0,1
Thread(s) per core:    1
Core(s) per socket:    2
Socket(s):             1
NUMA node(s):          1
Vendor ID:             GenuineIntel
CPU family:            6
Model:                 15
Model name:            Intel(R) Core(TM)2 Duo CPU     E4600  @ 2.40GHz
Stepping:              13
CPU MHz:               1200.000
CPU max MHz:           2400.0000
CPU min MHz:           1200.0000
BogoMIPS:              4789.54
L1d cache:             32K
L1i cache:             32K
L2 cache:              2048K
NUMA node0 CPU(s):     0,1
Flags:                 fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc arch_perfmon pebs bts rep_good nopl aperfmperf pni dtes64 monitor ds_cpl est tm2 ssse3 cx16 xtpr pdcm lahf_lm dtherm
 
Xorg doesn't use HAL anymore. It's using devd(8) by default now.

Panadestein can you post a recent Xorg.0.log? Did you create a xorg.conf? Did you add frequencies to the Monitor section? I'm thinking it may try to open a screen with too high frequencies and the monitor switches off in order to protect itself.
 
did You have hald_enable="YES" and dbus_enable="YES" set into /etc/rc.conf?
I have dbus_enable="YES" in my /etc/rc.conf but not hald_enable="YES", however:
Xorg doesn't use HAL anymore. It's using devd(8) by default now.

This is my /etc/rc.conf:
Code:
dbus_enable="YES"
hostname="panadestein"
create_args_wlan0="country FR"
sshd_enable="YES"
moused_enable="YES"
ntpd_enable="YES"
powerd_enable="YES"
# Set dumpdev to "AUTO" to enable crash dumps, "NO" to disable
dumpdev="AUTO"
#ifconfig_ue0="DHCP"
#wlans_urtwn0="wlan0"
#ifconfig_wlan0="WPA SYNCDHCP"
 
Panadestein can you post a recent Xorg.0.log? Did you create a xorg.conf? Did you add frequencies to the Monitor section? I'm thinking it may try to open a screen with too high frequencies and the monitor switches off in order to protect itself.
The log that I posted at the beginning was created the first time the problem appeared, this is the last log Xorg.0.log.

I didn't create a xorg.conf, because I thought it was automatically created...
 
Android...

Edit: I forgot to mention that at the beginning (just before installing Xfce and the xf86-intel-video driver) I tried i3wm and I was able to startx successfully, however, applications like Firefox didn't work.

Can You strat Xorg withount any Windo Manager and run from console firefox, and paste here respond.
 
Can You strat Xorg withount any Windo Manager and run from console firefox, and paste here respond.
No, just tried. Impossible to startx in any way, same result: screen turns off and have to reboot because mouse and keyboard are useless.

Impossible as a normal user and as root.
 
But first time only Xorg start normally write?
Yes, the first time (after install X.Org and i3wm) I could get into the i3wm session, but as I commented, some applications were misbehaving (or not starting at all), then I installed the other driver and Xfce4 (also tried to remove xf86-intel-video-vesa but I couldn't because it wanted to remove the hole X.Org) and that started the problem.
 
If it the fresh installation of FreeBSD Can You reinstall system, upgrade them, upgrade package using pkg update -f and install only Xorg again : pkg install x11/xorg
 
When Xorg startet, You can see something it isnt Driver prioblem. Is library or something.
I know it should be something related with the vesa driver, because in Arch Linux I had exactly the same issue (not screen turned off, but X not starting), when I purged vesa it was fixed.
 
FreeBSD is not Linux. Before change driver to VESA Xorg start normally, I don't know what You are exactly do and what messages was printing into console when You tried to run FF, so i suggested reinstall system and install it stedy, once again.

PS. Did You do that?
Code:
To set the VESA driver in a configuration file:
https://www.freebsd.org/doc/handbook/x-config.html
point 5.3
 
Last edited:
Back
Top