SATA drives show in BIOS but won't show in /dev

I have looked for a code bounty website but they seem to be out of favor at the moment.

If I were to attempt fixing this, what would be a good strategy?

Would compiling the kernel get me anything in this case or is this a lot more than just fixing some compiler variable-type warnings?
 
Out of curisoity, does a recent version of lets say Arch Linux (you can liveboot from the USB image) initialize your SATA controller correctly?
Also, if you reboot into FreeBSD (non cold boot) does it still fail to get detected?
You might also want to try turning on SATA Hot Plug
 
thank you very much diizzy for the suggestion.

In Arch 2023.08.01-x86_64 it has me choose Arch then wait for it to load in RAM. After that I got single user mode and /dev listed sda and sdb drives. hdparm -iI /dev/sd(a|b) confirmed these are my SATA drives. So it would appear that Arch works great with my board.

Turning on hot swap did not add any drives to dev. I still have sr-iov on and PCI Configuration\Above 4G Decoding (best guess to Plug and Play OS) off from my last try. Otherwise my bios is default.
 
I apologize for the delay. My fault.
SR-IOV is now off and /boot/loader.conf has the line added:
hw.pci.enable_io_modes=0

/dev/diskid, gpart show and gpart list only show my current nvme drive with four partitions. No ada or dada drives listed.

my dmesg still shows the same. head to first error:

Code:
Copyright (c) 1992-2021 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
        The Regents of the University of California. All rights reserved.
FreeBSD is a registered trademark of The FreeBSD Foundation.
FreeBSD 13.2-RELEASE-p2 GENERIC amd64
FreeBSD clang version 14.0.5 (https://github.com/llvm/llvm-project.git llvmorg-14.0.5-0-gc12386ae247c)
VT(efifb): resolution 800x600
CPU: AMD Ryzen 9 7950X 16-Core Processor             (4491.66-MHz K8-class CPU)
  Origin="AuthenticAMD"  Id=0xa60f12  Family=0x19  Model=0x61  Stepping=2
  Features=0x178bfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,MMX,FXSR,SSE,SSE2,HTT>
  Features2=0x7ef8320b<SSE3,PCLMULQDQ,MON,SSSE3,FMA,CX16,SSE4.1,SSE4.2,x2APIC,MOVBE,POPCNT,AESNI,XSAVE,OSXSAVE,AVX,F16C,RDRAND>
  AMD Features=0x2e500800<SYSCALL,NX,MMX+,FFXSR,Page1GB,RDTSCP,LM>
  AMD Features2=0x75c237ff<LAHF,CMP,SVM,ExtAPIC,CR8,ABM,SSE4A,MAS,Prefetch,OSVW,IBS,SKINIT,WDT,TCE,Topology,PCXC,PNXC,DBE,PL2I,MWAITX,ADMSKX>
  Structured Extended Features=0xf1bf97a9<FSGSBASE,BMI1,AVX2,SMEP,BMI2,ERMS,INVPCID,PQM,PQE,AVX512F,AVX512DQ,RDSEED,ADX,SMAP,AVX512IFMA,CLFLUSHOPT,CLWB,AVX512CD,SHA,AVX512BW,AVX512VL>
  Structured Extended Features2=0x405fde<AVX512VBMI,UMIP,PKU,OSPKE,AVX512VBMI2,GFNI,VAES,VPCLMULQDQ,AVX512VNNI,AVX512BITALG,AVX512VPOPCNTDQ,RDPID>
  Structured Extended Features3=0x10000010<FSRM,L1DFL>
  XSAVE Features=0xf<XSAVEOPT,XSAVEC,XINUSE,XSAVES>
  AMD Extended Feature Extensions ID EBX=0x791ef257<CLZERO,IRPerf,XSaveErPtr,RDPRU,WBNOINVD,IBPB,IBRS,STIBP,STIBP_ALWAYSON,PREFER_IBRS,SSBD>
  SVM: NP,NRIP,VClean,AFlush,DAssist,NAsids=32768
  TSC: P-state invariant, performance statistics
real memory  = 68717379584 (65534 MB)
avail memory = 65878507520 (62826 MB)
Event timer "LAPIC" quality 600
ACPI APIC Table: <ALASKA A M I >
FreeBSD/SMP: Multiprocessor System Detected: 32 CPUs
FreeBSD/SMP: 1 package(s) x 2 cache groups x 8 core(s) x 2 hardware threads
random: registering fast source Intel Secure Key RNG
random: fast provider: "Intel Secure Key RNG"
random: unblocking device.
ioapic0 <Version 2.1> irqs 0-23
ioapic1 <Version 2.1> irqs 24-55
Launching APs: 21 20 23 1 28 17 30 26 25 19 3 6 10 9 13 5 15 8 12 11 4 2 7 14 24 27 16 18 29 31 22
random: entropy device external interface
kbd0 at kbdmux0
efirtc0: <EFI Realtime Clock>
efirtc0: registered as a time-of-day clock, resolution 1.000000s
smbios0: <System Management BIOS> at iomem 0x794d8000-0x794d801e
smbios0: Version: 3.4, BCD Revision: 3.4
aesni0: <AES-CBC,AES-CCM,AES-GCM,AES-ICM,AES-XTS,SHA1,SHA256>
acpi0: <ALASKA A M I >
Firmware Error (ACPI): Failure creating named object [\134_SB.PCI0.GPP0._PRW], AE_ALREADY_EXISTS (20201113/dswload2-480)
ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20201113/psobject-372)
Firmware Error (ACPI): Failure creating named object [\134_SB.PCI0.GPP2._PRW], AE_ALREADY_EXISTS (20201113/dswload2-480)
ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20201113/psobject-372)
Firmware Error (ACPI): Failure creating named object [\134_GPE._L08], AE_ALREADY_EXISTS (20201113/dswload2-480)
ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20201113/psobject-372)


also later in the dmesg:
...
Code:
pcib2: <ACPI PCI-PCI bridge> at device 2.1 on pci0
pcib2: failed to allocate initial memory window: 0xfc000000-0xfc8fffff
pci2: <ACPI PCI bus> on pcib2
pcib3: <ACPI PCI-PCI bridge> at device 0.0 on pci2
pcib3: failed to allocate initial memory window: 0xfc000000-0xfc8fffff
pci3: <ACPI PCI bus> on pcib3
...
 
I really like this setup but I hesitate to buy more boards, even its siblings, because i need the sata ports to work.

If someone could point me to any information on who or where work gets done on hardware compatibility under FreeBSD I would appreciate it. Knowing who or even how it happens might help me figure out how to help in an effective way. I am aware of the hardware notes page

Would compiling the kernel get me anything in this case or is this a lot more than just fixing some compiler variable-type warnings?
 
There are several success stories with Asus boards including the one I have but I think you're better off getting a simple ASM1166 card (works great in my RockPro64) or such rather than getting another motherboard. There's something odd with the initialization of the controller unfortunately I'm not a kernel developer so I can't help you much. I can however share dmesg from my board for comparison. Asus ProArt X670E Creator https://www.asus.com/motherboards-components/motherboards/proart/proart-x670e-creator-wifi/

Code:
---<<BOOT>>---
Copyright (c) 1992-2023 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
        The Regents of the University of California. All rights reserved.
FreeBSD is a registered trademark of The FreeBSD Foundation.
FreeBSD 14.0-ALPHA2 amd64 1400094 #0: Sat Aug 19 20:58:08 CEST 2023
    diizzy@miyuki.pyret.net:/usr/obj/usr/src/amd64.amd64/sys/MIYUKI amd64
FreeBSD clang version 16.0.6 (https://github.com/llvm/llvm-project.git llvmorg-16.0.6-0-g7cbf1a259152)
VT(vga): resolution 640x480
CPU: AMD Ryzen 9 7900 12-Core Processor              (3693.14-MHz K8-class CPU)
  Origin="AuthenticAMD"  Id=0xa60f12  Family=0x19  Model=0x61  Stepping=2
  Features=0x178bfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,MMX,FXSR,SSE,SSE2,HTT>
  Features2=0x7ef8320b<SSE3,PCLMULQDQ,MON,SSSE3,FMA,CX16,SSE4.1,SSE4.2,x2APIC,MOVBE,POPCNT,AESNI,XSAVE,OSXSAVE,AVX,F16C,RDRAND>
  AMD Features=0x2e500800<SYSCALL,NX,MMX+,FFXSR,Page1GB,RDTSCP,LM>
  AMD Features2=0x75c237ff<LAHF,CMP,SVM,ExtAPIC,CR8,ABM,SSE4A,MAS,Prefetch,OSVW,IBS,SKINIT,WDT,TCE,Topology,PCXC,PNXC,DBE,PL2I,MWAITX,ADMSKX>
  Structured Extended Features=0xf1bf97a9<FSGSBASE,BMI1,AVX2,SMEP,BMI2,ERMS,INVPCID,PQM,PQE,AVX512F,AVX512DQ,RDSEED,ADX,SMAP,AVX512IFMA,CLFLUSHOPT,CLWB,AVX512CD,SHA,AVX512BW,AVX512VL>
  Structured Extended Features2=0x405fde<AVX512VBMI,UMIP,PKU,OSPKE,AVX512VBMI2,GFNI,VAES,VPCLMULQDQ,AVX512VNNI,AVX512BITALG,AVX512VPOPCNTDQ,RDPID>
  Structured Extended Features3=0x10000010<FSRM,L1DFL>
  XSAVE Features=0xf<XSAVEOPT,XSAVEC,XINUSE,XSAVES>
  AMD Extended Feature Extensions ID EBX=0x791ef257<CLZERO,IRPerf,XSaveErPtr,RDPRU,WBNOINVD,IBPB,IBRS,STIBP,STIBP_ALWAYSON,PREFER_IBRS,SSBD>
  SVM: NP,NRIP,VClean,AFlush,DAssist,NAsids=32768
  TSC: P-state invariant, performance statistics
real memory  = 68717379584 (65534 MB)
avail memory = 65913479168 (62859 MB)
Event timer "LAPIC" quality 600
ACPI APIC Table: <ALASKA A M I >
FreeBSD/SMP: Multiprocessor System Detected: 24 CPUs
FreeBSD/SMP: 1 package(s) x 2 cache groups x 6 core(s) x 2 hardware threads
random: unblocking device.
ioapic0 <Version 2.1> irqs 0-23
ioapic1 <Version 2.1> irqs 24-55
Launching APs: 12 13 18 23 17 21 15 3 10 8 7 4 1 20 14 19 16 22 5 6 2 9 11
TCP Hpts created 24 swi interrupt threads and bound 0 to cpus
random: entropy device external interface
kbd0 at kbdmux0
efirtc0: <EFI Realtime Clock>
efirtc0: registered as a time-of-day clock, resolution 1.000000s
vtvga0: <VT VGA driver>
smbios0: <System Management BIOS> at iomem 0x794a6000-0x794a601e
smbios0: Version: 3.5, BCD Revision: 3.5
aesni0: <AES-CBC,AES-CCM,AES-GCM,AES-ICM,AES-XTS,SHA1,SHA256>
acpi0: <ALASKA A M I >
Firmware Error (ACPI): Could not resolve symbol [\134_SB.PCI0.GPP7.UP00.DP40.UP00.DP68], AE_NOT_FOUND (20221020/dswload2-315)
ACPI Error: AE_NOT_FOUND, During name lookup/catalog (20221020/psobject-372)
acpi0: Power Button (fixed)
attimer0: <AT timer> port 0x40-0x43 irq 0 on acpi0
Timecounter "i8254" frequency 1193182 Hz quality 0
Event timer "i8254" frequency 1193182 Hz quality 100
atrtc0: <AT realtime clock> port 0x70-0x71 on acpi0
atrtc0: registered as a time-of-day clock, resolution 1.000000s
Event timer "RTC" frequency 32768 Hz quality 0
hpet0: <High Precision Event Timer> iomem 0xfed00000-0xfed003ff irq 0,8 on acpi0
Timecounter "HPET" frequency 14318180 Hz quality 950
Event timer "HPET" frequency 14318180 Hz quality 350
Event timer "HPET1" frequency 14318180 Hz quality 350
Event timer "HPET2" frequency 14318180 Hz quality 350
Timecounter "ACPI-fast" frequency 3579545 Hz quality 900
acpi_timer0: <32-bit timer at 3.579545MHz> port 0x808-0x80b on acpi0
acpi_ec0: <Embedded Controller: GPE 0x4> port 0x62,0x66 on acpi0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
amdsmn0: <AMD Family 19h System Management Network> on hostb0
amdtemp0: <AMD CPU On-Die Thermal Sensors> on hostb0
pci0: <base peripheral, IOMMU> at device 0.2 (no driver attached)
pcib1: <ACPI PCI-PCI bridge> at device 1.2 on pci0
pci1: <ACPI PCI bus> on pcib1
nvme0: <Generic NVMe Device> mem 0xec600000-0xec603fff at device 0.0 on pci1
pcib2: <ACPI PCI-PCI bridge> at device 1.3 on pci0
pci2: <ACPI PCI bus> on pcib2
mps0: <Avago Technologies (LSI) SAS2008> port 0xf000-0xf0ff mem 0xec5c0000-0xec5c3fff,0xec580000-0xec5bffff at device 0.0 on pci2
mps0: Firmware: 20.00.07.00, Driver: 21.02.00.00-fbsd
mps0: IOCCapabilities: 1285c<ScsiTaskFull,DiagTrace,SnapBuf,EEDP,TransRetry,EventReplay,HostDisc>
pcib3: <ACPI PCI-PCI bridge> at device 2.1 on pci0
pci3: <ACPI PCI bus> on pcib3
pcib4: <ACPI PCI-PCI bridge> at device 0.0 on pci3
pci4: <ACPI PCI bus> on pcib4
pcib5: <PCI-PCI bridge> at device 0.0 on pci4
pci5: <PCI bus> on pcib5
pcib6: <ACPI PCI-PCI bridge> at device 8.0 on pci4
pci6: <ACPI PCI bus> on pcib6
pcib7: <ACPI PCI-PCI bridge> at device 0.0 on pci6
pci7: <ACPI PCI bus> on pcib7
pcib8: <ACPI PCI-PCI bridge> at device 0.0 on pci7
pci8: <ACPI PCI bus> on pcib8
pci8: <network> at device 0.0 (no driver attached)
pcib9: <ACPI PCI-PCI bridge> at device 1.0 on pci7
pci9: <ACPI PCI bus> on pcib9
igc0: <Intel(R) Ethernet Controller I225-V> mem 0xeb700000-0xeb7fffff,0xeb800000-0xeb803fff at device 0.0 on pci9
igc0: Using 1024 TX descriptors and 1024 RX descriptors
igc0: Using 4 RX queues 4 TX queues
igc0: Using MSI-X interrupts with 5 vectors
igc0: Ethernet address: 08:bf:b8:13:99:0d
igc0: netmap queues/slots: TX 4/1024, RX 4/1024
pcib10: <PCI-PCI bridge> at device 3.0 on pci7
pci10: <PCI bus> on pcib10
pcib11: <ACPI PCI-PCI bridge> at device 4.0 on pci7
pci11: <ACPI PCI bus> on pcib11
pcib12: <ACPI PCI-PCI bridge> at device 0.0 on pci11
pci12: <ACPI PCI bus> on pcib12
pcib13: <ACPI PCI-PCI bridge> at device 0.0 on pci12
pci13: <ACPI PCI bus> on pcib13
pci13: <serial bus, USB> at device 0.0 (no driver attached)
pcib14: <PCI-PCI bridge> at device 1.0 on pci12
pcib15: <ACPI PCI-PCI bridge> at device 2.0 on pci12
pci14: <ACPI PCI bus> on pcib15
xhci0: <Intel Maple Ridge Thunderbolt 4 USB controller> mem 0xeb000000-0xeb00ffff at device 0.0 on pci14
xhci0: 32 bytes context size, 64-bit DMA
usbus0 on xhci0
usbus0: 5.0Gbps Super Speed USB v3.0
pcib16: <PCI-PCI bridge> at device 3.0 on pci12
pcib17: <PCI-PCI bridge> at device 8.0 on pci7
pci15: <PCI bus> on pcib17
pcib18: <ACPI PCI-PCI bridge> at device 10.0 on pci7
pci16: <ACPI PCI bus> on pcib18
igb0: <Intel(R) I350 (Copper)> port 0xe020-0xe03f mem 0xeb400000-0xeb4fffff,0xeb604000-0xeb607fff at device 0.0 on pci16
igb0: EEPROM V1.52-0
igb0: Using 1024 TX descriptors and 1024 RX descriptors
igb0: Using 8 RX queues 8 TX queues
igb0: Using MSI-X interrupts with 9 vectors
igb0: Ethernet address: 90:1b:0e:0c:c2:81
igb0: netmap queues/slots: TX 8/1024, RX 8/1024
igb1: <Intel(R) I350 (Copper)> port 0xe000-0xe01f mem 0xeb300000-0xeb3fffff,0xeb600000-0xeb603fff at device 0.1 on pci16
igb1: EEPROM V1.52-0
igb1: Using 1024 TX descriptors and 1024 RX descriptors
igb1: Using 8 RX queues 8 TX queues
igb1: Using MSI-X interrupts with 9 vectors
igb1: Ethernet address: 90:1b:0e:0c:c2:82
igb1: netmap queues/slots: TX 8/1024, RX 8/1024
pcib19: <ACPI PCI-PCI bridge> at device 12.0 on pci7
pci17: <ACPI PCI bus> on pcib19
xhci1: <XHCI (generic) USB 3.0 controller> mem 0xebc00000-0xebc07fff at device 0.0 on pci17
xhci1: 32 bytes context size, 64-bit DMA
usbus1 on xhci1
usbus1: 5.0Gbps Super Speed USB v3.0
pcib20: <PCI-PCI bridge> at device 13.0 on pci7
pci18: <PCI bus> on pcib20
ahci0: <AHCI SATA controller> mem 0xebb80000-0xebb803ff at device 0.0 on pci18
ahci0: AHCI v1.31 with 6 6Gbps ports, Port Multiplier supported
ahcich0: <AHCI channel> at channel 0 on ahci0
ahcich1: <AHCI channel> at channel 1 on ahci0
ahcich2: <AHCI channel> at channel 2 on ahci0
ahcich3: <AHCI channel> at channel 3 on ahci0
pcib21: <ACPI PCI-PCI bridge> at device 12.0 on pci4
pci19: <ACPI PCI bus> on pcib21
xhci2: <XHCI (generic) USB 3.0 controller> mem 0xebf00000-0xebf07fff at device 0.0 on pci19
xhci2: 32 bytes context size, 64-bit DMA
usbus2 on xhci2
usbus2: 5.0Gbps Super Speed USB v3.0
pcib22: <PCI-PCI bridge> at device 13.0 on pci4
pci20: <PCI bus> on pcib22
ahci1: <AHCI SATA controller> mem 0xebe80000-0xebe803ff at device 0.0 on pci20
ahci1: AHCI v1.31 with 6 6Gbps ports, Port Multiplier supported
ahcich6: <AHCI channel> at channel 0 on ahci1
ahcich7: <AHCI channel> at channel 1 on ahci1
ahcich8: <AHCI channel> at channel 2 on ahci1
ahcich9: <AHCI channel> at channel 3 on ahci1
pcib23: <ACPI PCI-PCI bridge> at device 8.1 on pci0
pci21: <ACPI PCI bus> on pcib23
vgapci0: <VGA-compatible display> port 0xd000-0xd0ff mem 0xfce0000000-0xfcefffffff,0xfcf0000000-0xfcf01fffff,0xec300000-0xec37ffff at device 0.0 on pci21
pci21: <multimedia, HDA> at device 0.1 (no driver attached)
pci21: <encrypt/decrypt> at device 0.2 (no driver attached)
xhci3: <XHCI (generic) USB 3.0 controller> mem 0xec100000-0xec1fffff at device 0.3 on pci21
xhci3: 64 bytes context size, 64-bit DMA
usbus3 on xhci3
usbus3: 5.0Gbps Super Speed USB v3.0
xhci4: <XHCI (generic) USB 3.0 controller> mem 0xec000000-0xec0fffff at device 0.4 on pci21
xhci4: 64 bytes context size, 64-bit DMA
usbus4 on xhci4
usbus4: 5.0Gbps Super Speed USB v3.0
pci21: <multimedia, HDA> at device 0.6 (no driver attached)
pcib24: <ACPI PCI-PCI bridge> at device 8.3 on pci0
pci22: <ACPI PCI bus> on pcib24
xhci5: <XHCI (generic) USB 3.0 controller> mem 0xec400000-0xec4fffff at device 0.0 on pci22
xhci5: 64 bytes context size, 64-bit DMA
usbus5 on xhci5
usbus5: 5.0Gbps Super Speed USB v3.0
isab0: <PCI-ISA bridge> at device 20.3 on pci0
isa0: <ISA bus> on isab0
acpi_button0: <Power Button> on acpi0
acpi_syscontainer0: <System Container> on acpi0
cpu0: <ACPI CPU> on acpi0
ns8250: UART FCR is broken
ns8250: UART FCR is broken
uart0: <16550 or compatible> port 0x3f8-0x3ff irq 4 flags 0x10 on acpi0
hwpstate0: <Cool`n'Quiet 2.0> on cpu0
Timecounter "TSC-low" frequency 1846530263 Hz quality 1000
Timecounters tick every 1.000 msec
ZFS filesystem version: 5
ZFS storage pool version: features support (5000)
ugen0.1: <Intel XHCI root HUB> at usbus0
ugen2.1: <AMD XHCI root HUB> at usbus2
ugen1.1: <AMD XHCI root HUB> at usbus1
ugen3.1: <AMD XHCI root HUB> at usbus3
ugen4.1: <AMD XHCI root HUB> at usbus4
ugen5.1: <AMD XHCI root HUB> at usbus5
uhub0 on usbus0
uhub0: <Intel XHCI root HUB, class 9/0, rev 3.00/1.00, addr 1> on usbus0
uhub1 on usbus1
uhub1: <AMD XHCI root HUB, class 9/0, rev 3.00/1.00, addr 1> on usbus1
uhub2 on usbus2
uhub2: <AMD XHCI root HUB, class 9/0, rev 3.00/1.00, addr 1> on usbus2
uhub3 on usbus4
uhub3: <AMD XHCI root HUB, class 9/0, rev 3.00/1.00, addr 1> on usbus4
uhub4 on usbus3
uhub4: <AMD XHCI root HUB, class 9/0, rev 3.00/1.00, addr 1> on usbus3
uhub5 on usbus5
uhub5: <AMD XHCI root HUB, class 9/0, rev 3.00/1.00, addr 1> on usbus5
Trying to mount root from zfs:zroot/ROOT/default []...
uhub3: 4 ports with 4 removable, self powered
uhub4: 4 ports with 4 removable, self powered
uhub0: 4 ports with 4 removable, self powered
uhub5: 1 port with 1 removable, self powered
uhub2: 18 ports with 18 removable, self powered
uhub1: 18 ports with 18 removable, self powered
ugen1.2: <vendor 0x04d9 USB Keyboard> at usbus1
ukbd0 on uhub1
ukbd0: <vendor 0x04d9 USB Keyboard, class 0/0, rev 1.10/3.13, addr 1> on usbus1
kbd1 at ukbd0
Root mount waiting for: CAM usbus1
ugen1.3: <MediaTek Inc. WirelessDevice> at usbus1
Root mount waiting for: CAM usbus1
ugen1.4: <AsusTek Computer Inc. AURA LED Controller> at usbus1
Root mount waiting for: CAM
Root mount waiting for: CAM
Root mount waiting for: CAM
Root mount waiting for: CAM
Root mount waiting for: CAM
nda0 at nvme0 bus 0 scbus9 target 0 lun 1
nda0: <CT2000P5PSSD8 P7CR403 REDACTED>
nda0: Serial Number REDACTED
nda0: nvme version 1.4
nda0: 1907729MB (3907029168 512 byte sectors)
ada0 at ahcich6 bus 0 scbus5 target 0 lun 0
ada0: <TOSHIBA HDWN180 GX2M> ACS-3 ATA SATA 3.x device
ada0: Serial Number REDACTED
ada0: 600.000MB/s transfers (SATA 3.x, UDMA5, PIO 8192bytes)
ada0: Command Queueing enabled
ada0: 7630885MB (15628053168 512 byte sectors)
ada1 at ahcich7 bus 0 scbus6 target 0 lun 0
ada1: <TOSHIBA HDWN180 GX2M> ACS-3 ATA SATA 3.x device
ada1: Serial Number Y734K2P6FP9E
ada1: 600.000MB/s transfers (SATA 3.x, UDMA5, PIO 8192bytes)
ada1: Command Queueing enabled
ada1: 7630885MB (15628053168 512 byte sectors)
ada2 at ahcich9 bus 0 scbus8 target 0 lun 0
ada2: <SanDisk SDSSDH3 1T00 415000RL> ACS-4 ATA SATA 3.x device
ada2: Serial Number 20514H800790
ada2: 600.000MB/s transfers (SATA 3.x, UDMA6, PIO 512bytes)
ada2: Command Queueing enabled
ada2: 953869MB (1953525168 512 byte sectors)
da0 at mps0 bus 0 scbus0 target 20 lun 0
da0: <ATA TOSHIBA MG08ACA1 0102> Fixed Direct Access SPC-4 SCSI device
da0: Serial Number REDACTED
da0: 600.000MB/s transfers
da0: Command Queueing enabled
da0: 15259648MB (31251759104 512 byte sectors)
da1 at mps0 bus 0 scbus0 target 21 lun 0
da1: <ATA TOSHIBA MG08ACA1 0102> Fixed Direct Access SPC-4 SCSI device
da1: Serial Number REDACTED
da1: 600.000MB/s transfers
da1: Command Queueing enabled
da1: 15259648MB (31251759104 512 byte sectors)
acpi_wmi0: <ACPI-WMI mapping> on acpi0
acpi_wmi0: Embedded MOF found
ACPI: \134AWW0.WQMO: 1 arguments were passed to a non-method ACPI object (Buffer) (20221020/nsarguments-361)
acpi_wmi1: <ACPI-WMI mapping> on acpi0
acpi_wmi1: Embedded MOF found
ACPI: \134ABAW.WQMO: 1 arguments were passed to a non-method ACPI object (Buffer) (20221020/nsarguments-361)
acpi_wmi2: <ACPI-WMI mapping> on acpi0
acpi_wmi2: Embedded MOF found
ACPI: \134RMTW.WQMO: 1 arguments were passed to a non-method ACPI object (Buffer) (20221020/nsarguments-361)
acpi_wmi3: <ACPI-WMI mapping> on acpi0
acpi_wmi3: Embedded MOF found
ACPI: \134AOD.WQBA: 1 arguments were passed to a non-method ACPI object (Buffer) (20221020/nsarguments-361)
driver bug: Unable to set devclass (class: ppc devname: (unknown))
ig4iic0: <Designware I2C Controller> iomem 0xfedc2000-0xfedc2fff irq 10 on acpi0
iicbus0: <Philips I2C bus (ACPI-hinted)> on ig4iic0
iicbus0: <unknown card> at addr 0x4e
iicbus0: <unknown card> at addr 0x4e
iicbus0: <unknown card> at addr 0x8
acpi_wmi4: <ACPI-WMI mapping> on acpi0
acpi_wmi4: Embedded MOF found
ACPI: \134_SB.ATKD.WQMO: 1 arguments were passed to a non-method ACPI object (Buffer) (20221020/nsarguments-361)
acpi_wmi5: <ACPI-WMI mapping> on acpi0
driver bug: Unable to set devclass (class: ppc devname: (unknown))
intsmb0: <AMD FCH SMBus Controller> at device 20.0 on pci0
intsmb0: Could not allocate I/O space
device_attach: intsmb0 attach returned 6
intsmb0: <AMD FCH SMBus Controller> port 0xff00-0xff0f at device 20.0 on pci0
intsmb0: Could not allocate I/O space
device_attach: intsmb0 attach returned 6
igc0: link state changed to UP
igb0: link state changed to UP
lo0: link state changed to UP
igc0: link state changed to DOWN
igb0: link state changed to DOWN
igc0: link state changed to UP
igb0: link state changed to UP
uhid0 on uhub1
uhid0: <vendor 0x04d9 USB Keyboard, class 0/0, rev 1.10/3.13, addr 1> on usbus1
uhid1 on uhub1
uhid1: <AsusTek Computer Inc. AURA LED Controller, class 0/0, rev 2.00/1.00, addr 3> on usbus1
ubt0 on uhub1
ubt0: <BTACLIf> on usbus1
ubt1 on uhub1
ubt1: <BTISOIf> on usbus1
ubt1: ubt_attach:670: could not get two interfaces
device_attach: ubt1 attach returned 6
ng_hci_process_command_timeout: ubt0hci - unable to complete HCI command OGF=0x3, OCF=0x3. Timeout
 
you've got a couple of issues in the log there, not sure if they mean anything. it does seem like your SATA drives are working.

curious though if you could elaborate on these issues. i'd hate to trade one problem for another.

Code:
Firmware Error (ACPI): Could not resolve symbol [\134_SB.PCI0.GPP7.UP00.DP40.UP00.DP68], AE_NOT_FOUND (20221020/dswload2-315)
ACPI Error: AE_NOT_FOUND, During name lookup/catalog (20221020/psobject-372)

Code:
ACPI: \134AWW0.WQMO: 1 arguments were passed to a non-method ACPI object (Buffer) (20221020/nsarguments-361)
acpi_wmi1: <ACPI-WMI mapping> on acpi0
acpi_wmi1: Embedded MOF found
ACPI: \134ABAW.WQMO: 1 arguments were passed to a non-method ACPI object (Buffer) (20221020/nsarguments-361)
acpi_wmi2: <ACPI-WMI mapping> on acpi0
acpi_wmi2: Embedded MOF found
ACPI: \134RMTW.WQMO: 1 arguments were passed to a non-method ACPI object (Buffer) (20221020/nsarguments-361)
acpi_wmi3: <ACPI-WMI mapping> on acpi0
acpi_wmi3: Embedded MOF found
ACPI: \134AOD.WQBA: 1 arguments were passed to a non-method ACPI object (Buffer) (20221020/nsarguments-361)
driver bug: Unable to set devclass (class: ppc devname: (unknown))
ig4iic0: <Designware I2C Controller> iomem 0xfedc2000-0xfedc2fff irq 10 on acpi0
iicbus0: <Philips I2C bus (ACPI-hinted)> on ig4iic0
iicbus0: <unknown card> at addr 0x4e
iicbus0: <unknown card> at addr 0x4e
iicbus0: <unknown card> at addr 0x8
acpi_wmi4: <ACPI-WMI mapping> on acpi0
acpi_wmi4: Embedded MOF found
ACPI: \134_SB.ATKD.WQMO: 1 arguments were passed to a non-method ACPI object (Buffer) (20221020/nsarguments-361)
acpi_wmi5: <ACPI-WMI mapping> on acpi0
driver bug: Unable to set devclass (class: ppc devname: (unknown))
intsmb0: <AMD FCH SMBus Controller> at device 20.0 on pci0
intsmb0: Could not allocate I/O space
device_attach: intsmb0 attach returned 6
intsmb0: <AMD FCH SMBus Controller> port 0xff00-0xff0f at device 20.0 on pci0
intsmb0: Could not allocate I/O space
device_attach: intsmb0 attach returned 6
 
dizzy, I purchased from this link a ASM1166 card and tried it in all slots. Won't boot with it in the PCI 3x16/4 or 5 slots, won't work in the pci 3x1 slot.

But thank you for the suggestion. I will try again with another card.
 
Top