Solved SAMBA build failed

Hi everyone,

I'm trying to install Samba with AD features, using portmaster the build fails each time with the following error :

Code:
+ install /usr/ports/devel/tevent/work/stage/usr/local/include/tevent.h (from tevent.h)
Waf: Leaving directory `/usr/ports/devel/tevent/work/tevent-0.13.0/bin/default'
'install' finished successfully (0.150s)
/bin/rm -f /usr/ports/devel/tevent/work/stage/usr/local/lib/tevent/libcmocka-tevent.so
/bin/rmdir /usr/ports/devel/tevent/work/stage/usr/local/lib/tevent
rmdir: /usr/ports/devel/tevent/work/stage/usr/local/lib/tevent: Directory not empty
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/devel/tevent
*** Error code 1

Stop.
make: stopped in /usr/ports/devel/tevent

===>>> make stage failed for devel/tevent
===>>> Aborting update

===>>> Update for devel/tevent failed
===>>> Aborting update


===>>> You can restart from the point of failure with this command line:
       portmaster <flags> net/samba416 devel/tevent

This command has been saved to ~/portmasterfail.txt

Here is the content of ~/portmasterfail.txt :

Code:
root@m900:~/samba/samba-4.17.2 # cat ~/portmasterfail.txt
portmaster <flags> net/samba416 devel/tevent

Can anyone please help.

Thanks,
 
Try running ports-mgmt/portmaster on devel/tevent alone and resume installing Samba.

Works fine on my system (main/latest ports branch):
Rich (BB code):
# portmaster devel/tevent

....
+ install /usr/ports/devel/tevent/work/stage/usr/local/include/tevent.h (from tevent.h)
Waf: Leaving directory `/usr/ports/devel/tevent/work/tevent-0.13.0/bin/default'
'install' finished successfully (0.369s)
/bin/rm -f /usr/ports/devel/tevent/work/stage/usr/local/lib/tevent/libcmocka-tevent.so
/bin/rmdir /usr/ports/devel/tevent/work/stage/usr/local/lib/tevent
/usr/bin/strip /usr/ports/devel/tevent/work/stage/usr/local/lib/libtevent.so
/usr/bin/strip /usr/ports/devel/tevent/work/stage/usr/local/lib/python3.9/site-packages/_tevent*.so
/usr/local/bin/python3.9 -m compileall -d /usr/local/lib/python3.9/site-packages /usr/ports/devel/tevent/work/stage/usr/local/lib/python3.9/site-packages
Listing '/usr/ports/devel/tevent/work/stage/usr/local/lib/python3.9/site-packages'...
Compiling '/usr/ports/devel/tevent/work/stage/usr/local/lib/python3.9/site-packages/tevent.py'...
====> Compressing man pages (compress-man)
===>  Installing for tevent-0.13.0_1
===>  Checking if tevent is already installed
===>   Registering installation for tevent-0.13.0_1
Installing tevent-0.13.0_1...

===>>> Installation of devel/tevent (tevent-0.13.0_1) complete
 
Try running ports-mgmt/portmaster on devel/tevent alone and resume installing Samba.

Works fine on my system (main/latest ports branch):
Rich (BB code):
# portmaster devel/tevent

....
+ install /usr/ports/devel/tevent/work/stage/usr/local/include/tevent.h (from tevent.h)
Waf: Leaving directory `/usr/ports/devel/tevent/work/tevent-0.13.0/bin/default'
'install' finished successfully (0.369s)
/bin/rm -f /usr/ports/devel/tevent/work/stage/usr/local/lib/tevent/libcmocka-tevent.so
/bin/rmdir /usr/ports/devel/tevent/work/stage/usr/local/lib/tevent
/usr/bin/strip /usr/ports/devel/tevent/work/stage/usr/local/lib/libtevent.so
/usr/bin/strip /usr/ports/devel/tevent/work/stage/usr/local/lib/python3.9/site-packages/_tevent*.so
/usr/local/bin/python3.9 -m compileall -d /usr/local/lib/python3.9/site-packages /usr/ports/devel/tevent/work/stage/usr/local/lib/python3.9/site-packages
Listing '/usr/ports/devel/tevent/work/stage/usr/local/lib/python3.9/site-packages'...
Compiling '/usr/ports/devel/tevent/work/stage/usr/local/lib/python3.9/site-packages/tevent.py'...
====> Compressing man pages (compress-man)
===>  Installing for tevent-0.13.0_1
===>  Checking if tevent is already installed
===>   Registering installation for tevent-0.13.0_1
Installing tevent-0.13.0_1...

===>>> Installation of devel/tevent (tevent-0.13.0_1) complete
Same result trying to install the port individually, I tried also to install it using pkg and even using source code, Samba build fails each time :

Code:
Waf: Leaving directory `/usr/ports/devel/tevent/work/tevent-0.13.0/bin/default'
'install' finished successfully (0.147s)
/bin/rm -f /usr/ports/devel/tevent/work/stage/usr/local/lib/tevent/libcmocka-tevent.so
/bin/rmdir /usr/ports/devel/tevent/work/stage/usr/local/lib/tevent
rmdir: /usr/ports/devel/tevent/work/stage/usr/local/lib/tevent: Directory not empty
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/devel/tevent
*** Error code 1

Stop.
make: stopped in /usr/ports/devel/tevent

===>>> make stage failed for devel/tevent
===>>> Aborting update


===>>> You can restart from the point of failure with this command line:
       portmaster <flags> devel/tevent

This command has been saved to ~/portmasterfail.txt
 
Same result, I don't know what to do to be honest :

Code:
+ install /usr/ports/devel/tevent/work/stage/usr/local/include/tevent.h (from tevent.h)
Waf: Leaving directory `/usr/ports/devel/tevent/work/tevent-0.13.0/bin/default'
'install' finished successfully (0.196s)
/bin/rm -f /usr/ports/devel/tevent/work/stage/usr/local/lib/tevent/libcmocka-tevent.so
/bin/rmdir /usr/ports/devel/tevent/work/stage/usr/local/lib/tevent
rmdir: /usr/ports/devel/tevent/work/stage/usr/local/lib/tevent: Directory not empty
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/devel/tevent
*** Error code 1
 
Looks like build and installation succeeded, but cleaning up went wrong. You could try to build his port manually as root, then proceed with portmaster:
Code:
cd /usr/ports/devel/tevent
make clean
make install
make clean
 
Looks like build and installation succeeded, but cleaning up went wrong. You could try to build his port manually as root, then proceed with portmaster:
Code:
cd /usr/ports/devel/tevent
make clean
make install
make clean
Same result, I think there is an issue with the port itself :
Code:
+ install /usr/ports/devel/tevent/work/stage/usr/local/include/tevent.h (from tevent.h)
Waf: Leaving directory `/usr/ports/devel/tevent/work/tevent-0.13.0/bin/default'
'install' finished successfully (0.159s)
/bin/rm -f /usr/ports/devel/tevent/work/stage/usr/local/lib/tevent/libcmocka-tevent.so
/bin/rmdir /usr/ports/devel/tevent/work/stage/usr/local/lib/tevent
rmdir: /usr/ports/devel/tevent/work/stage/usr/local/lib/tevent: Directory not empty
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/devel/tevent
*** Error code 1
 
Same result, I think there is an issue with the port itself :
I checked installation from port, no problem here. What's causing the port to terminate with an error on your system is limit to your system.

Try installing package devel/tevent again, but change to 'latest' package repository. 'quarterly' is set to default in /etc/pkg/FreeBSD.conf.

devel/tevent package on 'quarterly' has version number 0.13.0 whereas 'latest' is the same as the port (0.13.0_1). Because of the version difference portmaster tries to build devel/tevent on your previous attempt.
 
I checked installation from port, no problem here. What's causing the port to terminate with an error on your system is limit to your system.

Try installing package devel/tevent again, but change to 'latest' package repository. 'quarterly' is set to default in /etc/pkg/FreeBSD.conf.

devel/tevent package on 'quarterly' has version number 0.13.0 whereas 'latest' is the same as the port (0.13.0_1). Because of the version difference portmaster tries to build devel/tevent on your previous attempt.
I tried version 0.13.0_1 before and it gave me the same result, in fact I installed the port using pkg, portmaster tried the upgrade to 0.13.0_1, since portmaster keeps wanting to upgrade it.
if there is an option that tells portmaster not to upgrade the ports it should work.
 
I was able to build the port using make instead of partmaster, because make just accepted the version that I installed 0.13.0 through pkg.
Thanks everyone for your help.
 
So to sum up, portmaster forced the upgrade of tevent 0.13.0 from to 0.13.0_1, since portmaster failed to finish the installation I couldn't install Samba416, so I just compiled manually after I installed tevent 0.13.0 using pkg.
 
Top