ryzen 3 2200g vega 8 graphics

clawhammer

Active Member

Reaction score: 6
Messages: 169

I cant seem to get this to work as after i install the drm-kmod and add kld_list="amdgpu" to rc.conf after the freebsd boot screen the monitor go blank. turning off the frame buffer doesnt help.
 

shepper

Aspiring Daemon

Reaction score: 281
Messages: 806

I'm running the same APU in OpenBSD current.
http://daemonforums.org/showpost.php?p=67112&postcount=125
My understanding is that the firmware is bundled with the module. I would review your dmesg to see if it recognized and the firmware loaded. Also /var/log/Xorg.0.log for other errors
In OpenBSD I had to tweak the mouse cursor to a software cursor but otherwise, it runs well.
 
OP
OP
clawhammer

clawhammer

Active Member

Reaction score: 6
Messages: 169

I'm running the same APU in OpenBSD current.
http://daemonforums.org/showpost.php?p=67112&postcount=125
My understanding is that the firmware is bundled with the module. I would review your dmesg to see if it recognized and the firmware loaded. Also /var/log/Xorg.0.log for other errors
In OpenBSD I had to tweak the mouse cursor to a software cursor but otherwise, it runs well.
when I i read dmesg without the driver loaded it recogninzes it as a ryzen 3 cpu but once i load the driver the screen goes blank and I cant read the dmesg.
 

shepper

Aspiring Daemon

Reaction score: 281
Messages: 806

Unless it's frozen, you should be able to access a VT with <CTL-ALT-F3> and read the dmesg. Also /var/log/Xorg.0.log is retained so should be accessible without the driver being loaded.
 
Top