Running Telegram-GUI

mbzadegan

Active Member

Reaction score: 3
Messages: 184

Hi,
I downloaded telegram desktop and then extracted. Now, When I running it, it notify me to:
Code:
root@unix:/usr/home/user/Telegram # ./Telegram
./Telegram: error while loading shared libraries: libX11.so.6: cannot open shared object file: No such file or directory
root@unix:/usr/home/user/Telegram #
How can I resolve this?
I use MATE desktop too.
 
OP
OP
mbzadegan

mbzadegan

Active Member

Reaction score: 3
Messages: 184

I reinstalled this port, Now :
Code:
root@unix:/usr/home/user/Telegram # ./Telegram
FATAL: kernel too old
root@unix:/usr/home/user/Telegram # uname -a
FreeBSD unix 10.1-RELEASE FreeBSD 10.1-RELEASE #0 r274401: Tue Nov 11 22:51:51 UTC 2014     root@releng1.nyi.freebsd.org:/usr/obj/usr/src/sys/GENERIC  i386
root@unix:/usr/home/user/Telegram #
 

tobik@

Daemon
Developer

Reaction score: 1,386
Messages: 1,909

I reinstalled this port, Now :
Code:
root@unix:/usr/home/user/Telegram # ./Telegram
FATAL: kernel too old
root@unix:/usr/home/user/Telegram # uname -a
FreeBSD unix 10.1-RELEASE FreeBSD 10.1-RELEASE #0 r274401: Tue Nov 11 22:51:51 UTC 2014     root@releng1.nyi.freebsd.org:/usr/obj/usr/src/sys/GENERIC  i386
root@unix:/usr/home/user/Telegram #
Did you run sysctl compat.linux.osrelease=2.6.18?
 
OP
OP
mbzadegan

mbzadegan

Active Member

Reaction score: 3
Messages: 184

Code:
root@unix:/usr/home/user # sysctl compat.linux.osrelease=2.6.18
compat.linux.osrelease: 2.6.16 -> 2.6.18
root@unix:/usr/home/user/Telegram # ./Telegram 
./Telegram: /lib/libc.so.6: version `GLIBC_2.15' not found (required by ./Telegram)
 
OP
OP
mbzadegan

mbzadegan

Active Member

Reaction score: 3
Messages: 184

I installed net-im/sigram but nothing occurred and I did not find any commands to execution it!
 
Last edited by a moderator:

tobik@

Daemon
Developer

Reaction score: 1,386
Messages: 1,909

Run Sigram (with a capital S).

If in doubt what command to run you can list the binaries installed by a port with e.g pkg info --list-files net/sigram | grep bin/. This should give you an idea of what to run.
 
OP
OP
mbzadegan

mbzadegan

Active Member

Reaction score: 3
Messages: 184

Code:
root@unix:/usr/home/user # Sigram 
process 1127: D-Bus library appears to be incorrectly set up; failed to read machine uuid: Failed to open "/etc/machine-id": No such file or directory
See the manual page for dbus-uuidgen to correct this issue.
  D-Bus not compiled with backtrace support so unable to print a backtrace
Abort (core dumped)
root@unix:/usr/home/user #
 
OP
OP
mbzadegan

mbzadegan

Active Member

Reaction score: 3
Messages: 184

OK, I mixup with this error and forget google searching.
How can I run it with non-root user?
 
Top