Running Bhyve without nested virtualizations feature?

0w8States

New Member


Messages: 6

Hi All,

I've been doing some testing of my companies real-time kernel modules inside Bhyve, and I noticed that the system complains that it has nested virtualization enabled. This is common of my companies modules; if running on a guest inside Virtualbox, or VMWare workstation, it's as simple as disabling the "Nested virtualization" feature in the guest settings. I know the host OS requires Intel VT-x to run Bhyve, but most hypervisors can enable/disable that feature to be passed on-wards to the guest OS.

Here is my launch command for the Bhyve guest:


bhyve -c 2 -m 4G -H -w \
-s 0,hostbridge \
-s 3,ahci-cd,windows10.iso \
-s 4,ahci-hd,/dev/zvol/zroot/vms/win10/os_disk \
-s 5,virtio-net,tap10 \
-s 29,fbuf,tcp=0.0.0.0:5900,wait \
-s 30,xhci,tablet \
-s 31,lpc \
-l com1,stdio \
-l bootrom,/usr/local/share/uefi-firmware/BHYVE_UEFI.fd \
win10


Is there a way to disable this on Bhyve when launching the guest?
 
OP
0w8States

0w8States

New Member


Messages: 6

Update: This might not be a Bhyve feature that's preventing me to run. I just tried to load the same RT-module under KVM/QEMU, and it still complains; I know I have disabled nested virtualization on KVM. So it might be due to the Type 1 (or the hybrid area of KVM/Bhyve) type architecture, as opposed to my previous setup with Virtual Box.
 
Top