Solved run_depends not found

Nutz

Member

Reaction score: 1
Messages: 28

Hello All,

i'm working on a new poudriere and all is set up. port-tree, jail, poudriere.conf..etc..
The bulk of official packages works great but not for one of my own custom package.

The bulk is stopped at the phase run-depends :
Depends on package: py27-yaml>0 - not found (on each depends actually)

But when i check on freshport, the package exist...

i didnt change the Makefile from the former poudriere, does this problem is related to py_flavors and uses_python ?
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,905
Messages: 31,199

does this problem is related to py_flavors and uses_python
Yes.

7.4. USES=python and Flavors
Look at the example at the bottom.

But when i check on freshport, the package exist...
The port is named py-yaml. The package with the Python 2.7 flavor is called py27-yaml.

The way I fix my dependencies is to look at the port in question and look at how other ports are depending on it, databases/py-mysql2pgsql for example also has a py-yaml run dependency. Look at the Makefile from that port to see how you can use it in your own port.

Just a note, you may want to switch to Python 3.6, 2.7 will be end-of-life some time early 2020 and is likely to disappear from the ports tree not long after that. Also note that the default Python version is now 3.6, if your port requires 2.7 it should indicate that.
 
OP
OP
N

Nutz

Member

Reaction score: 1
Messages: 28

Hi Sirdice,

thanks for the answer !
I checked the Makefile and i had to delete distutils & add @${PY_FLAVOR} at the end of each depends.

And yes, we are currently working on translate our custom package to python 3.6 but some of them depend of py-libzfs and py-freebsd which are not available on python 3.6.

Edit: it was a bad idea to delete distutils :d, i ran into error "cannot open makefile". Now, its okay.

Have a good day,
N!
 
Top