Root on ZFS & rc.conf error => problem at boot time.

Martillo1

Active Member

Reaction score: 29
Messages: 226

I have a single disk with ZFS and everything on it, I mean the whole system even the root directory. Three hours ago I added a line to /etc/rc.conf like
Code:
downtimed_enable="YES"
but I surely ended writing it without the final double quotations marks. I say surely because when booting the output says that there is a missing quotation mark in /etc/rc.conf and diverts me to the single user prompt, where I can do nothing: no file systems mounted, no access to directory tree, no access to commands.

I have tried the Fixit! in the installation DVD, but apart from loading the ZFS module I can do nothing else because /dist/etc/rc.d/zfs does not start for it does not find the files needed, so I can not access to ZFS pool nor mount ZFS shares. The memory disk is not big enough to copy /dist/etc, so it is a trial & error, so I ask for advice about a shorter and safer way.

I know now why putting root partition on ZFS is heavily discouraged. Yes I know :r
 

kpa

Beastie's Twin

Reaction score: 1,856
Messages: 6,318

You should be able to do these three steps in single user mode and get your filesystems mounted, these are the first steps of the sequence I use everytime I have to upgrade my fileserver to a newer OS version (the make installworld part that has to be done in single user mode).

# adjkerntz -i
# mount -u /
# zfs mount -a

Fix /etc/rc.conf with your favorite editor

# reboot
 
OP
M

Martillo1

Active Member

Reaction score: 29
Messages: 226

Thank you very much! It worked like a charm!

Thanks a lot! I have written it down for future emergencies :)

Now I have to investigate more about ZFS, because I am aware that I lack knowledge about it.
 
Top