Solved Rescuing the ZFS pool from a fried FreeBSD box

This is my first post, I have used FreeBSD in my home-built NAS since v8.x and always been able to google the answer to any problem I've had. I often ended up here :) But today... I must admit I need your advice.

Today I switched my NAS (v10.1) off and on again. I heard that electric crackeling noise we all fear. The noise that warns you that something fried inside your box. And yes, at least my system disk is fried.

Armed with a FreeBSD usb-stick, I managed to boot from a stick and tried to repair the system with fsck. Fsck would not repair the UFS system drive.

I'm already researching my next NAS build (using FreeBSD), but, how do I go about rescuing the UFS system drive, or transfering (if possible) the zpool on the fried box to a new box?

In my setup I have
1 UFS system drive (destroyed)
4 zfs drives (unknown status)
+1 zfs spare
(the only drive I can physically identify is the system drive)

Any advice will appreciated.
I can't help you with the UFS drive---if the disk exploded, that system's probably gone for good. However, a zpool can be imported into any ZFS-capable operating system with the same feature flags your pool has. First verify that the disks in the zpool are alright---say, by booting that LiveUSB and making sure the system can see the disks, and then booting SystemRescueCd and running SMART tests on all of them. You can then boot into the FreeBSD LiveUSB again and import the pool with zfs import -R /mnt <pool_name>, then run a scrub on it.

Assuming the disks are all part of the same pool, their physical location/order in the case shouldn't matter.
Thank you! I will try your suggestion.

Yes, the ufs drive is garbage... but disks are cheap.

What worried me was making a fatal mistake during rescue. What I know about FreeBSD, I've learned from ruining the system a few times too often :)
Your USB stick might not last very long as a system disk if you run a scrub. Might be better to do a clean install to a new [hard] disk, import the pool, and run a scrub.
Last edited:
Thanks for all your advice! The problem is solved.

I decided to build a new computer, with all brand new components except for my zfs disks. smartctl suggested that they are all healthy.

zpool import discovered my old pool, and suggested I run zpool import -f tank.
I'm scrubbing the imported pool right now.

I had no idea it would be this easy...
I have suggested to colleagues and geek friends that they should try ZFS; if not on *BSD, then on linux. Its disaster recovery plan seemed great in theory... but when I had to recover data from a fried system for real, "wow!"