Solved remove geli disk from prompting for password

Earlier I had setup geli on my disk, but since it kept crashing due to a bad controller driver, I figured maybe it's the encryption so even though I couldn't remove the disk from geli anymore cause the system froze each time, I just reformated the drive without encryption.

Now the issue at hand is that it keeps prompting me for a password however the disk is not encrypted any more. So how do I remove this disk from geli.

I've tried geli detach ada5p(.eli) however that doesn't work. I do remember that the configuration is somewhere on disk although I don't remember where exactly.
You can first try running geli clear on the partition. If that doesn't work, then destroying the partition table on the disk should do the trick, though that may be a little extreme.

You should also check that you don't have any left-over entries for the partitions from /etc/rc.conf and /boot/loader.conf. If you manually configured GELI to unlock the filesystems during boot, you need to reverse that by running geli configure -B on the partition, though that's only a work-around that shouldn't be necessary once the GELI metadata has already been removed.