Solved reinstalled KDE5, many issues to follow

skeletonboss12

Member

Reaction score: 4
Messages: 69

Edit: Following a package update that causes even more issues.. I have opted to reinstall, and never switch from quarterly again. This seems to have fixed it

I am on freebsd 12.1 x64, running the latest branch for ports.

I had uninstalled KDE to try out MATE, after I was done I reinstalled KDE using the metaport, however it is acting quite weird.

Things that worked before just crash now such as konversation, balloo, discover, various system settingss.

I am not getting any errors in dmesg about it besides from balloo ...
Code:
Failed to fully fault in a core file segment at VA 0x805a00000 with size 0x4000000000 to be written at offset 0x35fc000 for process baloo_file
pid 42399 (baloo_file), jid 0, uid 1002: exited on signal 5 (core dumped)
I also noticed a few things were missing and needed to be manually installed.. dolphin, okular, various other widgets. SO maybe some base component is missing that is causing the issue/. when I try to install the collection of kde packages again it insists I am missing nothing. I also tried kde-baseapps, with how out of date the other DE's are this is pretty disheartening..


Edit: Dolphin is no longer launching now and fonts seem to be screwed up. Also cannot get any hotkey shortcuts to work anymore..
 

Attachments

Last edited:

mjollnir

Daemon

Reaction score: 756
Messages: 1,206

Did you install package or from ports? If you installed from ports, did you use so-called portmaster, or poudriere, or make install?
 

nb

New Member

Reaction score: 1
Messages: 12

FreeBSD 12.1-RELEASE-p7 amd64
After update from packages (latest - 2020-Jul-09 14:03) KDE is unusable.
 

mjollnir

Daemon

Reaction score: 756
Messages: 1,206

To give any help & suggestions, we need a more detailed description. Maybe your Xorg.0.log tells s/th.
 
OP
skeletonboss12

skeletonboss12

Member

Reaction score: 4
Messages: 69

I believe I have found the source of the issue...
$ dolphin
ld-elf.so.1: /usr/local/lib/qt5/libQt5Core.so.5: version Qt_5.15 required by /usr/local/lib/libKF5FileMetaData.so.3 not found
[tuder@vagrant-se /usr/home/loved]$ ^C

I may need to make a seperare thread for this.
 

achix

Well-Known Member

Reaction score: 49
Messages: 293

I had all those as well. I upgraded to 11.4-RELEASE , then I deleted all packages and tried installing from scratch by using the the default quarterly pkg repo. (but also specifying the eu mirror : url: "pkg+http://pkg.eu.FreeBSD.org/${ABI}/quarterly" , because the default was far too slow, btw I thought it would autoresolve to the eu mirror ?). Then I found out that there was no firefox pkg. Great. So I switched to the latest. After that lots of qt incompatibilities. So I scrap everything and try quarterly again. This seemed to do the trick. However the system still has issues :
a) I cannot lock the screen, if I do that the bottom plasma panels get lost.
b) I cannot switch to console by ctrl-alt-F1 and then then return, If I do this again the panels get lost.

btw, by the time I did all that, I noticed firefox back in quarterly, so I settled there. Still as I said not ideal . Anyone experience those?
now running with :
plasma5-plasma-5.19.2
kde5-5.19.2.20.04.2
qt5-core-5.14.2_3
 

mjollnir

Daemon

Reaction score: 756
Messages: 1,206

I do not have these issues. Turns out that this 2020/Q3 upgrade was somewhat sub-optimal... General guideline should be to wait 2-3 weeks before applying the quarterly package upgrades.
 

wolffnx

Well-Known Member

Reaction score: 106
Messages: 446

I believe I have found the source of the issue...
$ dolphin
ld-elf.so.1: /usr/local/lib/qt5/libQt5Core.so.5: version Qt_5.15 required by /usr/local/lib/libKF5FileMetaData.so.3 not found
[tuder@vagrant-se /usr/home/loved]$ ^C

I may need to make a seperare thread for this.
from time to time happen the same to me, then I run

pkg update -f
pkg upgrade

and done
edit: maybe when you install MATE install some newest libraries, and upgrade some existing ones
 
OP
skeletonboss12

skeletonboss12

Member

Reaction score: 4
Messages: 69

from time to time happen the same to me, then I run

pkg update -f
pkg upgrade

and done
edit: maybe when you install MATE install some newest libraries, and upgrade some existing ones
I should probably just mark this thread solved since I no longer use KDE anyways. Fed up with these random breakages
 
Top