Redshift not working

Hi,


1663511417974.png


Whether redshift 1.12_1 is installed as a binary package or a compiled package, it does not work. Does anyone have a viable solution ?
Once the installation with "pkg install" is done, there is no icon in the taskbar and running it via the terminal gives "Access to the current location was denied by GeoClue !" Once the installation is done via "/usr/ports/accessibility/redshift/", the icon appears several times in the dashboard and the system is completely blocked.
Many thanks.
 
Redshift works fine with xorg and even wayland.
Try:
Code:
redshift -l 1:1
(parameters minus el , one ,one).
If that works you can look your position on,
& give these as parameters to redshift.
 
I remember I had issue and the problem were some linuxisms caused by systemd integration... Therefore I moved to sct and I set up a cronjob to enable and another one to disable it:

Code:
 sct 4500 # sets warm temperature
sct # with nothing it resets

It is not fancy but it works and it is light!
 
Therefore I moved to sct and I set up a cronjob to enable and another one to disable it:
That sounds like something I might be interested in.
Could you leave some additional information regard what sct is (eg. a port, built-in binary, script, ...) or where to get it from?
 
Top