Reboots or Boots stops at AUTOBOOT in 10 seconds

nero

Member

Reaction score: 6
Messages: 22

Unless I hit enter on the console keyboard. My machine will not reboot. I am not sure where this setting would be.

Thanks,
T
 
OP
nero

nero

Member

Reaction score: 6
Messages: 22

fixed this by putting autoboot_delay="0" in /boot/loader.conf

Still not sure why it was waiting there and not just doing the 10 second count down.

Cheers,
T
 

Mjölnir

Daemon

Reaction score: 1,484
Messages: 2,114

Please tell which FreeBSD version & the hardware you were using. We'd like to know the output of
uname -aU & freebsd-version (or if you downloaded an install image, which one).
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 10,927
Messages: 36,836

Spacebar stuck? If you hit the spacebar during the countdown, the countdown stops and will wait forever.
 
OP
nero

nero

Member

Reaction score: 6
Messages: 22

So, tested the space bar and it is not stuck.

This is a Dell Laptop that I am using temporarily as a local webserver for development purposes. So, no X11; just console.

FreeBSD ***************** 12.2-RELEASE-p3 FreeBSD 12.2-RELEASE-p3 GENERIC amd64

i7 - 4000 something CPU
16Gigs RAM

Cheers,
T
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 10,927
Messages: 36,836

So, no X11; just console.
Not relevant for the boot menu in any case.

I'm wondering if it might be stuck in a loop trying to find boot environments or old kernels. Can you post a picture of the screen when it just sits there?
 
OP
nero

nero

Member

Reaction score: 6
Messages: 22

PXL_20210331_055337909.jpg
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 10,927
Messages: 36,836

Ok, no boot environments and it doesn't seem to have a problem listing the kernels. That's strange. If you set the autoboot_delay to 0 or "NO" it boots just fine? What if you set it to 3 seconds? Will it then be stuck at 3 seconds?
 
OP
nero

nero

Member

Reaction score: 6
Messages: 22

Yeah, so set to 0 it boots just fine.

And it seems like the oddest thing to me as well. Because it is not halting at an error or anything.

I am not in a position to test right now with 3 secs; but I will report back later on today when I can test that.

Cheers,
Tamer
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 10,927
Messages: 36,836

Maybe it has something to do with timers. When you get the chance, check the timer settings in the BIOS too. Make sure it's set to HPET or have it enabled if there's a BIOS setting for it.
 
OP
nero

nero

Member

Reaction score: 6
Messages: 22

So, I just tried a few things. FIrst:

There is absolutely nothing in the bios about Timers and HPET.

When I set the time to 3 it returned to the old behavior where it stopped there. Only difference was it now said Boot in 3 seconds.

And trying to figure out the bios upgrade...Will report back.

Cheers,
T
 

Snurg

Daemon

Reaction score: 577
Messages: 1,349

Got curious how the new boot loader looks.

As far as I can see from a short peek, there is no keyboard queue flush before the menu is called (function menu.process in /boot/lua/menu.lua).
If my suspicion is correct, every bad OEM keyboard that sends a spurious nonsense scancode at initializing will stop the boot loader.

But maybe this is "intentional behaviour", so one can press a key without having to wait for the boot menu to appear?

Edit:
Now, having looked a bit more at the new bootloader, I am quite sure that this should be categorized as a bug, unless people claim it's a feature.
I cannot find anything that clears the keyboard queue before the first menu call, and any key that does not have a function assigned makes the bootloader wait in the menu.

So, what do you think? Bug or feature?
 
OP
nero

nero

Member

Reaction score: 6
Messages: 22

I am not sure. This is the laptop's keyboard. But I do have another USB keyboard attached. Let me disconnect that and see what happens
 
OP
nero

nero

Member

Reaction score: 6
Messages: 22

Disconnecting the external keyboard did not fix the issue.

T
 

Snurg

Daemon

Reaction score: 577
Messages: 1,349

Well then it is possibly your laptops' keyboard that is "bad".
At least "bad" in the sense that it sends some nonsense scancode that confuses any boot loader, which does not clear the keyboard queue before entering its menu.

Or there is another key stuck that causes the problem?
To verify this, you could write a small loop in loader.lua that clears the keyboard queue before calling menu.

Either way, I think this should be considered a bug.
Because, any keyboard with stuck key(s) could prevent a server to start up.

SirDice, what do you think?
 

richardtoohey2

Well-Known Member

Reaction score: 260
Messages: 496

Either way, I think this should be considered a bug.
Because, any keyboard with stuck key(s) could prevent a server to start up.
Hmmm, maybe. If it's got stuck keys I might want to fix that before it starts up rather that a possibly stuck key selecting an option that I don't want.
 

Snurg

Daemon

Reaction score: 577
Messages: 1,349

If it's got stuck keys I might want to fix that before it starts up rather that a possibly stuck key selecting an option that I don't want.
Have you also experienced stuck keys that weren't obviously stuck?
I mean, keys that report "stuck" but not visibly.
Hammering (quite) hard on that key on my laptop helped to get the key "loose" and working again.

(Btw, this is why I hate laptops. They have no real keyboard.)
 

richardtoohey2

Well-Known Member

Reaction score: 260
Messages: 496

You said server so I was thinking about that specific scenario. But most of the servers I look after are "headless" anyway.
 

Snurg

Daemon

Reaction score: 577
Messages: 1,349

You said server so I was thinking about that specific scenario.
I'd be curious to know how many old laptops with sticky keys are being put to a last use as low-power home server, WLAN hotspot etc, like the OP plans to :)
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 10,927
Messages: 36,836

I don't think it's a stuck key, that would show up when the machine's booted too. The countdown being stuck is certainly something I've never seen happening before, so I'm shooting in the dark here.
 

balanga

Son of Beastie

Reaction score: 198
Messages: 3,768

Please tell which FreeBSD version & the hardware you were using. We'd like to know the output of
uname -aU & freebsd-version (or if you downloaded an install image, which one).
Never come across the -U option to uname() before...

Is see that it stands for:

-U Write the FreeBSD version of the user environment.
...but not sure what that means
 

Mjölnir

Daemon

Reaction score: 1,484
Messages: 2,114

Never come across the -U option to uname() before... Is see that it stands for: ...but not sure what that means
DO NOT TRY IT OUT! That's very dangerous, because it will irreversibly Write the FreeBSD version of the user environment to the stdout(4). EDIT Then you can only can get rid of it by pressing <ENTER> until it scrolls off, or close the terminal. The latter is considered bad style on any UNIX box; it is commonly accepted best practice to always have at least one terminal open.
 
Top