• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Reboot instead of going off, half time

Emrion

New Member

Thanks: 2
Messages: 18

#1
Hello,

I've just set up an old Dell PC with FreeBSD. I noticed that it reboots instead of going off, one time of two, when it receives poweroff command.

Saw some errors in dmesg, so I attached this file.

I will appreciate any tips to correct this problem.
 

Attachments

max21

Well-Known Member

Thanks: 18
Messages: 401

#4
It's possible but what can I actually do?
I would figure if my dell is at least build in 2008 or even 2003 and FreeBSD did install and ran, the problem would mainly be in the BIOS.

*The first thing I would do is reset the BIOS to factory default, then set time, etc.

*Then under Power Management Setup (or whatever it was called back then) I would set AC Back Function to [Full-ON]

*I would turn off-the Default Factory Boot Menu founded elsewhere so that I can see the boot terminal activity.

*Then I would find the Virtualization options and turn it on if I plan to run any VM programs.

*I would also turn-off APIC support in the BIOS. If that don’t work don’t forget to turn it back on so to continue your experiment. this might be the only thing you have to do. I can't remember but that will cause ACPI shutdown of VM not to work. FreeBSD vBox don't need it. It could have been what setting you make for the HDD, meaning use plain HDD and not whatever sata setting.


There is nothing wrong with raw FreeBSD 11.1 RELEASE that I experienced other then an occasional freeze at startup at ACPI stuff. I blame that on my over-worked 2010 hardware. I reboot again and it's AOK.

Other then that I have seen a reboot more-then-once for no reason at all. It was due to a SVN upgrade weeks ago. A member here tested SVN and told to retry. I re-upgraded a few days latter (it had new revision number) and it solved that problem. Evidently, the developers at SVN had caught it just in time.

This could be in a p4 p8 upgrade or whatever in your case so the next thing I would do is to run freebsd-update again or go straight to FreeBSD-11.2 BETA2 right now or wait for RC2 in a few days!

And if that don’t work I install it on another machine. I may only prove that your Dell PC is too old and can only handle FreeBSD-10x or previous.

Learning ACPI would be a great thing. There is plenty of info about ACPI. I almost got into it in the past however one of these thing got me up and running again. I had gotten confuse with APIC vs ACPI when I left off. Whatever the case its might not be a big deal. Pay attention to figure out what actually fixed it and let us know, it's still so major.

From that point I heard about flash-BIOS but finding and working with firmware (if that's what it's call) is a trip i think. Computing and expecially FreeBSD has too much going on to learn about everthing. ACPI is a trip that might change in a FLASH. FreeBSD has all I want learn. That is all that I can figure. You have just have to play hard until you find it.

Good Luck!

PS:

One more thing. Unplug the system. Check to make sure that your CPU and memory sticks are seated properly (and every thing else). Remove them all anyway and carefully reseat them. I would remove the CPU, clean it and give it a fresh coat of thermo grease. Then I would remove the computer battery for at least an hour. 24 hours recommended. Blow out your Power-Suppy. Now that I think about it I had one running but it was weak, I change it and the booting problem (or whatever was wrong) was gone. I bet that is your problem. You can't tell anymore -- the fan is spinning anyway. That was a new one on me and it was only last week when I change it. I been having hardware problems placed on the backburner for over a month now. Whatever all those problem was it's now gone off of one of my three 2010 machines (my main one)! I bet thats it!

And if that don’t work just get another old computer - - 2010 or newer (50 - 100 bucks).
 

Emrion

New Member

Thanks: 2
Messages: 18

#5
Thank you very much for this long message. I've tried some of the things you mention: played with memory sticks and almost all settings in the BIOS... But to no avail.

Then, light came. When I say "one time of two", this isn't random. One time it switches off and the try just after it reboots, and so on.

I didn't specify that I turn this PC on by wake on lan and that's the point. For if I use the power button there is no problem, it goes off all the time.

I recalled I didn't see any wol capabilities with ifconfig for this NIC (driver bge). I didn't pay much attention because it worked anyway, it seemed...

I put a NIC on the only PCI slot of this machine (driver vr) and there, I can use wol (ifconfig reports wol capabilities) and poweroff without trouble. But I have a new problem with this card: if I simulate a power failure, wol does not work anymore. I don't have this issue with the integrated NIC.

The poweroff problem is, I think, related to the FreeBSD driver bge. I say that because the integrated NIC works perfectly with Windows XP. So I can now rephrase my specific concern: is there a bge driver that supports wol? Maybe in the 12.0-CURRENT?
 

Emrion

New Member

Thanks: 2
Messages: 18

#6
I found two sources for having a wol aware bge driver. One is the driver from https://sourceforge.net/projects/nas4free/files/NAS4Free-11.1.0.4/11.1.0.4.5565/. It can be extracted from the iso. Other one consist to applying this patch: https://github.com/NamTaf/if_bge_wol and recompile the module if_bge.ko.

Both need to place the driver file if_bge.ko in /boot/kernel and force the kernel to load this module with loader.conf. And both well report wol_magic as option of the NIC. Finally, both just fail to actually activate wol. It doesn't work anymore with these drivers (no wake at all).

It's a good time to give up... :(
 
Top