Realtek RTL8187SE

DemoDoG

Active Member

Reaction score: 1
Messages: 193

Just my luck, I got my hands on an Acer EEE701SD which currently do not use the Atheros wirless card that is supported by madwifi.

Anyone knows if Realtek 8187SE cards can be run on FreeBSD? Perhaps with NDIS?
Can I put a request to include in CURRENT or if someone is working on it already?
 
OP
OP
D

DemoDoG

Active Member

Reaction score: 1
Messages: 193

Yeah sorry. It seems it´s not supported so I will try ndiswrapper.
 
OP
OP
D

DemoDoG

Active Member

Reaction score: 1
Messages: 193

Arglebargle.. ndiswrapper didn´t do it. I guess it was a long shot since I don´t see anything at all of the wlan card in dmesg. I guess I have to live on my hsdpa modem until a driver for RTL8187 arrives - if it does :)
 

richardpl

Aspiring Daemon

Reaction score: 68
Messages: 841

freebsd doesnt have ndiswrapper.
freebsd ndisulator supports usb devices only on recent 8.0

Both urtw and ndis on usb was done by same developer.
 
OP
OP
D

DemoDoG

Active Member

Reaction score: 1
Messages: 193

The handbook says:
The ndis driver is designed to support mainly Ethernet and wireless network devices with PCI and PCMCIA bus attachments.
(Cardbus devices are also supported as a subset of PCI.) It can support many different media types and speeds.

Although my card is using the PCIe and perhaps that is not supported by ndis.
 

richardpl

Aspiring Daemon

Reaction score: 68
Messages: 841

That is from old days, PCIe should not make any differences.

your Realtek is certainly usb device.
Post output of pciconf -lv for device you want to make work with ndis.
 
OP
OP
D

DemoDoG

Active Member

Reaction score: 1
Messages: 193

Thanx, I didn´t know about that command. Well it seems it has found the card atleast and that it is a networking class. Oh, how I would love this card to work :) I´m running CURRENT.
Here is the output of pciconf -lv:

none1@pci0:1:0:0: class=0x028000 card=0x819910ec chip=0x819910ec rev=0x22 hdr=0x00

vendor = 'Realtek Semiconductor'
class = network
 
OP
OP
D

DemoDoG

Active Member

Reaction score: 1
Messages: 193

I tried ndisulator in FreeBSD but it didn´t work. But the card disappeard from the pciconf -lv. It´s not listed at all, anymore. Wonder if that´s good or bad? :)
 

richardpl

Aspiring Daemon

Reaction score: 68
Messages: 841

How you attempted to use ndisulator, explain to me what you did and what kernel displayed.
 
OP
OP
D

DemoDoG

Active Member

Reaction score: 1
Messages: 193

I used the .INF and .SYS file from the Windows XP drivers included with the computer.

The kernel module was built successfully. I did kldload rtl8287Se_sys.ko and the module is loaded but nothing more happens. Also tried entering it to /boot/loader.conf and it was loaded at boot when I restarted. But no new device has showed up. Only difference is that it disappeared from psciconf -lv.

Is there perhaps something more to do to activate it?
 

richardpl

Aspiring Daemon

Reaction score: 68
Messages: 841

I cant imagine how it could disappear from pciconf.
You can try to load it again booting in verbose mode first and post dmesg output after kldload somewhere ...
 
OP
OP
D

DemoDoG

Active Member

Reaction score: 1
Messages: 193

Yeah I know there is no support for it in FreeBSD. I would like to give a try writing a driver myself. I have now installad Ubuntu on the machine and it found the card directly.

The command lspci in linux shows me RTL8187SE but when I rightclick on connection information when connected it says rtl8180. Either I will try do my own driver or perhaps buy a usb stick instead, but I dont like things sticking out of the computer :)
 

kostas_k

New Member


Messages: 3

Brigada,
I find this really interesting since I have an msi u90 with this wireless device. I want to install freeBSD but the wireless driver was repelling me from doing so. I have never used BSD and I haven't found much about the ndiscvt command in Google. Would it be possible for you to post the exact set of commands that are required to perform the conversion of the driver? I have already downloaded the driver from the link you provided. I am really sorry to ask for something that is probably well known but I only have a small experience on Unix based systems such as linux, not to speak for BSD which is tera incognita for me. Thanks in advance :).
Kostas
 

BRIGADA

New Member

Reaction score: 2
Messages: 2

kostas_k said:
I have never used BSD and I haven't found much about the ndiscvt command in Google.
Just type "man ndiscvt" or "man ndisgen" in console :)
I think, second command (ndisgen) will be simple way to you.

After converting you need load driver by kldload command.
 
Top