Read-only filesystem after configuring fstab

helmet1080

Member

Reaction score: 3
Messages: 49

I installed gnome3 and then configure a file, this file /etc/rc.conf like this
Code:
dbus_enable="YES"
hald_enable="YES"
Then I updated the file /etc/fstab with this
Code:
proc /proc procfs rw 0 0
I have only this partition / in virtual-box with the 512k partition. I didn't make much sense but I did.

I can't enter to the system with gdm3 installed. I think that this is because I read-only system. I enter Single User Mode, and I can't change fstab.
I don't know how to proceed to make the changes to the file. Thank you.

Here's the tutorial I followed. https://www.freebsd.org/doc/handbook/x11-wm.html
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,678
Messages: 30,595

Are you using ZFS or UFS?
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,678
Messages: 30,595

Alright, learn this by heart as you're going to need it every time you use single user mode. In single user mode only the root filesystem is mounted and will be read-only.

Code:
fsck -y           # check the filesystems for errors
mount -u /        # re-mount / read/write
mount -a -t ufs   # mount all other UFS filesystems
swapon -a         # Turn swap on
This will allow you to fix things. Only use single user mode to fix boot problems. It's not meant to be used for running the system.
 
OP
OP
helmet1080

helmet1080

Member

Reaction score: 3
Messages: 49

Alright, learn this by heart as you're going to need it every time you use single user mode. In single user mode only the root filesystem is mounted and will be read-only.

Code:
fsck -y           # check the filesystems for errors
mount -u /        # re-mount / read/write
mount -a -t ufs   # mount all other UFS filesystems
swapon -a         # Turn swap on
This will allow you to fix things. Only use single user mode to fix boot problems. It's not meant to be used for running the system.
Thank you! it worked!
Gnome requires proc to be mounted before being installed I think, and I did this on a second FreeBSD virtual machine.

proc /proc procfs rw 0 0

to fstab

I did all of the possibles solutions listed here to run Gnome. Gnome runs, but when I hover the login label, this changes, but I can't open it. Could it be virtualbox?
Should I create another thread for this?
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,678
Messages: 30,595

Always boot normally (multi-user) even if you're the only user (Single User Mode).

Gnome runs like crap on VirtualBox. It relies too heavily on 2D graphics acceleration, which VirtualBox doesn't provide for FreeBSD guests. The same is true for XFCE nowadays. "Simpler" window managers work a lot better. I personally like x11-wm/awesome and that runs just fine.
 
OP
OP
helmet1080

helmet1080

Member

Reaction score: 3
Messages: 49

Always boot normally (multi-user) even if you're the only user (Single User Mode).

Gnome runs like crap on VirtualBox. It relies too heavily on 2D graphics acceleration, which VirtualBox doesn't provide for FreeBSD guests. The same is true for XFCE nowadays. "Simpler" window managers work a lot better. I personally like x11-wm/awesome and that runs just fine.
Thank you! I installed FreeBSD on the desktop machine, and now I'm resolving the wireless usb adapter connection, to connect to internet. I'll create another thread for that. I'll use awesome in the future.
 
OP
OP
helmet1080

helmet1080

Member

Reaction score: 3
Messages: 49

I'm still using virtualbox. I'm running the system with KDE Plasma. Here's a guide to install it. Later I plan to switch to a more light weight desktop manager like awesome. Awesome worked! But I don't know how to use it yet. I wanted something graphical ready to use.
 
Top