• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Solved raspbsd on pi3 with a 1024x768 8" monitor spilling over screen.

clawhammer

Member

Thanks: 5
Messages: 91

#1
I have tried all the overscan options, the hdmi mode and group options, turning overscan on and off. I am at my wits end with this. When I modify the /boot/config.txt file and change display setting when I reboot the pi3 nothing on the screen changes at all.


EDIT:____________________________
I reformatted my sd card with FreeBSD-aarch64-12.0-GENERIC-320146M.img and the screen issue is fixed. I don't know what happened but obviously something got corrupted. thanks for all your help trying to figure it out.

I had an earlier version of freebsd on the pi3 and maybe it wasnt fully supported.

Nevermind. It started doing it again when I restarted the pi3. I figured out i need to unplug the power supply from the monitor before turning the pi3 on. Only having the monitor off will put the text off the screen.
 
Last edited:

Sensucht94

Active Member

Thanks: 144
Messages: 182

#2
Try something like, commenting all overscan entries:
Code:
hdmi_ignore_edid=0xa5000080
hdmi_force_hotplug=1
hdmi_drive=2
config_hdmi_boost=7
hdmi_group=2
hdmi_mode=16
framebuffer_depth=8
framebuffer_width=1024
framebuffer_height=768
 

clawhammer

Member

Thanks: 5
Messages: 91

#3
Try something like, commenting all overscan entries:
Code:
hdmi_ignore_edid=0xa5000080
hdmi_force_hotplug=1
hdmi_drive=2
config_hdmi_boost=7
hdmi_group=2
hdmi_mode=16
framebuffer_depth=8
framebuffer_width=1024
framebuffer_height=768
thanks. I'll try it out when I have access to my pi.
 

clawhammer

Member

Thanks: 5
Messages: 91

#4
Try something like, commenting all overscan entries:
Code:
hdmi_ignore_edid=0xa5000080
hdmi_force_hotplug=1
hdmi_drive=2
config_hdmi_boost=7
hdmi_group=2
hdmi_mode=16
framebuffer_depth=8
framebuffer_width=1024
framebuffer_height=768
I tried what you suggest and nothing on the screen changed. Could something be wrong with the screen instead of the config.txt file? Is there another config file that could be overriding the setting in the /boot/config.txt?
I also removed the plastic case around the screen thinking it might be overlapping the screen but it wasnt.
also the monitor wont even light up when I change the aspect ration on the monitor setting to 4:3 instead of 16:9.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Thanks: 5,508
Messages: 25,688

#5
change display setting when I reboot the pi3 nothing on the screen changes at all.
It's probably the TV or monitor that's scaling the picture.
 

clawhammer

Member

Thanks: 5
Messages: 91

#6
It's probably the TV or monitor that's scaling the picture.
I was thinking that also but I recently read that someone was having an issue where the pi wasnt formatted correctly and was reading the /boot directory. I am going to redo my sd card and see if that fixes it.
 

Sensucht94

Active Member

Thanks: 144
Messages: 182

#7
I tried what you suggest and nothing on the screen changed. Could something be wrong with the screen instead of the config.txt file? Is there another config file that could be overriding the setting in the /boot/config.txt?
I also removed the plastic case around the screen thinking it might be overlapping the screen but it wasnt.
also the monitor wont even light up when I change the aspect ration on the monitor setting to 4:3 instead of 16:9.
I usually had (and have) similar problems only with a VGA monitor. Perhaps you're using a VGA monitor with a HDMI2VGA adapter like me?
Are you 100% monitor is 1024x768? I remember having owned one many years ago which had some weird rarer resolution like 1024x600. Supported resolution include only the ones listed among Raspberry video options
You could also try forcing vt resolution, but as SirDice stated, I second his opinion about the monitor issue. Anyway you could put something like that, inside /boot/loader.conf

Code:
kern.vty=vt
hw.vga.textmode=1
kern.vt.fb.default_mode="1024x768"