Solved Raspberry Pi3 FreeBSD 13 Fails To Update "because upgrading from this platform (arm64) is unsupported"

Master Bacon

New Member

Reaction score: 2
Messages: 8

I'm having no issue installing OS onto SD card and having the device boot and run. I used the following img and have used both raspberry pi imager and etcher to flash the card:
FreeBSD-13.0-RELEASE-arm64-aarch64-RPI.img.xz

However, once booted I'm unable to use basic operations like freebsd-update fetch, or even any pkg command.

When I attempt to update, it fails to find any mirrors and states "This may be because upgrading from this platform (arm64) or release (13.0-RELEASE) is unsupported by freebsd-update."

But from what I've read online, it seems arm64 was upgraded to Tier-1?

Not sure what the problem is exactly, I'm assuming its something simple regarding my installation...
 
OP
M

Master Bacon

New Member

Reaction score: 2
Messages: 8

root@generic:~ # pkg bootstrap -f
The package management tool is not yet installed on your system.
Do you want to fetch and install it now? [y/N]: y
Bootstrapping pkg from pkg+http://pkg.FreeBSD.org/FreeBSD:13:aarch64/quarterly, please wait...
epkg: Error fetching http://pkg.FreeBSD.org/FreeBSD:13:aarch64/quarterly/Latest/pkg.txz: No address record
Address resolution failed for http://pkg.FreeBSD.org/FreeBSD:13:aarch64/quarterly.
Consider changing PACKAGESITE.


and in case its helpful to someone, here is the code output from freebsd-update fetch:

root@generic:~ # freebsd-update fetch
src component not installed, skipped
Looking up update.FreeBSD.org mirrors... none found.
Fetching public key from update.FreeBSD.org... failed.
No mirrors remaining, giving up.

This may be because upgrading from this platform (arm64)
or release (13.0-RELEASE) is unsupported by freebsd-update. Only
platforms with Tier 1 support can be upgraded by freebsd-update.
See https://www.freebsd.org/platforms/index.html for more info.

If unsupported, FreeBSD must be upgraded by source.
 
OP
M

Master Bacon

New Member

Reaction score: 2
Messages: 8

There's a networking issue.

Without sharing the details, consider output from commands such as these:

ifconfig
cat /etc/resolv.conf
cat /etc/resolvconf.conf
route show default
I wondered if it was networking too, but that seems to be working fine.

Outputs from those are device local ip and local domain name.

I can SSH into device, ping Google, etc.


I cant explain or understand why the pi seems like it doesnt know arm is now tier 1
 

Erichans

Member

Reaction score: 38
Messages: 50

I presume you're SSH-ing from within your local network?

From your raspberry do you get a response from both:
$ ping -c 3 8.8.8.8
$ ping -c 3 google.com
 
OP
M

Master Bacon

New Member

Reaction score: 2
Messages: 8

I presume you're SSH-ing from within your local network?

From your raspberry do you get a response from both:
$ ping -c 3 8.8.8.8
$ ping -c 3 google.com
seems it cannot ping google.com, outputs below


root@generic:~ # ping -c 3 8.8.8.8
PING 8.8.8.8 (8.8.8.8): 56 data bytes
64 bytes from 8.8.8.8: icmp_seq=0 ttl=115 time=4.880 ms
64 bytes from 8.8.8.8: icmp_seq=1 ttl=115 time=4.962 ms
64 bytes from 8.8.8.8: icmp_seq=2 ttl=115 time=4.739 ms

--- 8.8.8.8 ping statistics ---
3 packets transmitted, 3 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 4.739/4.861/4.962/0.092 ms

root@generic:~ # ping -c 3 google.com
ping: Unknown host
root@generic:~ #
 

eternal_noob

Aspiring Daemon

Reaction score: 515
Messages: 745

Maybe try add additional nameservers:
Code:
# Generated by resolvconf
search home.local
nameserver 192.168.1.1
nameserver 8.8.8.8
nameserver 1.1.1.1
 

Erichans

Member

Reaction score: 38
Messages: 50

When adding nameservers do not give the desired result, what is the output from
$ cat /etc/nsswitch.conf | grep hosts
 
OP
M

Master Bacon

New Member

Reaction score: 2
Messages: 8

SOLVED! Thank you all for taking the time to write and help

It was an issue with nameservers. adding google and/or cloudflare nameservers let the pi fetch update

I forgot between my original boot of freebsd on my pi and this current one that I set up my own OPNsense router. I haven't had much issues with it, but adding cloudflare nameservers to my DNS allows my pi to fetch update without specifying additional nameservers in my device config (i'm learning!)
 
OP
M

Master Bacon

New Member

Reaction score: 2
Messages: 8

Thanks,



– to /etc/resolvconf.conf, yes?

(The content of /etc/resolv.conf is transient.)
I added to /etc/resolv.conf, which fixed the problem.

Then I reset the file without these nameservers to see if updating my DNS nameservers on router would fix the problem as an "up-stream" solution (it did)


I'm new to BSD, so will have to look more into differences between similar files and what you mean by the file I edited being transient (i'm guessing its temporary/lost on boot, off the top of my head)
 

Erichans

Member

Reaction score: 38
Messages: 50

I added to /etc/resolv.conf, which fixed the problem.
[...]
I'm new to BSD, so will have to look more into differences between similar files and what you mean by the file I edited being transient (i'm guessing its temporary/lost on boot, off the top of my head)

I have my nameserver entries in /etc/resolv.conf as well; no nameserver entries in my /etc/resolvconf.conf. Under certain settings /etc/resolv.conf gets (re)generated, i.e.: transient; in that case you better not place the nameserver entries in that file.

What is your output from:
$ cat /etc/resolvconf.conf | grep resolv_conf
 
Top