Raspberry Pi B+ and Xorg not works

kecskefasz

New Member

Reaction score: 1
Messages: 8

Hi.

I'm trying to breathe life to Xorg under my RPi, without succes. I installed Xorg and xf86-video-scfb with pkg.

Whenever i run startx, this is the result:
Code:
xauth:  file /root/.serverauth.948 does not exist
xauth: (argv):1:  bad display name "raspberry-pi:0" in "list" command
xauth: (stdin):1:  bad display name "raspberry-pi:0" in "add" command


X.Org X Server 1.17.4
Release Date: 2015-10-28
X Protocol Version 11, Revision 0
Build Operating System: FreeBSD 12.0-CURRENT arm
Current Operating System: FreeBSD raspberry-pi 12.0-CURRENT FreeBSD 12.0-CURRENT #0 r312722M: Tue Jan 24 15:19:14 MST 2017     brd@hive.raspbsd.org:/usr/local/raspbsd/obj/RPI-B/obj/arm.armv6/usr/local/raspbsd/src/common/sys/RPI-B arm
Build Date: 31 January 2017  03:34:34PM

Current version of pixman: 0.34.0
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Wed Jan 25 02:37:37 2017
(==) Using config file: "/etc/X11/xorg.conf"
scfb trace: probe start
scfb trace: probe done
scfb: PreInit 0
(EE)
Fatal server error:
(EE) no screens found(EE)
(EE)
Please consult the The X.Org Foundation support
         at http://wiki.x.org
 for help.
(EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
(EE)
(EE) Server terminated with error (1). Closing log file.
xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error
xauth: (argv):1:  bad display name "raspberry-pi:0" in "remove" command
This is my Xorg.log:
Code:
[  1675.529]
X.Org X Server 1.17.4
Release Date: 2015-10-28
[  1675.532] X Protocol Version 11, Revision 0
[  1675.533] Build Operating System: FreeBSD 12.0-CURRENT arm
[  1675.535] Current Operating System: FreeBSD raspberry-pi 12.0-CURRENT FreeBSD 12.0-CURRENT #0 r312722M: Tue Jan 24 15:19:14 MST 2017     brd@hive.raspbsd.org:/usr/local/raspbsd/obj/RPI-B/obj/arm.armv6/usr/local/raspbsd/src/common/sys/RPI-B arm
[  1675.731] Build Date: 31 January 2017  03:34:34PM
[  1675.732]  
[  1675.733] Current version of pixman: 0.34.0
[  1675.734]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[  1675.735] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  1675.743] (==) Log file: "/var/log/Xorg.0.log", Time: Wed Jan 25 02:43:04 2017
[  1675.755] (==) Using config file: "/etc/X11/xorg.conf"
[  1675.949] (==) ServerLayout "layout"
[  1675.950] (**) |-->Screen "Screen" (0)
[  1675.952] (**) |   |-->Monitor "<default monitor>"
[  1675.958] (**) |   |-->Device "Generic FB"
[  1675.959] (==) No monitor specified for screen "Screen".
   Using a default monitor configuration.
[  1675.960] (**) |-->Input Device "Mouse1"
[  1675.961] (**) |-->Input Device "Keyboard1"
[  1675.963] (**) Option "AIGLX" "false"
[  1675.965] (**) Option "DRI2" "False"
[  1675.966] (==) Automatically adding devices
[  1675.967] (==) Automatically enabling devices
[  1675.968] (==) Not automatically adding GPU devices
[  1676.001] (==) FontPath set to:
   /usr/local/share/fonts/misc/,
   /usr/local/share/fonts/TTF/,
   /usr/local/share/fonts/OTF/,
   /usr/local/share/fonts/Type1/,
   /usr/local/share/fonts/100dpi/,
   /usr/local/share/fonts/75dpi/
[  1676.002] (==) ModulePath set to "/usr/local/lib/xorg/modules"
[  1676.003] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[  1676.004] (WW) Disabling Mouse1
[  1676.004] (WW) Disabling Keyboard1
[  1676.005] (II) Loader magic: 0x217ecc
[  1676.006] (II) Module ABI versions:
[  1676.007]    X.Org ANSI C Emulation: 0.4
[  1676.007]    X.Org Video Driver: 19.0
[  1676.008]    X.Org XInput driver : 21.0
[  1676.009]    X.Org Server Extension : 9.0
[  1676.015] (WW) "dri" will not be loaded unless you've specified it to be loaded elsewhere.
[  1676.016] (WW) "dri2" will not be loaded unless you've specified it to be loaded elsewhere.
[  1676.016] (WW) "glx" will not be loaded unless you've specified it to be loaded elsewhere.
[  1676.017] (II) "glx" will be loaded even though the default is to disable it.
[  1676.018] (II) LoadModule: "dbe"
[  1676.020] (II) Module "dbe" already built-in
[  1676.021] (II) LoadModule: "extmod"
[  1676.022] (II) Module "extmod" already built-in
[  1676.023] (II) LoadModule: "scfb"
[  1676.045] (II) Loading /usr/local/lib/xorg/modules/drivers/scfb_drv.so
[  1676.051] (II) Module scfb: vendor="X.Org Foundation"
[  1676.052]    compiled for 1.17.4, module version = 0.0.4
[  1676.053]    ABI class: X.Org Video Driver, version 19.0
[  1676.054] (II) scfb: driver for wsdisplay framebuffer: scfb
[  1676.061] (--) Using syscons driver with X support (version 2.0)
[  1676.062] (--) using VT number 5

[  1676.064] (WW) Falling back to old probe method for scfb
[  1676.065] scfb trace: probe start
[  1676.067] (II) scfb(0): using default device
[  1676.068] scfb trace: probe done
[  1676.069] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
[  1676.070] scfb: PreInit 0
[  1676.073] (II) scfb(0): Using: depth (24),   width (1024),    height (768)
[  1676.074] (EE) scfb(0): specified depth (24) or bpp (32) doesn't match framebuffer depth (24)
[  1676.075] (II) UnloadModule: "scfb"
[  1676.076] (EE) Screen(s) found, but none have a usable configuration.
[  1676.077] (EE)
Fatal server error:
[  1676.079] (EE) no screens found(EE)
[  1676.082] (EE)
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
[  1676.084] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[  1676.086] (EE)
[  1676.094] (EE) Server terminated with error (1). Closing log file.
And this is my xorg.conf:
Code:
Section "Files"
EndSection

Section "Module"
    Load        "dbe"
    Disable    "dri"
    Disable    "dri2"
    Disable    "glx"
    SubSection  "extmod"
        Option  "omit xfree86-dga"
    EndSubSection
EndSection

Section "ServerFlags"
    Option    "AIGLX"        "false"
    Option    "NoAccel"    "True"
    Option    "NoDRI"        "True"
    Option    "DRI"        "False"
    Option    "DRI2"        "False"
EndSection

Section "InputDevice"
    Identifier  "Keyboard1"
    Driver      "kbd"
EndSection

Section "InputDevice"
    Identifier  "Mouse1"
    Driver      "mouse"
    Option      "Protocol"      "auto"
    Option      "Device"        "/dev/sysmouse"
EndSection

Section "Device"
    Identifier  "Generic FB"
    Driver      "scfb"
    Option    "NoAccel"    "True"
EndSection

Section "Screen"
    Identifier  "Screen"
    Device      "Generic FB"
    Monitor     "Monitor"
    DefaultDepth 24
    SubSection "Display"
        Depth           24
        Modes           "1024x768"
    EndSubsection
EndSection

Section "ServerLayout"
    Identifier  "layout"
    Screen      0 "Screen" 0 0
    InputDevice "Mouse1" "CorePointer"
    InputDevice "Keyboard1" "CoreKeyboard"
EndSection
And my .xinitrc
Code:
xterm &
exec twm

I don't understand a thing. I did not even specified a display named "raspberry-pi:0". Does FreeBSD stores the config at another file? But it says, it's using /etc/X11/xorg.conf

Xorg -configure did not helped too. It does not even creates the config, just crashes with similar messages than startx.
 
Top