Solved Raspberry Pi 4

Samuel Venable

Active Member

Reaction score: 83
Messages: 110

Hi.

Searched the forum and found a lot of topics about the RPi4 and similar devices, but none with this specific issue mentioned, which really surprised me.

Installed to a microsd card the RPI3 img from here: https://www.freebsd.org/where/

More specifically, the 12.2-RELEASE version. Tried both balenaEtcher and Raspberry Pi Imager. Neither worked. Booted the pi, and it claims no sd card is inserted, asking to insert an sd card. The same screen you get when no card is inserted, but with some errors saying it can't find a boot file or something like that.

Also, for clarity, this page: https://wiki.freebsd.org/arm/Raspberry Pi says: "For Raspberry Pi 4 use the image for RPI3."

No idea what's going on, and was hoping someone could help?
Samuel
 

msplsh

Well-Known Member

Reaction score: 161
Messages: 493

This works for me on RPI3, sorry I don't have a 4 to test

unxz FreeBSD-12.2-RELEASE-arm64-aarch64-RPI3.img.xz
dd if=FreeBSD-12.2-RELEASE-arm64-aarch64-RPI3.img of=/dev/disk2 bs=10240
 
Last edited:

tingo

Daemon

Reaction score: 602
Messages: 2,484

Based on feedback from the mailing lists, RPi4 needs a newish firmware on the SDcard (warning: this is firmware files that the Pi loads from the SD card when it boots, it is not the EEPROM contents / update - that is a different thing).- I think 12.2-RELEASE is too old to have the correct files for the Pi4 on it.
Try to boot a FreeBSD 13.0-RC5 image on your Pi4, if that works you can try to copy the relevant firmware files (for the Pi4) from the 13.0-RC5 sdcard to the 12.2-RELEASE card.
Note: I haven't tested this myself (yet).
 

hpc

New Member

Reaction score: 1
Messages: 18

Hello, I didn't remember, why but BSD 13 has a better support for RPI4.

I've start to build a RPI4 cluster. I try to share some experiments, you'll find info on the installation of FreeBSD 13 on this blog post :

 

tingo

Daemon

Reaction score: 602
Messages: 2,484

FWIW, I got the FreeBSD 13.0-RC5 image to boot on my Pi4 (8 GB). The boot process was .. strange. I had to "prod" the keyboard a few times (by pressing a key), it looked like the boot process fell asleep. I wrote the image like this xz -dc FreeBSD-13.0-RC5-arm64-aarch64-RPI.img.xz | sudo dd of=/dev/da5 bs=4M status=progress (da5 is my SD card reader).
Code:
root@generic:~ # freebsd-version -ku
13.0-RC5
13.0-RC5
root@generic:~ # uname -a
FreeBSD generic 13.0-RC5 FreeBSD 13.0-RC5 #0 releng/13.0-n244727-f8a134d0ef1: Fri Apr  2 06:15:20 UTC 2021
     root@releng1.nyi.freebsd.org:/usr/obj/usr/src/arm64.aarch64/sys/GENERIC  arm64
I hope this helps.
 
Top