Solved Qtile 0.17.1 and default twm boots into black screen

r2com

Member

Reaction score: 5
Messages: 82

So I installed all dependencies, then git checked latest version and did "pip install ." all went OK.

then in my .xinitrc inside home folder I got these two lines:
#!/bin/sh
exec qtile start

and when I type startx as user it loads into black screen.

By the way, starting "startx" as root actually boots OK into default window manager - twm. so that I assume means that X is working OK and no issues there.

then I did another test, I removed "exec qtile start" from .xinitrc of users home folder and did "startx" - thinking that then I should boot into default window manager - twm, but I again get black screen.

where should I look into?
 

chrbr

Aspiring Daemon

Reaction score: 351
Messages: 866

To start twm write the line
Code:
exec /usr/local/bin/twm
which is the full path to twm. Regarding qtile I am not sure. Please run whereis qtile. This should output the full path of the executable. It might be that the trailing start in your .xintrc is not necessary. At least it is not necessary for twm.
 

T-Daemon

Daemon

Reaction score: 788
Messages: 1,622

starting "startx" as root actually boots OK into default window manager - twm. ...

... I removed "exec qtile start" from .xinitrc of users home folder and did "startx" - thinking that then I should boot into default window manager - twm, but I again get black screen.

Which graphics card does the machine have, and how is it configured? In case it's AMD or INTEL and a drm-fbsdX-kmod is installed and configured, is the user in the video group? Check /var/log/Xorg.0.log for errors, hints.

Also please show the version of FreeBSD installed.

in my .xinitrc inside home folder I got these two lines:
#!/bin/sh
exec qtile start

According to Qtile manual exec qtile is all that is needed.
 
OP
R

r2com

Member

Reaction score: 5
Messages: 82

system: 12.2-RELEASE-p4
graphics card: it is some old laptop, I think its Intel HD Graphics 4000. I didn't do anything about configuring it.
user is part of video group
/var/log/Xorg.0.log doesnt show anything outstanding
 
OP
R

r2com

Member

Reaction score: 5
Messages: 82

yes user is in the wheel group.
having "exec /usr/local/bin/qtile" also did not work. neither did "exec /usr/local/bin/twm"

what else could be missing? again, when running "startx" as root it perfectly loads into twm.
 

bsduck

Active Member

Reaction score: 129
Messages: 174

What about running startx as user without any .xinitrc ?
If it doesn't work either, you probably have to add your user to the "video" group.
 

covacat

Well-Known Member

Reaction score: 170
Messages: 365

Code:
#!/bin/sh
export DISPLAY=:0
X &
sleep 2
xclock &
xterm -geometry 80x25+200+100 &
try this
bypass xinit and see if you get a clock and a term
 
OP
R

r2com

Member

Reaction score: 5
Messages: 82

ok so here is some update... as bsduck suggested, I tried to just delete .xinitrc and do "startx" as user. and it worked! perfectly loaded into twm!

now.. next step is figure out how can I start into qtile
in that case the question is: where I must modify proper settings for successful start of qtile?
 

covacat

Well-Known Member

Reaction score: 170
Messages: 365

default xinit 'clientsetup' is
/usr/local/etc/X11/xinit/xinitrc
try to copy it as your .xinitrc and replace twm with qtile
 
OP
R

r2com

Member

Reaction score: 5
Messages: 82

covacat, so I copied over that file into .xinitrc (looked at it, it was kinda verbose)

then without changing anything I did "startx", and did load OK into twm.

next, after reboot, I changed line "twm &" to "qtile &" inside that file and did "startx" and again black screen...
 
OP
R

r2com

Member

Reaction score: 5
Messages: 82

so is there someone specifically using qtile on FreeBSD so that he can share settings maybe or any additional piece of info I might be missing?
 
OP
R

r2com

Member

Reaction score: 5
Messages: 82

that port is really obsolete. 0.14.2 is an old version and not recommended by devs.

so I am really trying to figure out what the problem is, or maybe get some hint for a way to figure it out
 
OP
R

r2com

Member

Reaction score: 5
Messages: 82

if I start normally into twm, and then in its xterm terminal do:
/usr/local/bin/qtile start

strange thing happens...some window created at the point of cursor, and no matter where I "drop" that window and click, the whole screen changes into what looks like twm's subwindow... and inside on top i see bar "1 2 3 4...9 none... then on top right i see date and time"

so.. ?
 
OP
R

r2com

Member

Reaction score: 5
Messages: 82

Also, let me paste here the .xinitrc which I have, maybe it will be indicative of something:
#!/bin/sh

userresources=$HOME/.Xresources
usermodmap=$HOME/.Xmodmap
sysresources=/usr/local/etc/X11/xinit/.Xresources
sysmodmap=/usr/local/etc/X11/xinit/.Xmodmap

# merge in defaults and keymaps

if [ -f $sysresources ]; then







xrdb -merge $sysresources

fi

if [ -f $sysmodmap ]; then
xmodmap $sysmodmap
fi

if [ -f "$userresources" ]; then







xrdb -merge "$userresources"

fi

if [ -f "$usermodmap" ]; then
xmodmap "$usermodmap"
fi

# start some nice programs

if [ -d /usr/local/etc/X11/xinit/xinitrc.d ] ; then
for f in /usr/local/etc/X11/xinit/xinitrc.d/?*.sh ; do
[ -x "$f" ] && . "$f"
done
unset f
fi


twm &
xclock -geometry 50x50-1+1 &
xterm -geometry 80x50+494+51 &
xterm -geometry 80x20+494-0 &
exec xterm -geometry 80x66+0+0 -name login

the above setup with that "twm &" works beautifylly, i.e. twm starts and operates just fine.
but not the qtile.

also I tried this instead of the "twm &" line:
"/usr/local/bin/qtile start" with or without "exec" in front. and same result every time - black screen.

one thing I noticed is, the file .local/share/qtile/qtile.log is NOT created every failed attempt. which strangely suggests that qtile is NOT even started, even though line in .xinitrc exists.

for example that log file IS created when I manually try to load qtile from console (which is wrong of course).

so I'd appreciate if some "qtile person" if there are any here could kick in and shade some light
 

covacat

Well-Known Member

Reaction score: 170
Messages: 365

Code:
xterm &
qtile start &
sleep 10000000
this works for me in .xinitrc. otherwise (exec qtile) i get a black screen
 
OP
R

r2com

Member

Reaction score: 5
Messages: 82

wow ok! so here is what happened when I appended those 3 lines you showed:
I actually did start into qtile! I see on bottom a bar with 1...2...3....etc and bottom right I see a date and time.

now... in middle and top (or the rest of screen area) I see the console of xterm... kinda weird....so?... is this like normal or? shouldnt it just be empy space for desktop?

another question is... what about that 10M sleep command?? why? (without last line it was again black screen)... so is that ok or no?
 
OP
R

r2com

Member

Reaction score: 5
Messages: 82

is there workaround in such a way that I don't need to bound myself with long sleep time?
 

covacat

Well-Known Member

Reaction score: 170
Messages: 365

is there workaround in such a way that I don't need to bound myself with long sleep time?
sleep prevents xinit exiting.
for some reason it doesn't work correctly if you exec qtile
probably cleaner workarounds exist but i'm to lazy to experiment
 
OP
R

r2com

Member

Reaction score: 5
Messages: 82

thanks for that hint, well, at least I can load qtile and actually use it now.
I guess later I will research cleaner ways/workarounds and setups.

I'd call it solved for now.
 
Top