QT5 breaks FreeBSD 11.3 and 11.4

Datapanic

Well-Known Member

Reaction score: 219
Messages: 428

Code:
Poudriere ignored ports: "qt5-network-5.15.0 is marked as broken: Qt5 requires Openssl 1.1.1, upgrade to FreeBSD 12.x/13.x or add DEFAULT_VERSIONS+=ssl=[openssl|libressl*] to /etc/make.conf"
I tried setting openssl in my poudriere make file for FreeBSD 11.3 and 11.4 builds, but that just breaks other ports. When FreeBSD 12.0 came out, I only tried it briefly because its support only for openssl 1.1.1 broke so many other ports that there was no way I could use it.

Is it safe to upgrade to 12.x now? I really need qt5 for desktop and other packages that rely on openssl that works. I would rather stay with FreeBSD 11.4 - it is a supported version. Any advice?
 
OP
Datapanic

Datapanic

Well-Known Member

Reaction score: 219
Messages: 428

I changed the Makefile for qt5-network to not run the FreeBSD version check that sets the port broken for anything less than 12.0. Ran poudriere again and qt5-network and all the other qt5 ports dependent on qt5-network built just fine.
 

pestslent1

Member

Reaction score: 5
Messages: 84

I just installed 11.4 RELEASE and I am using "synth" to manage my ports. I believe I have hit a similar roadblock. How did you, " I changed the Makefile for qt5-network to not run the FreeBSD version check that sets the port broken for anything less than 12.0" ? I looked at the Makefile and did not see where to do this.
Is there a better way since this post?

Thanks
 
OP
Datapanic

Datapanic

Well-Known Member

Reaction score: 219
Messages: 428

pestslent1 - Comment out lines 27 - 30 of the Makefile. Here's the patch:
Code:
--- /usr/ports/net/qt5-network/Makefile 2020-07-05 23:43:37.000000000 -0700
+++ Makefile    2020-07-15 15:40:34.633215000 -0700
@@ -24,10 +24,10 @@

 .include <bsd.port.pre.mk>

-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1200085 && ${SSL_DEFAULT} == "base"
+#.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1200085 && ${SSL_DEFAULT} == "base"
 # 1200085      339270  October 19, 2018        12.0-STABLE after updating OpenSSL to version 1.1.1.
-BROKEN=                Qt5 requires Openssl 1.1.1, upgrade to FreeBSD 12.x/13.x or add DEFAULT_VERSIONS+=ssl=[openssl|libressl*] to /etc/make.conf
-.endif
+#BROKEN=               Qt5 requires Openssl 1.1.1, upgrade to FreeBSD 12.x/13.x or add DEFAULT_VERSIONS+=ssl=[openssl|libressl*] to /etc/make.conf
+#.endif

 post-patch:
        @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
This is only a temporary fix - it does build on FreeBSD 11.4 for qt5 version 5.15 without error, but eventually it wont work with FreeBSD 11.3 or 11.4 and there are no plans to make it work with openSSL 1.0.x. The other option is to use the security/openssl in the ports tree, but I ran into even more dependency problems with other ports doing that.
 

the3ajm

New Member


Messages: 8

I tried setting openssl in my poudriere make file for FreeBSD 11.3 and 11.4 builds, but that just breaks other ports. When FreeBSD 12.0 came out, I only tried it briefly because its support only for openssl 1.1.1 broke so many other ports that there was no way I could use it.

Is it safe to upgrade to 12.x now? I really need qt5 for desktop and other packages that rely on openssl that works. I would rather stay with FreeBSD 11.4 - it is a supported version. Any advice?
I've just upgraded to 12.1 from 11.4 when I noticed that pkg wants to remove kde related packages which seems to follow the reason that Qt5 dropped support. I'm not going through the port tree route as I'm worried about future dependencies problem that might prop up, I'm interested to know if you've used the port tree to stay on 11.4.
 
OP
Datapanic

Datapanic

Well-Known Member

Reaction score: 219
Messages: 428

I've just upgraded to 12.1 from 11.4 when I noticed that pkg wants to remove kde related packages which seems to follow the reason that Qt5 dropped support. I'm not going through the port tree route as I'm worried about future dependencies problem that might prop up, I'm interested to know if you've used the port tree to stay on 11.4.
I am staying on 11.4 for now. I only have 1 computer with 11.4 and Mate but I rarely use it. I use Poudriere with Portshaker to customize my ports tree. I have one vm running 12.1 that uses the same ports tree and package list for later on when it is time to upgrade to 12 or 13.
 
Top