qt4 update

A

Anonymous

Guest


After portmaster -ad:

===>>> Starting build for ports that need updating <<<===

===>>> Launching child to update qt4-moc-4.4.1

===>>> Port directory: /usr/ports/devel/qt4-moc
===>>> Starting check for build dependencies
===>>> Gathering dependency list for devel/qt4-moc from ports
===>>> Starting dependency check
===>>> Launching child to update qt4-qmake-4.4.1 to qt4-qmake-4.4.3
qt4-moc-4.4.1 >> qt4-qmake-4.4.1

===>>> Port directory: /usr/ports/devel/qmake4
===>>> Starting check for build dependencies
===>>> Gathering dependency list for devel/qmake4 from ports
===>>> No dependencies for devel/qmake4
===> Cleaning for qt4-qmake-4.4.3

===> Extracting for qt4-qmake-4.4.3
=> MD5 Checksum mismatch for KDE/qt-x11-opensource-src-4.4.3.tar.gz.
=> SHA256 Checksum mismatch for KDE/qt-x11-opensource-src-4.4.3.tar.gz.
===> Refetch for 1 more times files: KDE/qt-x11-opensource-src-4.4.3.tar.gz KDE/qt-x11-opensource-src-4.4.3.tar.gz
=> qt-x11-opensource-src-4.4.3.tar.gz doesn't seem to exist in /usr/ports/distfiles/KDE.
=> Attempting to fetch from ftp://ftp.iasi.roedu.net/mirrors/ftp.trolltech.com/qt/source/.
fetch: ftp://ftp.iasi.roedu.net/mirrors/ftp.trolltech.com/qt/source/qt-x11-opensource-src-4.4.3.tar.gz: File unavailable (e.g., file not found, no access)
=> Attempting to fetch from ftp://ftp.ntua.gr/pub/X11/Qt/qt/source/.
fetch: qt-x11-opensource-src-4.4.3.tar.gz: local modification time does not match remote
=> Attempting to fetch from ftp://ftp.tu-chemnitz.de/pub/Qt/qt/source/.
...
...
Same as above and error 1
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 13,907
Messages: 40,632

rm /usr/ports/distfiles/KDE/gt-x11-opensource-src-4.4.3.tar.gz

and try again :)
 
OP
A

Anonymous

Guest


SirDice said:
rm /usr/ports/distfiles/KDE/gt-x11-opensource-src-4.4.3.tar.gz

and try again :)

No, it doesn't help.
 

macbias

Member

Reaction score: 3
Messages: 63

rm /usr/ports/distfiles/KDE/qt-x11-opensource-src-4.4.3.tar.gz

just a typo error , notice qt not gt-x11.
 
OP
A

Anonymous

Guest


mdma said:
rm /usr/ports/distfiles/KDE/qt-x11-opensource-src-4.4.3.tar.gz

just a typo error , notice qt not gt-x11.

As I wrote before it doesn't works.
 

macbias

Member

Reaction score: 3
Messages: 63

this part

-- local modification time does not match remote ---

usually means (if i'm not mistaken) that u may have just part of the file still in /ports/distfiles; meaning it could have started to download earlier and got interrupted.

first try to go into /ports/distfiles/KDE, see what files u have there and delete the qt-x11 ones (rm qt-x11*)

if that doesn't work, try to download the file manually with your web browser from ftp.freebsd.org (usually in -> pub -> distfiles) and then copy it to /ports/distfiles/KDE/

that file is about 100mb i think

there was some other reason this could be happening but i can't recall right now. from ftp u should be ok
 
OP
A

Anonymous

Guest


mdma said:
this part

-- local modification time does not match remote ---

usually means (if i'm not mistaken) that u may have just part of the file still in /ports/distfiles; meaning it could have started to download earlier and got interrupted.

first try to go into /ports/distfiles/KDE, see what files u have there and delete the qt-x11 ones (rm qt-x11*)

if that doesn't work, try to download the file manually with your web browser from ftp.freebsd.org (usually in -> pub -> distfiles) and then copy it to /ports/distfiles/KDE/

that file is about 100mb i think

there was some other reason this could be happening but i can't recall right now. from ftp u should be ok

I did clean and try again: everything is the same:
=> MD5 Checksum mismatch for KDE/qt-x11-opensource-src-4.4.3.tar.gz.
=> SHA256 Checksum mismatch for KDE/qt-x11-opensource-src-4.4.3.tar.gz.
than or file didn't file or modification time. I look on ftp.freebsd.org server in /distfiles directory but this file doesn't exist there.
 

jb_fvwm2

Daemon

Reaction score: 227
Messages: 1,868

various qt4 port files (1?) need updating before
fetching the correct latest distfinfo in most any
particular one. ... Simply wait a day or so
and re-csup, cvsup, or ... your ports tree and the
fetches should work. I did not find out which file
caused the problem.
 

Brandybuck

Active Member

Reaction score: 12
Messages: 147

lumiwa said:
I did clean and try again: everything is the same:

Yes, but did you REMOVE /usr/ports/distfiles/KDE/qt-x11-opensource-src-4.4.3.tar.gz? It sounds like you might have a corrupted copy.
 
OP
A

Anonymous

Guest


Brandybuck said:
Yes, but did you REMOVE /usr/ports/distfiles/KDE/qt-x11-opensource-src-4.4.3.tar.gz? It sounds like you might have a corrupted copy.

Yes, I deleted the file but when I try to update again It downloaded qt-x11-opensource-src-4.4.3.tar.gz which is 58.2 MB (61,042,688 B), modified 2009-01-14 16:22, Accessed 2009-01-14 18:40.
And than I got what I wrote before.
 
OP
A

Anonymous

Guest


Solved

The problem is solved. Problem is portmaster. I switch to portupgrade and everything going smoothly.

Anyone know what should be wrong with "portmaster", please?
 

macbias

Member

Reaction score: 3
Messages: 63

i don't know what's wrong with portmaster there. what i know is that portmaster, unlike portupgrade downloads distfiles in the background sometimes where it can. maybe it's related to that.
 

dougb@

Member
Developer

Reaction score: 10
Messages: 28

lumiwa said:
After portmaster -ad:

===>>> Starting build for ports that need updating <<<===

===>>> Launching child to update qt4-moc-4.4.1

===>>> Port directory: /usr/ports/devel/qt4-moc
===>>> Starting check for build dependencies
===>>> Gathering dependency list for devel/qt4-moc from ports
===>>> Starting dependency check
===>>> Launching child to update qt4-qmake-4.4.1 to qt4-qmake-4.4.3
qt4-moc-4.4.1 >> qt4-qmake-4.4.1

===>>> Port directory: /usr/ports/devel/qmake4
===>>> Starting check for build dependencies
===>>> Gathering dependency list for devel/qmake4 from ports
===>>> No dependencies for devel/qmake4
===> Cleaning for qt4-qmake-4.4.3

Unless you eliminated part of the log, this indicates that the 'make checksum' completed successfully. If it had not, at this point you would see lines that looked like:
===>>> Waiting on fetch & checksum for devel/qmake4 <<<===

===> Extracting for qt4-qmake-4.4.3
=> MD5 Checksum mismatch for KDE/qt-x11-opensource-src-4.4.3.tar.gz.
=> SHA256 Checksum mismatch for KDE/qt-x11-opensource-src-4.4.3.tar.gz.

For some reason the file you now have doesn't pass the checksum, and there is (apparently) no fetch process still working in the background.

===> Refetch for 1 more times files: KDE/qt-x11-opensource-
...

This is the ports infrastructure trying to re-fetch the file, which is not succeeding. Portmaster has nothing to do with it at this point, but that doesn't mean it didn't cause the problem that got you here.

I was able to install qt4-moc-4.4.3 (and qt4-qmake-4.4.3 as a dependency) using portmaster without any problems. I used portmaster to fetch the file two different ways (-F and the regular build) and there were no problems.

If you are still experiencing this problem please do the following:
script pm-qt4.log
/bin/sh -x /usr/local/sbin/portmaster devel/qt4-moc

and send me the output to dougb@FreeBSD.org.


hope this helps,

Doug
 
Top