Qt minimum requirement

tkjacobsen

Member

Reaction score: 11
Messages: 46

Hi all

I'm porting Avogadro (science/avogadro) and am currently just using:

Code:
USE_QT_VER= 4
in Makefile. But the true dependency is qt>= 4.4. Is there anyway to do this with easily or should I add something like

Code:
LIB_DEPENDS+=    QtCore.4.[4-5]:${PORTSDIR}/devel/qt4
Best regards
Troels Kofoed Jacobsen
 
OP
OP
T

tkjacobsen

Member

Reaction score: 11
Messages: 46

hmm, cannot find the edit button :(

Seems you cannot have more than one number in LIB_DEPENDS (like QtCore.4.4). I could use BUILD_DEPENDS+= qt4-corelib=4.5.0, but it seems to be the wrong solution to me.
 

avilla@

Well-Known Member
Developer

Reaction score: 58
Messages: 258

OP
OP
T

tkjacobsen

Member

Reaction score: 11
Messages: 46

thanks for the pointers. Though I still cannot find a way to specify that e.g. qt 4.3 is not good enough as 4.4 is the minimum requirement.

Can I just assume that people with qt4 installed has it updated to the latest version?

Best regards
Troels
 
OP
OP
T

tkjacobsen

Member

Reaction score: 11
Messages: 46

Also, is there an easy way to use qmake, like USE_CMAKE= yes? Or do I have to make my own like the following:

Code:
do-configure:
        cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${QMAKE} \
                "PREFIX=${PREFIX}" "LOCALBASE=${LOCALBASE}" \
                "WWWBROWSER=${WITH_BROWSER}"  main.pro
(I'm trying to update graphics/ipe to the qt4 version)
 

avilla@

Well-Known Member
Developer

Reaction score: 58
Messages: 258

$ grep -ru3 QMAKE /usr/ports
some ports do as you suggest, some just put qmake_build in QT_COMPONENTS and let it do everything, at least as far as i understand... you should investigate further those found ports, and start trying the simplest solution

regarding the qt version, i know that audio/amarok-kde4 and editors/koffice-kde4 in area 51, which depend on qt 4.5, don't specify the version (i'm using koffice-kde4 with qt 4.4 with some patches and it doesn't complain). so, you should assume that people has it updated: if they try to build it will fail, and then they'll upgrade

anyway, i suggest you write to freebsd-kde@ for both the problems: maybe they should add dependency versioning for qt and kde components
 
Top