PUTTY from vista home premium to 7.x

How embarassing, my first post on the freebsd forums, and its about Vista.

I'm probably one of the very few people that actually use Windows Vista Home Premium, but I got a laptop primarily to play video games and that's what it came with. I also use this laptop to VPN in to work and SSH to the multitude of FBSD boxen there and at home.

With FBSD 6.x I had no problems. I had several machines that had 6.x on them, and I could use putty to SSH into them at any time.

After upgrading to 7.x, I noticed that I would get 'access denied' any time I tried to putty from the vista laptop. XP works fine, OSX works fine, but my poor little 'wintendo' will not connect.

The machines are on the same subnet, same switch, etc. The OSX or XP machines can get in with the same username/password. The vista machine gets 'access denied'.

I have googled, but you try typing in 'vista access denied' and see what you get.

Is there a setting for the SSHd that is keeping Vista from being able to get in? Or is this a Vista issue? Otherwise, I have to put another OS on the laptop just to do SSH.

Thanks for any input.
Did you ssh key change? Check the Putty's equivalent to know_hosts file. You can also go over sshd_config in the server to see if you changed anything.
The fact you are using Vista is irrelevant, it's not a Vista issue.
Well it might be Vista...my roommate has Vista Home Premium and I just used Putty to SSH to my FreeBSD 7.1 box and it worked fine...given its on the same network but I also have all that UAL(user access control) crap in Vista turned off. So you might want to check into that.
Thanks for your replies, in order:

tangram: I haven't checked the known_hosts thing in putty, but normally you get that POTENTIAL SECURITY BREACH dialogue and just hit 'yes' and you're golden, but I will check that out. The sshd_config is stock. The only line that isn't commented out is the:
Subsystem sftp /usr/libexec/sftp-server

SirDice: I wont say anything like 'well if it's irrelevant, then why does it work on the non-vista machines?' because that would just be mean-spirited, but thank you for your feedback- even if there isn't a whole lot I can take from it.

gentoobob: I'll mess with the UAL or whatever and see if that works.
I still feel it's not a Vista issue.. but ok..

Turn on logging in PuTTY, have a look at that. Kill sshd and run it with the -v switch. Look at that too. Either one will contain clues as to why it's not working.
SirDice said:
Turn on logging in PuTTY, have a look at that. Kill sshd and run it with the -v switch. Look at that too. Either one will contain clues as to why it's not working.

Cool, I will try those things. Thank you.
SirDice: you were right. It was not a vista issue.

I had been using the same old putty.exe from like the year 2000. So when I went into the settings to turn on logging, I noticed that I was missing a ton of options. I downloaded and installed the new version of putty, and everything is cool.

Thanks everyone for the ideas.
Well geez, we all assumed you used the latest PUTTY! lol im kidding. even the greatest geeks over look the simplest issues. Good on you.
I had the same problem with XP on my laptop when I tried to connect to my 7.0 system. The old version of putty worked ok when I connected to a 6.x system.
I assumed the OP was using the latest PuTTY too
I should have known.. Assumption is the mother of all f*** ups :e