Solved Pulseaudio exits after 30 seconds without giving any reason

Holger

Member

Reaction score: 16
Messages: 22

Hi!

I am running Google Chrome on Linuxulator along the lines of this superb thread:

https://forums.freebsd.org/threads/linuxulator-how-to-install-brave-linux-app-on-freebsd-13-0.78879/

All works fine except that there is no sound. Google Chrome, being a Linux thing, needs Pulseaudio. It should be started automatically using the scripts provided in the above thread.

After investigating the problem I found out that Pulseaudio does indeed start, but exits after some time (30 seconds or so) without giving any reason.

I can reproduce this behavior by starting Pulseaudio manually (as a normal user):
pulseaudio --start
and then observing it by doing, e.g., ps aux | grep pulseaudio on a differnt terminal.

What could be the reason?

I am running 13.0-RELEASE-p3.

Best,
Holger
 

George

Aspiring Daemon

Reaction score: 204
Messages: 512

I can reproduce this behavior by starting Pulseaudio manually (as a normal user):
pulseaudio --start
and then observing it by doing, e.g., ps aux | grep pulseaudio on a differnt terminal.
Increase the debug level of pulseaudio(1) e.g. by running pulseaudio -vvvv. There is also a default log target, which can be set to stderr, e.g. pulseaudio -vvvv --log-target stderr.
 
OP
Holger

Holger

Member

Reaction score: 16
Messages: 22

Hi George,

here is what pulseaudio -vvvv gives me:
https://pastebin.com/LtRDxw76

Interesting:
Code:
D: [(null)] core.c: Hmm, no streams around, trying to vacuum.
I: [(null)] core.c: We are idle, quitting...
I: [(null)] main.c: Daemon shutdown initiated.

So quitting because of being idle seems like expected behavior?
 
OP
Holger

Holger

Member

Reaction score: 16
Messages: 22

Ok, I think here it is: man pulseaudio:
Code:
       --exit-idle-time=SECS
              Terminate the daemon after the last client quit and this time in
              seconds passed. Use a negative value to disable this feature.
              Defaults to 20.

I tried pulseaudio --start --exit-idle-time=3600 and now sound in Chrome works. Yay! :)
 

grahamperrin

Daemon

Reaction score: 695
Messages: 2,217

If your post is Solved, you can mark it so; use the Edit feature (near the head of the page). Thanks.
 
Top