Solved Psearch does not work with "gitup ports"

PSearch only works when portsnap has been used to populate /usr/ports. But psearch returns no result when 'gitup ports' is used to populate the same dir. I have had to copy INDEX-NN (where NN is a digit) into the dir in the some cases after the gitup command to get it to work.

Any suggestions?
 
You have to rebuild the index file yourself when updating from git.

cd /usr/ports && make index

It might take a few minutes BTW.
 
OP
Lamia
I was going to inform all that portsnap autogenerates the index; and perhaps, there is a way to generate it or update the gitup command with its argument 'ports' to automatically do so.

Thanks Matthieu.
 
First, index would have to be fixed. AFAIK, it's broken since port flavors are supported (leading to wrong results). Wether it's worthwhile to fix this feature or just dropping it entirely is an option as well might be a discussion some day ;)
 

rigoletto@

Developer
Add to your crontab (adjust as necessary): make -C /usr/ports fetchindex > /dev/null 2>&1

Sometimes (not usual) something may get corrupted and the file is not updated, and this command will not return any error messages.
You need to have a look from time to time, or modify it to get the e-mails with error messages.
 
Top