Solved Problems with freebsd-update on a FreeBSD 11 RELEASE

I downloaded the FreeBSD 11.0-Release cd image and installed it on VirtualBox for testing. While I can install from both pkgs and ports, I have been unable to update the installation to the latest security updates by using freebsd-update fetch install.

The command always end up displaying that a file is corrupt. I have tried removing the corrupted file, even the whole contents of /var/db/freebsd-update/ and still got the same result. No idea if is because the release of 11.1 is so close.
I'm not at the computer right now, so I will answer with what I remember.

1.The Host is Windows 10.
2.Network adapter in Host is a USB wireless.
3.Network config in VBox as NAT (the default network option)
4.Under FreeBSD guest Network driver is Intel.
5.VM has 4 GB of RAM, 60 GB image, 2 processors.

Internet works fine. Can download ports and packages, and browse the web. Freebsd-update download stuff when running, but end with corrupt files.
Ok, now in the computer, refer to this one for the info.
Host info:
1. Host is Windows 10 Home, version 1703 (Creators Ed)
2. Network Adapter is an ASUS USB-N53 (RT28xx series chip), latest Mediatek driver for it.
3. Intel i5 6500 (Skylake) running on a Z170 chipset board. Probably irrelevant due to FreeBSD being running on VBox.

1. FreeBSD 11.0-RELEASE
2. Network adapter attached to NAT (default).
3. 4 GB RAM, 60 GB image, 2 processors (of the 4).
4. Most Vbox guest options left to their defaults.
5. virtualbox-ose-additions not installed. Had same issue with them installed.
6. trying the freebsd-update straight from root console.
Try the bridged network option. It's usually what I use, unless I'm on another network where I can't get an IP that way.
I changed the network configuration from the default NAT to Bridged Adapter, and selected Intel PRO/1000MT Desktop as the guest adapter type, and after that change freebsd-update performed the update cycle without problems.

Thanks for the tip SirDice.

Marking thread as solved.