Solved Problems updating www/firefox

I've been attempting to update www/firefox to the latest release 49.0_8,1, but the build fails near the end (after linking) with a segfault in dtrace (as reported by the output, and in /var/log/messages). Overnight, I removed all user set options from /var/db/ports and reinstalled everything with
portmaster -f www/firefox
but it failed with the same error. All the dependencies built and reinstalled successfully. The system is running 10.3 p9 amd64.

I can paste the exact message in a follow up post. As Firefox is the only browser on the machine I'll have to copy the output over. Anyone else have this problem?
Good question: I do have a few lines in there, but didn't think it would cause a failure. Everything built till firefox-49.0_7,1.

Here are the contents of /etc/make.conf
# Enable Tahoma in x11-fonts/webfonts if you have a Windows license
.if ${.CURDIR:M*/x11-fonts/webfonts}
I just commented out everything in /etc/make.conf and ran
make clean && make
in /usr/ports/www/firefox. Will post back with the output. The machine is now accessible so I can paste any output.
It failed, with everything commented out in /etc/make.conf. The tail bit of the error message is:
dtrace -x nolibs -G -C -s /usr/ports/www/firefox/work/firefox-49.0/js/src/devtools/javascript-trace.d -o js-dtrace.o RegExp.o CTypes.o Library.o Parser.o StoreBuffer.o ExecutableAllocatorPosix.o Disassembler-x86-shared.o jsarray.o jsatom.o jsdtoa.o jsmath.o jsutil.o pm_stub.o ConditionVariable.o Mutex.o Thread.o Initialization.o TraceLogging.o TraceLoggingGraph.o TraceLoggingTypes.o Unified_cpp_js_src0.o Unified_cpp_js_src1.o Unified_cpp_js_src10.o Unified_cpp_js_src11.o Unified_cpp_js_src12.o Unified_cpp_js_src13.o Unified_cpp_js_src14.o Unified_cpp_js_src15.o Unified_cpp_js_src16.o Unified_cpp_js_src17.o Unified_cpp_js_src18.o Unified_cpp_js_src19.o Unified_cpp_js_src2.o Unified_cpp_js_src20.o Unified_cpp_js_src21.o Unified_cpp_js_src22.o Unified_cpp_js_src23.o Unified_cpp_js_src24.o Unified_cpp_js_src25.o Unified_cpp_js_src26.o Unified_cpp_js_src27.o Unified_cpp_js_src28.o Unified_cpp_js_src29.o Unified_cpp_js_src3.o Unified_cpp_js_src30.o Unified_cpp_js_src31.o Unified_cpp_js_src32.o Unified_cpp_js_src33.o Unified_cpp_js_src34.o Unified_cpp_js_src35.o Unified_cpp_js_src36.o Unified_cpp_js_src37.o Unified_cpp_js_src38.o Unified_cpp_js_src4.o Unified_cpp_js_src5.o Unified_cpp_js_src6.o Unified_cpp_js_src7.o Unified_cpp_js_src8.o Unified_cpp_js_src9.o
gmake[7]: *** [/usr/ports/www/firefox/work/firefox-49.0/config/ js-dtrace.o] Segmentation fault
gmake[7]: Leaving directory '/usr/ports/www/firefox/work/firefox-49.0/obj-x86_64-unknown-freebsd10.3/js/src'
gmake[6]: *** [/usr/ports/www/firefox/work/firefox-49.0/config/ js/src/target] Error 2
gmake[6]: Leaving directory '/usr/ports/www/firefox/work/firefox-49.0/obj-x86_64-unknown-freebsd10.3'
gmake[5]: *** [/usr/ports/www/firefox/work/firefox-49.0/config/ compile] Error 2
gmake[5]: Leaving directory '/usr/ports/www/firefox/work/firefox-49.0/obj-x86_64-unknown-freebsd10.3'
gmake[4]: *** [/usr/ports/www/firefox/work/firefox-49.0/config/ default] Error 2
gmake[4]: Leaving directory '/usr/ports/www/firefox/work/firefox-49.0/obj-x86_64-unknown-freebsd10.3'
gmake[3]: *** [/usr/ports/www/firefox/work/firefox-49.0/ realbuild] Error 2
gmake[3]: Leaving directory '/usr/ports/www/firefox/work/firefox-49.0'
gmake[2]: *** [/usr/ports/www/firefox/work/firefox-49.0/ build] Error 2
gmake[2]: Leaving directory '/usr/ports/www/firefox/work/firefox-49.0'
===> Compilation failed unexpectedly.
Try to set MAKE_JOBS_UNSAFE=yes and rebuild before reporting the failure to
the maintainer.
*** Error code 1

make[1]: stopped in /usr/ports/www/firefox
*** Error code 1

make: stopped in /usr/ports/www/firefox
Just came across this; looking through the logs, I got exactly the error mentioned in the link when I initially tried to update (before the rebuild).
Thanks! I did, actually. Then the xpcshell process segfaults instead. I'm beginning to suspect it's some kind of library mixup.

There is a new update in the link I posted; it seems like a port issue.
Do the libs get placed into /usr/local/lib/firefox or into /usr/local/lib/firefox-devel-49.0_8.1?

I was wondering like you when attempting to build and run FF. www/firefox from packages installs libs into /usr/local/lib/firefox, whereas www/firefox from ports installs into /usr/local/lib/firefox-devel-... instead for some reason I do not yet understand.
So I just deleted the libs from packages and set a link from /usr/local/lib/firefox to /usr/local/lib/firefox-devel-....

Hope this helps.

It's confirmed. I just upgraded www/firefox.

% pkg info firefox
Name           : firefox
Version        : 49.0_8,1
Installed on   : Wed Oct 12 00:18:56 2016 CEST
Origin         : www/firefox
Architecture   : freebsd:10:x86:64
Prefix         : /usr/local
Categories     : ipv6 www
Licenses       :
Maintainer     :
WWW            :
Comment        : Web browser based on the browser portion of Mozilla
Options        :
    ALSA           : on
    CANBERRA       : on
    DBUS           : on
    DEBUG          : off
    DTRACE         : off
    FFMPEG         : on
    GCONF          : on
    GNOMEUI        : off
    GTK2           : off
    GTK3           : on
    LIBPROXY       : off
    PGO            : off
    PROFILE        : off
    PULSEAUDIO     : off
    RUST           : on
    TEST           : off
Shared Libs required:
Annotations    :
    cpe            : cpe:2.3:a:mozilla:firefox:49.0:::::freebsd10:x64:8
    no_provide_shlib: yes
Flat size      : 99.3MiB
Description    :
Mozilla Firefox is a free and open source web browser descended from the
Mozilla Application Suite. It is small, fast and easy to use, and offers
many advanced features:

 o Popup Blocking
 o Tabbed Browsing
 o Live Bookmarks (ie. RSS)
 o Extensions
 o Themes
 o FastFind
 o Improved Security


It's safe to build firefox with DTRACE option enabled.