Solved Problems starting slim.

casianbsd

Member

Reaction score: 1
Messages: 29

I'm new to this OS but I installed Xorg and XFCE and SLiM to login into the desktop environment. But when I type slim to enter in it it says : (EE) Server terminated with error (1). Closing log file.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 12,767
Messages: 39,377

Start here: Chapter 5. The X Window System. Make sure X itself is configured and working properly before adding things like a desktop environment and display managers.

And if you want people to notice your thread, don't use a generic title like "Help". Lots of people only look at the thread title to see if there's anything they can respond to. Use something more descriptive next time or it'll just get ignored.
 
OP
C

casianbsd

Member

Reaction score: 1
Messages: 29

Thanks, SirDice. I'm going to try tomorrow, I'm going to let an update if it worked.
 
OP
C

casianbsd

Member

Reaction score: 1
Messages: 29

Start here: Chapter 5. The X Window System. Make sure X itself is configured and working properly before adding things like a desktop environment and display managers.

And if you want people to notice your thread, don't use a generic title like "Help". Lots of people only look at the thread title to see if there's anything they can respond to. Use something more descriptive next time or it'll just get ignored.
Tried, but seemed like i got the same error after a reboot
 
OP
C

casianbsd

Member

Reaction score: 1
Messages: 29

( im not typing the numbers because it will take too long to type, it even took me one hour to type all of this) this is what my log says :

[ 3.620]
X.Org X Server 1.20.11
X Protocol Server Version 11, Revision 0
Build Operating System:FREEBSD 13.0-RELEASE-p4 amd64
Current Operating system: FreeBSD casian 13.0-RELEASE FreeBSD 13.0-RELEASE #0 releng/13.0-n244733-ea31abc261f: Fri Apr 9 04:24:09 UTC 2021 root@releng1.nyi.freebsd.org
Build Date:05 October 2021 09:46:30AM
Current version of pixman:0.40.0
Before reporting problems, check http://wiki.x.org
to make sure you have the latest version.
Markers:(--) probed, (**) from config file, (==) default setting.
(++) from command line, (!!) notice, (II) informational, (WW) warning, (EE) error, (NI) not implemented, (??) unknown.

and now... it starts getting strange :
Using system config directory "/usr/local/share/X11/xorg.conf.d
No layout section. Using the first Screen Section
No screen section available. Using defaults.
I---->Screen "Default Screen Section" (0)
I I---->Monitor "<default monitor>
No monitor specified for screen"Default Screen Section".
Using a default monitor configuration
Automatically adding devices
Automatically enabling devices
Not automatically adding GPU devices
Max clients allowed : 256,resource mask: 0x1fffff
FontPath set to:
/usr/local/share/fonts/misc/
usr/local/share/fonts/TTF/
usr/local/share/fonts/OTF/
usr/local/share/fonts/Type1/
usr/local/share/fonts/100dpi/
usr/local/share/fonts/75dpi/
catalogue:/usr/local/etc/X11/fontpath.d
ModulePath set to "usr/local/lib/xorg/modules"
Loader magic: 0x435b20
Module ABI versions:
X.Org ANSI C Emulation:0.4
X.Org Video Driver : 24.1
X.Org Server Extension : 10.0
(--) PCI:*(0@0:2:0) 8086:22b1:103c:82a9 rev 53, Mem@ 0x90000000/16777216, 0x80000000/268435456, I/O @ 0x00001000/64, BIOS @ 0x????????/65536
LoadModule : "glx"
Loading /usr/local/lib/xorg/modules/extensions/libglx.so
but i dont think the problem is here.. i think its here :
Matched intel as autoconfigured driver 0
Matched modesetting as autoconfigured driver 1
Matched scfb as autoconfigured driver 2
Matched vesa as autoconfigured driver 3
Assigned the driver to xf86ConfigLayout
LoadModule: "intel"
Warning, couldn't open module intel
Failed to load module "intel" (module does not exist, 0)
LoadModule: "modesetting"
Loading /usr/local/lib/xorg/modules/drivers/scfb_drv.so
Module vesa: vendor="X.Org Foundation"

another thing that i saw was this :
open /dev/dri/card0: No such file or directory
Falling back to old probe method for modesetting
open /dev/dri/card0:No such file or directory
Falling back to old probe method for scfb
scfb trace : probe start
scfb(1): using default device
scfb trace: probe done
VGA arbiter: cannot open kernel arbiter, no multi-card support
Screen 0 deletes because of no matching config section.
UnloadModule: "modesetting"
Fatal server error : Cannot run in framebuffer mode. Please specify busIDs for all framebuffer devices
Please also check the log file at "/var/log/Xorg. 0.log" for additional information

Server terminated with error (1). Closing log file.
 

Argentum

Aspiring Daemon

Reaction score: 299
Messages: 626

I'm new to this OS but I installed Xorg and XFCE and SLiM to login into the desktop environment. But when I type slim to enter in it it says : (EE) Server terminated with error (1). Closing log file.
Do you have slim_enable="YES" in your /etc/rc.conf?
Without that you can test the slim with service slim onestart as a root, of course.
... and you looked into /usr/local/etc/slim.conf and created your ~/.xinitrc. Sure, slim should start without that if your Xorg is good but you cannot start the WM without that file.

See /var/log/Xorg.0.log to find out issues with Xorg.
 
OP
C

casianbsd

Member

Reaction score: 1
Messages: 29

Do you have slim_enable="YES" in your /etc/rc.conf?
Without that you can test the slim with service slim onestart as a root, of course.
... and you looked into /usr/local/etc/slim.conf and created your ~/.xinitrc. Sure, slim should start without that if your Xorg is good but you cannot start the WM without that file.

See /var/log/Xorg.0.log to find out issues with Xorg.
so i didnt have slim_enable="YES" over there but i did that now but i get the same error and then i tried service slim onestart it said :
Starting slim.
startxfce4 - Xfce Session
startxfce4 - Xfce Session
and nothing popped on the screen...
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 12,767
Messages: 39,377

Leave SliM off for now. Test your X configuration with startx. Once it's working then you can enable SLiM.

What graphics card does the system have?
 
OP
C

casianbsd

Member

Reaction score: 1
Messages: 29

Leave SliM off for now. Test your X configuration with startx. Once it's working then you can enable SLiM.

What graphics card does the system have?
I repaired it from the guide by installing the intel drivers but what i see is that any desktop enviroment or window manager doesnt work, only the default twm from startx :( any other desktop enviroment/window manager (i prefer window manager) says unable to open display
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 12,767
Messages: 39,377

Ok, good. That means that X is working if you can see the default TWM. Add this to your ~/.xinitrc so you can select the proper DE/WM from SLiM:
Code:
[ -n "$1" ] && [ -x "$1" ] && exec "$1"

Now you're ready to enable SLiM. sysrc slim_enable="YES". On the SLiM login page, you can select a DE or WM with F1. That's useful if you want to try different DEs.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 12,767
Messages: 39,377

It's in your home directory (file doesn't exist by default, so create it); ~/.xinitrc.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 12,767
Messages: 39,377

Different file for a different purpose. Don't edit that one.
 
OP
C

casianbsd

Member

Reaction score: 1
Messages: 29

i need to create it in the home directory or in the /usr/local/etc/X11/xinit?
 

Alexander88207

Aspiring Daemon

Reaction score: 529
Messages: 755

open /dev/dri/card0: No such file or directory
Falling back to old probe method for modesetting
open /dev/dri/card0:No such file or directory
Falling back to old probe method for scfb
scfb trace : probe start
scfb(1): using default device
scfb trace: probe done
VGA arbiter: cannot open kernel arbiter, no multi-card support
Screen 0 deletes because of no matching config section.
UnloadModule: "modesetting"
Fatal server error : Cannot run in framebuffer mode. Please specify busIDs for all framebuffer devices
Please also check the log file at "/var/log/Xorg. 0.log" for additional information

Server terminated with error (1). Closing log file.

No graphics/drm-kmod drivers installed or not setup properly.

See: https://wiki.freebsd.org/Graphics
 
OP
C

casianbsd

Member

Reaction score: 1
Messages: 29

nano <filename> if the file doesn't exist it will be created.
i still get the same error though i did the steps correctly :(
error : IceWM: Can't open display: <none>. X must br running and $DISPLAY set.
thats what its saying to any window manager :(
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 12,767
Messages: 39,377

IceWM has nothing to do with XFCE. So what exactly did you do?
 
OP
C

casianbsd

Member

Reaction score: 1
Messages: 29

IceWM has nothing to do with XFCE. So what exactly did you do?
Seemed like only desktop enviroments works for me, i installed LXQT do you think that 400M/1.87G ram usage is okay on lxqt? or is there something more lightweight than lxqt?
 
Top