Problems installing FreeBSD 7.1

I am trying to install FreeBSD 7.1 from a USB flash memory stick.

I used before and it worked so far that I could start the installer from USB. But I am doing this on an Acer Aspire One and the ethernet-card didn't work.
Then I read somewhere that it should work with 7.1, but I have not been succesfull in making it boot from USB.

I tried normal unetbootin, but since I am new to FreeBSD I don't know what to choose as initrd and kernel from the installCD.

I tried to install using and then just copying the content of 7.1 instead of 7.0 to the USB, but then when choosing MS-dos media in the installer it just said that it couldn't find the files needed to install.

Any ideas..? I have tried to make this work for some weeks now, and I don't intend to give up just yet. I don't have much experience with FreeBSD, so another question.. Is there someway I can check mountpoints and devices from the installCD, either bootonly, disk1 or dvd.?

I found the fixit terminal, but it didn't recognize any commands like mount, cd, lspci or ls. Maybe I these don't work on FreeBSD.? And only Linux?
I am also trying to install FreeBSD 7.1 on an Acer Aspire One from a USB stick created with UNetbootin from:

I couldn't select FreeBSD 7.1 on UNetbootin and so I used the 7.0 option and got at far as the following:
Loading /ubnkern.
Invalid or corrupt kernel image.

This is the most luck I have had... Let me know if you find a solution!