Problems building Cmake

lasuit

Member

Reaction score: 6
Messages: 28

I'm running 12.1-p2 on amd64. Recently, when trying to update ports I ran into a problem while updating cmake. The error looks like this:

Code:
root@miller:/usr/ports/devel/cmake # make install clean
===>  Building for cmake-3.16.3
[  4%] Built target cmsys
[  6%] Built target cmsys_c
[  6%] Built target cmstd
[ 75%] Built target CMakeLib
[ 77%] Built target CMakeServerLib
[ 90%] Built target CTestLib
[ 90%] Built target ctest
[ 94%] Built target CPackLib
[ 95%] Built target cpack
[ 96%] Built target cmake
[ 99%] Built target ccmake
[100%] ESC[34mESC[1msphinx-build man: see Utilities/Sphinx/build-man.logESC[0m
Traceback (most recent call last):
  File "/usr/local/bin/sphinx-build", line 6, in <module>
    from pkg_resources import load_entry_point
  File "/usr/local/lib/python3.7/site-packages/pkg_resources/__init__.py", line 3251, in <module>
    @_call_aside
  File "/usr/local/lib/python3.7/site-packages/pkg_resources/__init__.py", line 3235, in _call_aside
    f(*args, **kwargs)
  File "/usr/local/lib/python3.7/site-packages/pkg_resources/__init__.py", line 3264, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
The build-man.log file has zero bytes. I've tried rebuilding python37 and py-sphinx, but neither of those seem to help. Any suggestions?
 
Top