Problem with xorg-server 1.20.7 and nvidia-driver-304 on Dell XPS M1330 (need to downgrade X.org?)

rm1984

New Member

Reaction score: 1
Messages: 4

Hello everyone,
I'm running FreeBSD 12.1-p2 on an old Dell XPS M1330 laptop.
The video card is an old nVidia GeForce 8400M GS, and everything use to work fine with driver "nvidia-driver-304-304.137_6".
A few days ago I installed the latest system updates, and now X.org stopped working.
By reading the logs, I found an error about the video driver ABI (you can find it at the end):
Code:
[    30.187]
X.Org X Server 1.20.7
X Protocol Version 11, Revision 0
[    30.187] Build Operating System: FreeBSD 12.0-RELEASE-p13 amd64
[    30.187] Current Operating System: FreeBSD insanity 12.1-RELEASE-p2 FreeBSD 12.1-RELEASE-p2 GENERIC amd64
[    30.188] Build Date: 22 February 2020  01:18:45AM
[    30.188] 
[    30.188] Current version of pixman: 0.38.4
[    30.188]     Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
[    30.188] Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    30.188] (==) Log file: "/var/log/Xorg.0.log", Time: Tue Feb 25 09:05:25 2020
[    30.194] (==) Using config directory: "/usr/local/etc/X11/xorg.conf.d"
[    30.194] (==) Using system config directory "/usr/local/share/X11/xorg.conf.d"
[    30.195] (==) ServerLayout "Layout0"
[    30.196] (**) |-->Screen "Screen0" (0)
[    30.196] (**) |   |-->Monitor "Monitor0"
[    30.196] (**) |   |-->Device "Device0"
[    30.196] (**) |-->Input Device "Keyboard0"
[    30.196] (**) |-->Input Device "Mouse0"
[    30.196] (**) Option "Xinerama" "0"
[    30.196] (==) Automatically adding devices
[    30.196] (==) Automatically enabling devices
[    30.196] (==) Not automatically adding GPU devices
[    30.196] (==) Max clients allowed: 256, resource mask: 0x1fffff
[    30.206] (==) FontPath set to:
    /usr/local/share/fonts/misc/,
    /usr/local/share/fonts/TTF/,
    /usr/local/share/fonts/OTF/,
    /usr/local/share/fonts/Type1/,
    /usr/local/share/fonts/100dpi/,
    /usr/local/share/fonts/75dpi/,
    catalogue:/usr/local/etc/X11/fontpath.d
[    30.206] (==) ModulePath set to "/usr/local/lib/xorg/modules"
[    30.206] (**) Extension "Composite" is enabled
[    30.206] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[    30.206] (WW) Disabling Keyboard0
[    30.206] (WW) Disabling Mouse0
[    30.206] (II) Loader magic: 0x426020
[    30.206] (II) Module ABI versions:
[    30.206]     X.Org ANSI C Emulation: 0.4
[    30.206]     X.Org Video Driver: 24.1
[    30.206]     X.Org XInput driver : 24.1
[    30.206]     X.Org Server Extension : 10.0
[    30.206] (--) PCI:*(1@0:0:0) 10de:0427:1028:0209 rev 161, Mem @ 0xf5000000/16777216, 0x120000000/268435456, 0xf2000000/33554432, I/O @ 0x0000ef00/128, BIOS @ 0x????????/65536
[    30.207] (II) LoadModule: "glx"
[    30.208] (II) Loading /usr/local/lib/xorg/modules/extensions/libglx.so
[    30.483] (II) Module glx: vendor="NVIDIA Corporation"
[    30.483]     compiled for 4.0.2, module version = 1.0.0
[    30.483]     Module class: X.Org Server Extension
[    30.483] (II) NVIDIA GLX Module  304.137  Thu Sep 14 14:06:12 PDT 2017
[    30.483] (II) LoadModule: "nvidia"
[    30.484] (II) Loading /usr/local/lib/xorg/modules/drivers/nvidia_drv.so
[    30.506] (II) Module nvidia: vendor="NVIDIA Corporation"
[    30.506]     compiled for 4.0.2, module version = 1.0.0
[    30.506]     Module class: X.Org Video Driver
[    30.506] ================ WARNING WARNING WARNING WARNING ================
[    30.506] This server has a video driver ABI version of 24.1 that this
driver does not officially support.  Please check
http://www.nvidia.com/ for driver updates or downgrade to an X
server with a supported driver ABI.
[    30.506] =================================================================
[    30.506] (EE) NVIDIA: Use the -ignoreABI option to override this check.
[    30.506] (II) UnloadModule: "nvidia"
[    30.506] (II) Unloading nvidia
[    30.507] (EE) Failed to load module "nvidia" (unknown error, 0)
[    30.507] (EE) No drivers available.
[    30.507] (EE)
Fatal server error:
[    30.507] (EE) no screens found(EE)
[    30.507] (EE)
Please consult the The X.Org Foundation support
     at http://wiki.x.org
 for help.
[    30.507] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    30.507] (EE)
[    30.507] (EE) Server terminated with error (1). Closing log file.

These, among the others, are the X.org packages currently installed:
xorg-7.7_3
xorg-server-1.20.7,1


I think the best way to solve this problem is to downgrade xorg-server to the latest working version (it should be 1.18.4_13,1).

How can I downgrade xorg-server?
Or alternatively, how could I solve the problem with the latest version of the driver? I already tried the "IgnoreABI" directive in the "ServerFlags" section in xorg.conf but the screen turns black just after showing the nVidia logo.

Thanks in advance for any precious help.
Have a nice day!
 

outpaddling

Active Member

Reaction score: 38
Messages: 117

I hit the same issue on an old iMac.
Note that nVidia driver versions overlap in their hardware support. I upgraded from nvidia-driver-304 to nvidia-driver-340 and it's working fine now.
 

scottro

Daemon

Reaction score: 770
Messages: 1,883

To answer the OP's question, to downgrade, you can look in /var/cache/pkg. You should have the previous version of xorg-server there, called something like xorg-server-1.18.etc.tgz

You can remove your current xorg server. I ran into this too, mouse and keyboard wouldn't work. so I did pkg delete -f xorg-server. (The -f keeps it from taking dependencies, it want to also remove the nvidia, keyboard, and mouse drivers.) Then just do pkg install /var/cache/pkg/xorg-server-1.18 whatever.txz When you startx you should be back in business.
 

huskers

New Member


Messages: 5

To answer the OP's question, to downgrade, you can look in /var/cache/pkg. You should have the previous version of xorg-server there, called something like xorg-server-1.18.etc.tgz

You can remove your current xorg server. I ran into this too, mouse and keyboard wouldn't work. so I did pkg delete -f xorg-server. (The -f keeps it from taking dependencies, it want to also remove the nvidia, keyboard, and mouse drivers.) Then just do pkg install /var/cache/pkg/xorg-server-1.18 whatever.txz When you startx you should be back in business.

I have a similar issue, If not then how to downgrade, is a compilation from the port the only option? is there a package version one can download ?
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 10,991
Messages: 36,924

Does Geforce 6100 work with nvidia-driver-340?
Not according to the NVidia driver website. The Geforce 8 series is the "lowest" card that's supported by the 340 version. But you can always try, the worst thing that could happen is that the driver tells you it's not supported, you're not going to break anything.

I do know the 340 version still works with recent Xorg versions though, I need it for a GT520 in a Zotac PC I have.
 

shkhln

Daemon

Reaction score: 897
Messages: 2,102

The easiest way to use this (horribly obsolete) hardware would probably be a patch for Xorg 1.19 selectively reverting ABI changes in affected places. (The process of writing this patch is left as an exercise for the reader.) Jury is still out on potential security issues with unsupported drivers.
 
Top