Problem with RTL8180 WIFI

sergok

New Member


Messages: 2

Hi everyone!
I've found an old pci wiriless card in my box, and trying to make it work on FREEBSD 7.1, but I see that there is no chance to start it up.
I do everything by instruction (this one)
But still, cannot manage. There is no ndis0 device appear when I do ifconfig or dmesg.
kldstat doesn't show ndis.ko module either
What's the problem about this? Please some one help me to nake work this device
 

jrick

Member

Reaction score: 6
Messages: 84

Those look like very old instructions, have you tried the newer ndisgen(8))?

By the way, I had the exact same problem trying to get my wifi card (a Realtek RTL8191SE) to work. I was able to load the kernel module (it appeared in kldstat), but no ndis0 device appeared.
 
OP
S

sergok

New Member


Messages: 2

jrick said:
Those look like very old instructions, have you tried the newer ndisgen(8))?

By the way, I had the exact same problem trying to get my wifi card (a Realtek RTL8191SE) to work. I was able to load the kernel module (it appeared in kldstat), but no ndis0 device appeared.
Well, it seems I've solved this problem. The sollution is very simple, in any case it works on my PC. I don't know why, I didn't manage to make it work, by doing the same things which were described in the article "how to get ndis support working in freebsd". So my sollution is:

1. Download windowds driver files. Something like that "NET8180.INF and rtl8180.sys".
2. Then, I've put these 2 files into /sys/modules/if_ndis and #ndisgen NET8180.INF rtl8180.sys
I've got generated file rtl8180_sys.ko in the same folder.
3. Make sure that you are in the folder where rtl8180_sys.ko is located and cp rtl8180_sys.ko /boot/kernel
4. kldload rtl8180_sys.ko and thats it!
Each time when I tried to follow the instruction, I didn't manage to setup my wifi. dmesg didn't show anything.
But now, it seems that it works perfect, excluding one thing...
I have AP and it is WEP secure, when I do iconfig ndis0 the status is "no carrier".
That's right because I didn't mentioned anywhere wepkey.
So I do # ifconfig ndis0 inet 192.168.1.33 netmask 255.255.255.0 wepmode on wepkey 0203040506
Where 0203040506 is my wepkey. When I look again ifconfig ndis0, I see that status is "associated", but I can't ping anything but my own IP 192.168.1.33. When I turn off WEP on my AP, everything works fine. Has anybody any idea about this?
Now I've just made access by filtering MAC addresses on AP. How to make work WEP?
 

jrick

Member

Reaction score: 6
Messages: 84

sergok said:
3. Make sure that you are in the folder where rtl8180_sys.ko is located and cp rtl8180_sys.ko /boot/kernel
I believe that /boot/kernel is overwritten every time you upgrade freebsd, so it may be smarter to copy it to /boot/modules instead.
 
Top