Solved Problem with Realtec ALC887

I have problem with sound with my Realtec ALC887 integrated in motherboard.
dmesg | grep Realtek
hdacc1: <Realtek ALC887 HDA CODEC> at cad 0 on hdac1
hdaa1: <Realtek ALC887 Audio Function Group> at nid 1 on hdacc1
pcm4: <Realtek ALC887 (Rear Analog 7.1/2.0)> at nid 20,22,21,23 and 24,26 on hdaa1
pcm5: <Realtek ALC887 (Front Analog)> at nid 27 and 25 on hdaa1
pcm6: <Realtek ALC887 (Onboard Digital)> at nid 17 on hdaa1
cat /dev/sndstat
Installed devices:
pcm0: <NVIDIA (0x0084) (HDMI/DP 8ch)> (play)
pcm1: <NVIDIA (0x0084) (HDMI/DP 8ch)> (play)
pcm2: <NVIDIA (0x0084) (HDMI/DP 8ch)> (play)
pcm3: <NVIDIA (0x0084) (HDMI/DP 8ch)> (play)
pcm4: <Realtek ALC887 (Rear Analog 7.1/2.0)> (play/rec) default
pcm5: <Realtek ALC887 (Front Analog)> (play/rec)
pcm6: <Realtek ALC887 (Onboard Digital)> (play)
No devices installed from userspace.
But if I make a test here i could hear a test music.

My FreeBSD is 11.0-RELEASE-p8.
Please help me to configure my audio.
It was my fail. Problem was solved.
I had no sound only in firefox.
make -C /usr/ports/www/firefox showconfig
===> The following configuration options are available for firefox-52.0_3,1:
     BUNDLED_CAIRO=on: Use bundled fork of cairo-1.9.5
     CANBERRA=off: Sound theme alerts
     DBUS=on: D-Bus IPC system support
     DEBUG=off: Build with debugging support
     DTRACE=on: Build with DTrace probes
     FFMPEG=on: FFmpeg support (WMA, AIFF, AC3, APE...)
     GCONF=off: GConf configuration backend support
     GNOMEUI=off: libgnomeui support module
     INTEGER_SAMPLES=off: Integer audio sample format
     LIBPROXY=off: Proxy support via libproxy
     OPTIMIZED_CFLAGS=on: Use extra compiler optimizations
     PGO=off: Use Profile-Guided Optimization
     PROFILE=off: Build with profiling support
     RUST=on: Build with components written in Rust language
     TEST=off: Build and/or run tests
====> Options available for the multi AUDIO: you have to choose at least one of them
     ALSA=on: ALSA audio architecture support
     PULSEAUDIO=off: PulseAudio sound server support
     SNDIO=off: Sndio audio support
====> Options available for the single TOOLKIT: you have to select exactly one of them
     GTK2=off: GTK+ 2 GUI toolkit support
     GTK3=on: GTK+ 3 GUI toolkit support
===> Use 'make config' to modify these settings
My fail was in ALSA=on and PULSEAUDIO=on.