Problem with opened ports

onehitxzibit

New Member


Messages: 2

I am using a clean install of FreeBSD, but when I try to connect to my web server using telnet (telnet localhost 80) it says "connection refused". I didn't install any firewalls and the same command works fine for port 22 (ssh), so I guess FreeBSD comes with ports closed by default. My question is - how can I open them?
 

Nokobon

Active Member

Reaction score: 3
Messages: 109

Are you shure that your Webserver is running?
Is it listed in the output of
Code:
sockstat -4
?

As far as I know neither TCP Wrapper nor Paket Filter deny traffic on any ports by default...
 

DutchDaemon

Administrator
Staff member
Administrator
Moderator
Developer

Reaction score: 2,818
Messages: 11,306

Is Apache set to actually listen on all interfaces (including loopback), or is it bound to a specific IP address on your system?
 

phoenix

Administrator
Staff member
Administrator
Moderator

Reaction score: 1,259
Messages: 4,099

$ netstat -an | grep LIST will show open TCP ports as well.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,755
Messages: 30,864

If you install apache it will not start automatically. You will need to add apache22_enable="YES" to /etc/rc.conf. After that you can start it using # /usr/local/etc/rc.d/apache22 start (this is assuming you've installed apache 2.2.x).

Just remember, anything you install will not start automatically, you will have to edit something (usually /etc/rc.conf) to get it to start.
 
OP
OP
O

onehitxzibit

New Member


Messages: 2

It turned out that the Apache wasn't running. Thank you all for the help. @SirDice - after I enable it will it start automaticly after system restart?
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,755
Messages: 30,864

onehitxzibit said:
@SirDice - after I enable it will it start automaticly after system restart?
Yes, if you add apache22_enable="YES" to /etc/rc.conf, apache will start automatically when the system is booted.
 
Top