Problem With isc-dhcpd and Diskless Booting

wright546

New Member


Messages: 4

Hello Everyone,

My end goal is to install FreeBSD on a workstation via UEFI PXE booting. I'm following instructions in the links below.

I have a server set up running TFTP and NFS, and a workstation in UEFI mode with "secure boot" disabled.

The problem I'm having is that isc-dhcpd does not seem to be passing the "root-path" option to the workstation. After I network boot the workstation, I check the server where I have TFTP running and see in /var/log/xferlog that the workstation successfully got the "pxeboot" file from TFTP. But then the workstation never reaches out for any files in the "root-path" via TFTP or NFS. The xferlog doesn't show anything, and I'm running tcpdump on port 111/809/895 to get NFS traffic but there is none.

In dhcpd.conf I've tried all 3 of these entries, same result each time. I tried it in the global section and in the 192.168.1.0 scope section.
Code:
filename "FreeBSD/boot/pxeboot";
if exists user-class and option user-class = "FreeBSD" {
    option root-path "/FreeBSD"; 
    #option root-path "tftp://192.168.1.10/FreeBSD/"; 
    #option root-path "192.168.1.10:/tftproot/FreeBSD" ; 
}
I verified that I can manually download the pxeboot file via TFTP, which I probably didn't need to do since I saw it was working in xferlog. I also manually mounted the nfs share and copied a few files just as a test, and that worked.

I've been running tcpdump on port 67 and 68 on the server to capture the dhcp transactions. I see the "next-server" and "filename" options being offered, but I don't see the "root-path" option at all.


I'm sure it's something I'm doing wrong. Any ideas or suggestions?

Thanks for your help!
 
Top