• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Problem with automounting NTFS partition in KDE

nickag

Member

Thanks: 6
Messages: 40

#1
Hi
I have problem with automounting NTFS partition in KDE its usb drive16GB. I have fuse kernel module loaded
and I can mount it manually with ntfs-3g but still no luck.

Code:
An error occurred while accessing '7.2 GiB Removable Media', the system responded: org.freedesktop.Hal.Device.Volume.UnknownFailure: mount: illegal option -- u usage: mount [-t fstype] [-o options] target_fs mount_point
 

cabriofahrer

Active Member

Thanks: 3
Messages: 102

#2
I've got exactly the same problem. FreeBSD amd64 10.2 with HAL properly configured. No Problem before with FreeBSD 9.x versions and HAL-automounting in MATE. But since upgrade to 10.2 it simply does not work anymore, not with KDE4 nor with MATE. Any solution to this?
 

LoaderBSD

New Member


Messages: 1

#5
Same problem here, in KDE FreeBSD 10.3-RC1

I don't find any solution to solve the problem, I tried all and there is no way. Fusefs-ntfs package, similar packages of fusefs and dependencies are installed... and loaded in the kernel as a module.

The extrange, is that when I mount the external NTFS USB HDD with ntfs-3g it's mounted perfectly (as root only!, not in standar user mode), but dolphin automount, or thundar, or whatever file manager that I've tried to mount a NTFS filesystem, at least in kde does not run.

Regards and sorry for my english.
 

cabriofahrer

Active Member

Thanks: 3
Messages: 102

#6
I officially reported this some time ago, but it seems that the developers have not found a solution yet: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=204464

Interesting is the following response which offers some explanation about what is happening:

Code:
 rkoberman@gmail.com 2016-01-23 06:09:32 UTC

This is probably not an issue with HAL, ugly as HAL is. This is most likely fall-out of the removal of the old almost read-only implementation in the base system.

In v9, the mount command attempt to mount NTFS file systems by calling the mount_ntfs(8) command. A script was provided on the gnome web page to replace mount_ntfs. It would translate the mount_ntfs command to ntfs-3g syntax and then exec ntfs-3g. The hooks in mount(8) to call mount_ntfs(8) were removed, breaking the ability to use the standard mount(8) command to mount the ntfs volume using the fuse-based ntfs-3g command.

It looks like automount in 10.2 can work with devd to handle this. See section 17.4 of the FreeBSD Handbook. This assumes that you are talking about a removable device. Of course, the traditional /etc/fstab can be used for fixed ntfs file systems.
I experimented with autofs, but it seems that it does not work properly under 10.2 yet, apart from the fact that stuff mounted in /media by autofs does not show up in KDE4/Dolphin, so it looks like autofs is no valid replacement for HAL. Also, KDE still needs HAL for power management. This is a very unsatisfactory situation for people who use FreeBSD as a desktop, apparently it is not clear to the developers that all external drives sold out there come formatted with NTFS and it makes sense to have it that way, in order to assure data exchangability with Windows computers.