Problem with a Python module

rghq

Member

Reaction score: 7
Messages: 76

Hello,

I'm about porting a small Python script that required the m2crypto module in order to run.
Setting:

Code:
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}m2crypto:security/py-m2crypto
Won't recognize it as installed and the build run fails reporting m2crypto is already installed.
Since that port (m2crypto) installs one file that differs depending from the installed FreeBSD and Python version - another way to work-around this issue somehow ?

Thanks in advance
 
J

john_doe

Guest


Can't you use depends from an existing port? For example, net-im/py-pyxmpp uses
Code:
RUN_DEPENDS=	${PYTHON_PKGNAMEPREFIX}m2crypto>=0.18.2:${PORTSDIR}/security/py-m2crypto
 
OP
OP
rghq

rghq

Member

Reaction score: 7
Messages: 76

Yup - tried this already still the result remains the same.
 

Carpetsmoker

Daemon

Reaction score: 184
Messages: 1,012

Actually, that line works fine for me.
It doesn't work without the version number, not sure why. I can't find anything obvious in /ports/Mk/ right now ...
 
Top