Problem getting XFCE to run on my old ThinkPad T430

parski

New Member

Reaction score: 3
Messages: 9

Hello,

I have a Lenovo ThinkPad T430 with a i5-3320M and no dedicated GPU so we're talking Intel HD Graphics.

I followed the handbook instructions of how to set up X and after that, XFCE. So in short:

I installed X:

Code:
# pkg install xorg


Added my user to video and wheel:

Code:
# pw groupmod video -m parski || pw groupmod wheel -m parski


Switched console to vt in /boot/loader.conf:

Code:
kern.vty=vt


Installed drm-kmod:

# pkg install drm-kmod

In my /etc/rc.conf I have:

Code:
kld_list="/boot/modules/i915kms.ko"
dbus_enable="YES"
hald_enable="YES"
moused_enable="YES"


I double checked and I have the i915kms module in that path.

Then I attempted to install XFCE:

Code:
# pkg install xfce


Then I changed to my user, and updated my .xinitrc:

Code:
$ echo ". /usr/local/etc/xdg/xfce4/xinitrc" > ~/.xinitrc


Now when I run:

Code:
$ startx


I get this:

Image.jpeg


So I manually set the XDF_CONFIG_DIRS to /usr/local/etc and I double checked that xfce4-session is installed and it is.

However, xconfd isn't running. In fact, I find nothing called xconfd on my system or in the package manager. It's not mentioned in the Handbook. Is this what's causing my issue? Does anybody know how I might go about fixing it?

Thanks.
 

mjollnir

Daemon

Reaction score: 835
Messages: 1,267

You could try sysutils/desktop-installer or sysutils/mkdesktop. To access the webcam, you user must also be in the webcamd group. kern.vty=vt is default anyway. Did you service dbus start & service hald start? Standard disclaimer:
  • install the docs: pkg install {de,en}-freebsd-doc, replace de with your native tongue, and point your favorite browser to /usr/local/share/doc/freebsd.
  • You can add to the ALIAS section of /usr/local/etc/pkg.conf message: "query '[%C/%n] %M'",, read through all pkg message|less and apply the requested settings.
  • Instead of less(1), you may find sysutils/most more user-friendly. Beginners will prefer edit(1) or editors/nano instead of vi(1).
 

decuser

Active Member

Reaction score: 50
Messages: 174

[USER=58399]parski[/USER] I'm using a T430 and I used to run XFCE - here are sections of some of my files, from back then, that are relevant:

Code:
/boot/loader.conf
drm.i915.semaphores=1
drm.i915.intel_iommu_enabled=1
drm.i915.enable_rc6=7
hint.p4tcc.0.disabled=1
hint.acpi_throttle.0.disabled=1
hw.psm.synaptics_support="1"


and

Code:
/etc/rc.conf
kld_list="/boot/modules/i915kms.ko /boot/kernel/acpi_ibm.ko /boot/kernel/cuse.ko"
moused_enable="YES"
dbus_enable="YES"
hald_enable="YES"
webcamd_enable="YES"


Code:
.xinitrc
exec /usr/local/bin/startxfce4 --with-ck-launch


My package list at the time was:
sudo pkg install cups-filters xorg xfce xfce4-goodies xfce4-whiskermenu-plugin xfce4-volumed-pulse xfce4-pulseaudio-plugin xfce-evolution xfce-icons-elementary python py27-dbus system-config-printer noto

I don't remember why I used all of them, but I include them here as potential help, but YMMV. I'll do an install and see if I can get it working, too.

Update: I have it working on my T430, now, so hopefully I can give you better current info.
 

mjollnir

Daemon

Reaction score: 835
Messages: 1,267

The drm.i915 are gone, these are now sysctl compat.linuxkpi
[USER=58399]parski[/USER] Please tell which freebsd-version you're uising.
 
OP
parski

parski

New Member

Reaction score: 3
Messages: 9

The drm.i915 are gone, these are now sysctl compat.linuxkpi
[USER=58399]parski[/USER] Please tell which freebsd-version you're uising.
I'm using 12.1-RELEASE r354233 with the GENERIC kernel. Fresh install. Sorry, I should have mentioned that.

[Edit]

Just updated to 12.1-RELEASE p10. Still have the same issue.

[Edit 2]

I'm trying the desktop-installer now. Apparently this machine has an Nvidia GF108M (NVS 5400M). I don't have high hopes for getting that working though but I'm giving it a shot.
 

Misirca

New Member

Reaction score: 1
Messages: 8

Does the problem persists if
  • you just startxfce4
  • you use a one-liner .xinitrc like suggered above?
Code:
.xinitrc:
exec /usr/local/bin/startxfce4 --with-ck-launch

or
Code:
.xinitrc:
exec xfce4-session
 
OP
parski

parski

New Member

Reaction score: 3
Messages: 9

Does the problem persists if
  • you just startxfce4
  • you use a one-liner .xinitrc like suggered above?
Code:
.xinitrc:
exec /usr/local/bin/startxfce4 --with-ck-launch

or
Code:
.xinitrc:
exec xfce4-session
Yes, I've tried all of the above. Exact same issue.
 

Misirca

New Member

Reaction score: 1
Messages: 8

Hmmm.
This is unlikely a driver issue since you got a graphical output.

Do you get the same result with startxfce4 as a different user or as root?

Might be a permission problem or a corrupted ~/.config/ or ~/.cache/ ?
Code:
mv ~/.config ~/.config-old
mv ~/.cache ~/.cache-old


Code:
chown -R yourusername:yourusername ~
 
OP
parski

parski

New Member

Reaction score: 3
Messages: 9

Hmmm.
This is unlikely a driver issue since you got a graphical output.

Do you get the same result with startxfce4 as a different user or as root?

Might be a permission problem or a corrupted ~/.config/ or ~/.cache/ ?
Code:
mv ~/.config ~/.config-old
mv ~/.cache ~/.cache-old


Code:
chown -R yourusername:yourusername ~
I will try this soon. The desktop-installer changed a so many things on my system and borked my resolution so I'm just doing a clean install and trying again.
 
OP
parski

parski

New Member

Reaction score: 3
Messages: 9

I reinstalled FreeBSD and did the exact steps as I wrote in the first post. Now it works flawlessly. I have no idea what happened there, I have never had that issue before. Thanks for the help, guys.
 
Top