Printer on Router connected via USB


My printer is connected to my router via USB. From my lapttop, with Ubuntu, I can print on him, without a problem. So I configure cups on my FreeBSD Server and wanted to print something. But the printer just makes some noise, like he is going to print, but then stops.
lpstat -p -d
printer printer is idle.  enabled since Sun Apr 24 21:49:48 2016
Waiting for printer to finish. system default destination: printer

Where printer is the name of my printer.

Even if I turn the printer off, there is no change of the status.

Inside of the error log I didn't find anything that's wrong but this
D [24/Apr/2016:21:59:11 +0200] [Client 82] HTTP_STATE_WAITING Closing for error 32 (Broken pipe)
Some printers process the print job using manufacturer supplied code (aka Binary Blobs). Canon, Brother and Samsung supply drivers that have been built for linux systems but not BSD systems. If this is the case, it can sometimes be worked around. Can you provide the make/model of your printer?
According to print/splix your printer should be supported and this would be the best solution.

There also appear to be 2 additional options if the FreeBSD splix port does not work.

Option 1: Run the binary blob with linux emulation as described in the NetBSD howto.

Option 2: Try the foo2zjs drivers as described here.
In order to trouble shoot your configuration settings will need to be posted and the cups error logs reviewed. I would recommend trying to troubleshoot the native splix port first.
Ok, after I reinstalled Splix, configured Cups and installed cups-filter, I can print with /usr/local/bin/lpr pdf-test.pdf. So its solved. Thank you!